Nowe posty

Autor Wątek: Problwem z instalacją  (Przeczytany 1641 razy)

lesiulodz

  • Gość
Problwem z instalacją
« dnia: 2006-12-09, 10:07:17 »
Mam problem z instalacją paczki gtk 2.10.6 (oczywiście tar.gz), pow wpisaniu ./configure dostaję taką wiadomość:

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.12.0    atk >= 1.9.0    pango >= 1.12.0    cairo >= 1.2.0) were not met:

Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

czyli nie mam paczki atk, ściągnąłem ją (wersja 1.10.3 tar.gz) wpisuje ./configure i dostaję komunikat:

checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.12.4, but GLIB (2.6.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.12.4, but GLIB (2.6.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

ściągam gliba (wersja 2.12.4 tar.gz) instaluje go i chcę wgrać znowu atk ale dostaję komunikat :

checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.12.4, but GLIB (2.6.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.12.4, but GLIB (2.6.4)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

z tego co widze to chyba mam jakąś starą wersję i instalator się kłuci, co mam zrobić by wgrać atk ?
mam debian3-sarge1 na kernelu  2.4.27-3-386


jk33

  • Gość
Problwem z instalacją
« Odpowiedź #1 dnia: 2006-12-09, 10:52:18 »
2006-12-09 10:07:17 lesiulodz napisał:
> (oczywiście tar.gz)
Czy o paczkach .deb Kolega słyszał?
apt-get?
aptitude?

lesiulodz

  • Gość
Problwem z instalacją
« Odpowiedź #2 dnia: 2006-12-09, 12:51:43 »
tak słyszałem ale nie ma tam tego czego potrzebuje, albo gdy coś znajde to wyskakuje komunikat że nie mogą być zainstalowane (oczywiście na roocie)

jk33

  • Gość
Problwem z instalacją
« Odpowiedź #3 dnia: 2006-12-10, 15:25:31 »
Z tego co patrzyłem na stronie Debiana,
jest gtk+-2.10.x w repozytoriach.
Nie wydaje mi się, żebyś potrzebował
nowszego.

Kaka

  • Gość
Problwem z instalacją
« Odpowiedź #4 dnia: 2006-12-10, 15:29:36 »
Masz to co każdy Debianowiec lubi najbardziej - niespełnione zależności. Daj se spokój, bo i tak dużo nie zdziałasz (no chyba, że naprawdę Cię nie doceniam :p). Weź może przejdź na testing lub sida (polecam sida - sam mam).


Pozdrawiam!