Nowe posty

Autor Wątek: Problemy z rpm - ami  (Przeczytany 1314 razy)

AndrzejGTex

  • Gość
Problemy z rpm - ami
« dnia: 2006-11-23, 12:45:42 »
Nie rozumiem o co chodzi.
W Fedora6 , ale i w dawniejszych RH, mam problemy z rpm-ami:
Po instalacji  
 - rpm -ivh AdobeReader_enu-7.0.8-1.i386.rpm  
wynik operacji ok, ale adobe nie działa.
Chcę go odinstalować
 - rpm -e AdobeReader_enu-7.0.8-1.i386.rpm
        błąd: pakiet AdobeReader_enu-7.0.8-1.i386.rpm nie jest zainstalowany
To samo z opcją
 - rpm -e  --nodeps AdobeReader_enu-7.0.8-1.i386.rpm
Ale jeśli wykonam
 - rpm -Uvh AdobeReader_enu-7.0.8-1.i386.rpm
     Przygotowywanie...          ###########################################          
       [100%]
          pakiet AdobeReader_enu-7.0.8-1 jest już zainstalowany
lub
 - rpm -e --force AdobeReader_enu-7.0.8-1.i386.rpm
    rpm: tylko instalację, uaktualnienie i usuwanie źródeł można wymusić
Nie pomaga    
 - rpm --rebuilddb
O CO CHODZI?!
Andrzej G

TheUsh

  • Gość
Problemy z rpm - ami
« Odpowiedź #1 dnia: 2006-11-23, 13:13:52 »
2006-11-23 12:45:42 AndrzejGTex napisał:

> Nie rozumiem o co chodzi.
 > W Fedora6 , ale i w dawniejszych RH, mam problemy z rpm-ami:
 > Po instalacji  
 >  - rpm -ivh AdobeReader_enu-7.0.8-1.i386.rpm  
 > wynik operacji ok, ale adobe nie działa.
 > Chcę go odinstalować
 >  - rpm -e AdobeReader_enu-7.0.8-1.i386.rpm
 >         błąd: pakiet AdobeReader_enu-7.0.8-1.i386.rpm nie jest zainstalowany
 > To samo z opcją
 >  - rpm -e  --nodeps AdobeReader_enu-7.0.8-1.i386.rpm

przy opcji -e (usuwanie) nie podajemy calej nazwy rpm'a z numerem wersji i rozszerzeniem tylko nazwe programu w tym przypadku musisz podac tylko AdobeReader albo AdobeReader_enu

 > Ale jeśli wykonam
 >  - rpm -Uvh AdobeReader_enu-7.0.8-1.i386.rpm
 >      Przygotowywanie...          ###########################################          
 >        [100%]
 >           pakiet AdobeReader_enu-7.0.8-1 jest już zainstalowany
 > lub
 >  - rpm -e --force AdobeReader_enu-7.0.8-1.i386.rpm
 >     rpm: tylko instalację, uaktualnienie i usuwanie źródeł można wymusić
 > Nie pomaga    
 >  - rpm --rebuilddb
 > O CO CHODZI?!
 > Andrzej G
 >