Nowe posty

Autor Wątek: Irda, panasonic CF-35 i slackware...  (Przeczytany 19923 razy)

Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #15 dnia: 2005-08-26, 16:16:02 »
2005-08-26 15:42:35 chmooreck napisał:

> daj no sekcje dotyczaca driverow do grafiki z .config\\'a jadra...
 > jaka masz architekture procesora ? (tzn x86, czy amd64 ?)

i686

# Graphics support
#
CONFIG_FB=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_SOFT_CURSOR=y
# CONFIG_FB_MACMODES is not set
CONFIG_FB_MODE_HELPERS=y
# CONFIG_FB_TILEBLITTING is not set
# CONFIG_FB_CIRRUS is not set
# CONFIG_FB_PM2 is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_ASILIANT is not set
# CONFIG_FB_IMSTT is not set
CONFIG_FB_VGA16=y
CONFIG_FB_VESA=y
CONFIG_VIDEO_SELECT=y
# CONFIG_FB_HGA is not set
# CONFIG_FB_NVIDIA is not set
# CONFIG_FB_RIVA is not set
# CONFIG_FB_I810 is not set
# CONFIG_FB_INTEL is not set
# CONFIG_FB_MATROX is not set
# CONFIG_FB_RADEON_OLD is not set
# CONFIG_FB_RADEON is not set
# CONFIG_FB_ATY128 is not set
# CONFIG_FB_ATY is not set
# CONFIG_FB_SAVAGE is not set
# CONFIG_FB_SIS is not set
# CONFIG_FB_NEOMAGIC is not set
# CONFIG_FB_KYRO is not set
# CONFIG_FB_3DFX is not set
# CONFIG_FB_VOODOO1 is not set
# CONFIG_FB_TRIDENT is not set
# CONFIG_FB_PM3 is not set
# CONFIG_FB_GEODE is not set
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_VIRTUAL is not set

#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
# CONFIG_MDA_CONSOLE is not set
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
# CONFIG_FONTS is not set
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y

# Logo configuration
#
CONFIG_LOGO=y
CONFIG_LOGO_LINUX_MONO=y
CONFIG_LOGO_LINUX_VGA16=y
CONFIG_LOGO_LINUX_CLUT224=y
# CONFIG_BACKLIGHT_LCD_SUPPORT is not set

Dziękuję za zainteresowanie problemem
olka

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #16 dnia: 2005-08-26, 17:26:48 »
podejrzewam, ze chodzi mu o VGA16, ale podam ci wszystkie roznice w porownaniu z moja konfiguracja... (u mnie chodzi ;-) )

 # CONFIG_FB_MODE_HELPERS is not set
 # CONFIG_FB_VGA16 is not set

sprobuj.. moze akurat ;-)

Offline Franciszek Raś

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 213
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #17 dnia: 2005-08-26, 17:53:27 »
2005-08-26 15:33:05 olka napisał:

> 2005-08-26 10:54:57 Frank napisał:
 >
 > > To ze nie działa Ci polecenie:
 >  > vga=cyferki
 >  > też wcześniej zauważyłem i dlatego proponowałem Ci polecenie:
 >  > vga=ask
 >
 > Hmm... może ja sie nie znam, ale co za różnica czy ja wpiszę vga= ask i uzyskam komunikat:
 > \\"Press return to see video mode\\" (czy jakoś mniej więcej tak) czy uzyskam ten
 > komunikat po vga=jakiś_tryb (You choose undefined mode number. Press return to see...).
 >
 > Dla porządku zrobiłam jak kolega radził, no i oczywiście mam tylko tryby tekstowe :
 >
 > Dzięki za zainteresowanie. Jeśli są jeszcze jakieś pomysły do przetestowania, jestem
 > zainteresowana :)
 >
 > pozdrawiam
 > olka

Nie napisałaś jakie masz te tryby; u mnie są:
ask, normal i ext. Służą one tylko do wyświetlania startu, a późniejsza praca zależy od ustawień w xorg.conf, chyba że Ty używasz tylko konsoli.

Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #18 dnia: 2005-08-26, 18:51:41 »
2005-08-26 17:26:48 chmooreck napisał:

 >  # CONFIG_FB_MODE_HELPERS is not set
 >  # CONFIG_FB_VGA16 is not set
 >
 > sprobuj.. moze akurat ;-)

ehh i znowu kompilacja :), dzięki wielkie, wieczorem zapuszczę i zobaczymy co z tego wyjdzie...

2005-08-26 17:53:27 Frank napisał:

 > Nie napisałaś jakie masz te tryby; u mnie są:
 > ask, normal i ext. Służą one tylko do wyświetlania startu, a późniejsza praca zależy od
 > ustawień w xorg.conf, chyba że Ty używasz tylko konsoli.

Dzięki ogromne za zainteresowanie, ale chyba nie bardzo mówimy o tym samym
Primo rozchodzi sie o odświeżanie dla framebuffera i xorg nie ma tu nic do rzeczy (poza tym, że sterowniki mogą się \\"gryźć\\", ale wtedy \\"ofiarą\\" ;) i tak będą x-y a nie konsola) - w srodowisku graficznym mam 1024x768 i 85Hz i to działa
Secundo: wydawało mi się, że piszę jasno, że mam tylko tryby tekstowe, więc przepraszam (dla autora post zawsze jest jasny i zrozumiały ;-).
Nie zaleznie jak do tego dojdę, zawsze mam do wyboru jedynie:
0 0F00 80x28
1 0F01 80x50
2 0F02 80x43
3 0F03 80x28
4 0F04 80x30
5 0F05 80x34
6 0F06 80x60

dziękuję wszystkim i pozdrawiam
olka

Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #19 dnia: 2005-08-26, 21:18:42 »
2005-08-26 17:26:48 chmooreck napisał:

> podejrzewam, ze chodzi mu o VGA16, ale podam ci wszystkie roznice w porownaniu z moja
 > konfiguracja... (u mnie chodzi ;-) )
 >
 >  # CONFIG_FB_MODE_HELPERS is not set
 >  # CONFIG_FB_VGA16 is not set
 >
 > sprobuj.. moze akurat ;-)

okazało się, że akurat nie bardzo :D -  teraz w ogóle nie działa framebuffer (w sekcji nt grafiki nie zmieniałam nic innego niż w/w)
# fbset
open /dev/fb0: No such file or directory
no i poza tym nie ma pingwinka ;-)

ehh, i znowu rekompilacja :
(a skoro już i tak rekompiluję, to może wrzucić jakieś inne sterowniki ? Na tym kernelu sterów invidii do x-ów nie posiadam, bo rozsypywały mi konsolę, więc gryźć się nic nie będzie)

dzięki za pomoc
olka



Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #20 dnia: 2005-08-26, 22:32:47 »
 > okazało się, że akurat nie bardzo :D -  teraz w ogóle nie działa framebuffer (w sekcji nt
 > grafiki nie zmieniałam nic innego niż w/w)
 > # fbset
 > open /dev/fb0: No such file or directory
 > no i poza tym nie ma pingwinka ;-)

a to przedtem mialas fb, tylko nie takie odswiezanie tak ?

czyli wszystko ok :-)

vesafb wlasnie matakie odswiezanie do...

zainteresuj sie projektem vesafb-tng
jest to nowy sterownik do vesafb... (zreszta naszego rodaka ;-) )
pozwala ponoc w wiekszym stopniu sterowac ustawieniami konsoli - osobiscie nie probowalem, bo jest tylko dla x86 (a ja jestem szczesliwym posiadaczem amd64)

aaa.. i na przyszlosc nie wyrzucaj starych jajek, dopoki nie bedziesz miala wersji, ktora cie satysfakcjonuje i dziala stabilnie... oszczedzisz sobie sporo czasu ;-)

Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #21 dnia: 2005-08-26, 22:42:52 »
2005-08-26 22:32:47 chmooreck napisał:

 > a to przedtem mialas fb, tylko nie takie odswiezanie tak ?
 
Dokładnie tak, co z resztą zaznaczyłam w pierwszym poście :-)

 > czyli wszystko ok :-)
 >
 > vesafb wlasnie matakie odswiezanie do...
 >

zastanawia mnie tylko czemu nie mam żadnych trybów \\"graficznych\\" dla vga, przeciez powinny działać, chociaż te niższe rozdzielczości, a ja nic tylko tekstowe :|

 > zainteresuj sie projektem vesafb-tng
 > jest to nowy sterownik do vesafb... (zreszta naszego rodaka ;-) )
 > pozwala ponoc w wiekszym stopniu sterowac ustawieniami konsoli - osobiscie nie probowalem,

dzięki, nie omieszkam

 > aaa.. i na przyszlosc nie wyrzucaj starych jajek, dopoki nie bedziesz miala wersji, ktora cie
 > satysfakcjonuje i dziala stabilnie... oszczedzisz sobie sporo czasu ;-)

az tak źle to ze mną nie jest :). oczywiście, ze mam stare jądro :), tylko - jeśli można przy okazji taki mały offtopic :D - słyszałam, ze przy rekompilacji jądra nadpisywane są kompilowane moduły, no i nie wiem jak to jest. Czyli nie musze rekompiolowac? :D

dzięki za pomoc
olka

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #22 dnia: 2005-08-26, 23:12:47 »
> az tak źle to ze mną nie jest :). oczywiście, ze mam stare jądro :), tylko - jeśli można przy
 > okazji taki mały offtopic :D - słyszałam, ze przy rekompilacji jądra nadpisywane są kompilowane
 > moduły, no i nie wiem jak to jest. Czyli nie musze rekompiolowac? :D
 >

sa nadpisywane przy instalacji...
1. jesli nie zmieniasz modulow (tzn kompilujesz za kazdym razem te same) to mozesz ich uzywac ponownie (nie robisz make modules_install)
2. jesli masz rozne modult, to mozesz zrobic make modules && make modules_install - zawsze to krocej niz kompilowanie calego jadra
3. najlepsze (moim zdaniem) wyjscie (w konfigueacji jadra):
General setup  ---> Local version - append to kernel release
i masz wtedy unikalna wersje jadra - i dla niej beda trzymane osobno moduly w /lib/modules


Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #23 dnia: 2005-08-26, 23:22:32 »
2005-08-26 23:12:47 chmooreck napisał:

 > 3. najlepsze (moim zdaniem) wyjscie (w konfigueacji jadra):
 > General setup  ---> Local version - append to kernel release
 > i masz wtedy unikalna wersje jadra - i dla niej beda trzymane osobno moduly w /lib/modules

właśnie tego mi brakowało :D, wielkie dzięki

a jakby ktoś, coś, fb +geforce i w ogóle, bedę wdzięczna ;-)

pozdrawiam
olka

Offline Leszek Drogosz

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 12
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #24 dnia: 2005-08-28, 11:17:09 »
2005-08-26 23:22:32 olka napisał:

> 2005-08-26 23:12:47 chmooreck napisał:
 >
 >  > 3. najlepsze (moim zdaniem) wyjscie (w konfigueacji jadra):
 >  > General setup  ---> Local version - append to kernel release
 >  > i masz wtedy unikalna wersje jadra - i dla niej beda trzymane osobno moduly w
 > /lib/modules
 >
 > właśnie tego mi brakowało :D, wielkie dzięki
 >
 > a jakby ktoś, coś, fb +geforce i w ogóle, bedę wdzięczna ;-)
 >
 > pozdrawiam
 > olka
 >
Dobra. ja używam Slacka 10.1, kernel 2.6.12.5 oraz GF4 mx (a pozatym słucham metalu i jestem do wzięcia ;->).

Odnośnie nvdidia fb - nie używać. Vesa całkowicie wystarczy, niemal wszystkie karty obecnie są kompatybilne z tym standardem.

Zacznijmy od tego że w źródłach kernela 2.6 jest dokumentacja do vesa fb (/Documentation/fb/vesafb.txt jeśli się nie myle). Odświeżanie chwilowo jest stale i wynosi 60Hz dla konsoli (można zamotać; jak mi się uda, to opisze co i jak)

Opcje kernela które trzeba wybrać dla wsparcia innych trybów to kolejno:
support for frame buffer devices FB
VESA VGA graphics support
VGA text console (jak się coś spapra to jest text mode)
Framebuffer Console support
Select compiled-in console fonts
VGA 8x16 font

I to na tyle z jądrem. Teraz wyedytowac lilo.conf:
[...]
# VESA framebuffer console @ 1024x768x64k(przykladowo)
vga = 791
[...]
W slackware jest narzedzie liloconfig, tam można znaleźć wszystkie tryby vesafsb.

Pozdrawiam.

Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #25 dnia: 2005-09-02, 17:54:20 »
2005-08-28 11:17:09 mordimmer napisał:

 > Dobra. ja używam Slacka 10.1, kernel 2.6.12.5 oraz GF4 mx (a pozatym słucham metalu i jestem do
 > wzięcia ;->).

A to się chyba nie najlepiej składa, bo ja preferuję muzyke klasyczną ;-)
a tak na poważnie,

 >Odświeżanie chwilowo jest stale i wynosi
 > 60Hz dla konsoli
Hmm... chwilowo? z tego co się wywiedziałam to nie wygląda to na sprawę przejściową, poza tym praca przy takim odświeżaniu w trybie graficznym grozi ślepotą ;)

 > Opcje kernela które trzeba wybrać dla wsparcia innych trybów to kolejno:
 > support for frame buffer devices FB
 > VESA VGA graphics support
 > VGA text console (jak się coś spapra to jest text mode)
 > Framebuffer Console support
 > Select compiled-in console fonts
 > VGA 8x16 font
 
Ustawiłam dokładnie to, co kolega radził i d...
FB nie działa
open /dev/fb0: No such file or directory

---------------------------------------

ogólnie rzecz ujmując utknęłam w martwym punkcie, pomimo przeczytania dokumentacji do fb, wielu z dostępnych manuali (slackware, gentoo, debian), a także wypowiedzi na róznych nie tylko slackowych forach pod kątem fb i tej karty oraz tylokrotnej rekompilacji jądra, ze już przestałam liczyć :D. Pozostaje tylko rwać włosy z głowy albo iść na wieczorny spacer...

Uzyskane wnioski:
Slackware 10.1 + 2.6.12.3
*vesa (sama)
nie działa fb
*vesa +fb_vga16
fb działa, ale tylko na VGA16
(Frame buffer device information:
    Name        : VGA16 VGA)
    nie można ustawić trybu pracy przez vga=jakiś_tryb_graficzny, mimo, że zgodny z zawartością fb.modes
    -zawsze: undefined mode number, a dla vga=ask tylko tryby tekstowe
*vesa + VGA16 +riva(jako moduł)    
 j/w (wyczytałam, że sterownik dla fb musi być wkompilowany w jądro, bo fb jest uruchamiane przed załadowaniem modułów, nie wiem czy to prawda, ale tłumaczyłoby dlaczego działa na vga a nie rivie)
 *riva (sama)
 nie działa fb
 *nvidia (sama)
 działa fb ale nie można ustawić domyślnie trybu dla wszystkich konsoli przez lilo- uruchamia sie w trybie domyslnym dla vesy: 640x480-60 (można zmienić ręcznie przez fbset)

Najdziwniejsze jest dla mnie jednak co poniżej (może czegoś nie wiem i dlatego się dziwię :D)
Archlinux
   +2.6.12.3
*fb_nvidia
fb działa, ale tylko w 640x480-60 (co można zmienić przez fbset)

    +2.6.12
*vesa(sama)  - config identyczny jak w przypadku slacka
fb działa i to domyślnie w trybie 800x600-75 ! Minus: ekran przesunięty jest dość znacznie w prawo (co oczywiscie da sie skorygowac recznie za pomocą fbset)
Frame buffer device information:
    Name        : VESA VGA
a jak w lilo pojawi się jakikolwiek zapis vga=... (np vga=ask) to w podpowiedziach ukazują sie tylko tryby tekstowe a sterownikiem fb jest VGA16 :
Frame buffer device information:
    Name        : VGA16 VGA
a w .configu TEGO kernela stoi:
# CONFIG_FB_VGA16 is not set  

Skopiowanie w/w kernela do slacka(chciałam mieć absolutną pewnośc co do identyczności uruchamianego kernela) skutkuje uruchomieniem fb na sterowniku VGA16

-------------------

Skoro nie udało mi się uzyskać zadawalajacych rozdzielczości na wszystkich konsolach przez wpis w lilo, próbowalam ustawić to przez odpowiednie wpisy w różnych skryptach:

1.)Dopisanie do /etc/inittab (testowane zarówno w slacku jak i archlinuxie)
fb:2345:wait:/usr/sbin/fbset -a 1024x768-75
co opatrzone było komentarzem na stronce, z której to wyczytałam:
\\"Success! My virtual terminals all run at a nice resolution\\"
niestety, ten zapis ustawił mi jedynie parametry dla pierwszej konsoli, co więcej, nie znalazłam w manualu do fbset żadnej opcji -a (czy też sugerowanej w innych poradach wersji --all)
2.)Spróbowałam więc łopatologicznie
fb1:2345:wait:/usr/sbin/fbset 1024x768-75 tty1
fb2:2345:wait:/usr/sbin/fbset 1024x768-75 tty2
...
fb6:2345:wait:/usr/sbin/fbset 1024x768-75 tty6

efekt: jak wcześniej

2.)Trochę przez zmałpowanie, próbowałam ustawić to w rc.local, kierując się skryptem ustawiającym numlocka na wszystkich konsolach
echo \\"Ustawiam parametry framebuffera\\"
for i in 1 2 3 4 5 6 ; do
/usr/sbin/fbset 800x600-75/dev/null
done
ale efekt: jak wcześniej
z tym, że to była akurat moja własna radosna twórczośc ;), więc i nie dziwota, że nie działa. (Testowane tylko na slacku, bo w archu, z uwagi na troche inna strukturę i nazewnictwo urządzeń w ogóle się skrypt wysypywał bo nie umiałam poprawnie odwołać się do odpowiednich konsoli)

Pukając do różnych drzwi uzyskałam najróżniejsze porady, włącznie z  odpowiedzią od jednego użytkownika fb na GF400, że najłatwiej zwalić winę na sterowniki/linuxa zamiast samemu poszukać rozwiązania, ale to już by musiało sugerować totalny debilizm z mojej strony, jeśli po tylu różnych próbach nie mogę uruchomić fb w satysfakcjonujący sposób.

Dziękuję wszystkim za dobre chęci i próbę pomocy,
pozdrawiam
olka

PS Mam nadzieję, że tak długa wypowiedź nie zostanie uznana za forumowy spam :D. A jeśli, to bardzo przepraszam.

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #26 dnia: 2005-09-02, 18:04:34 »
2005-09-02 17:54:20 olka napisał:
 
 > j/w (wyczytałam, że sterownik dla fb musi być wkompilowany w jądro, bo fb jest uruchamiane przed załadowaniem modułów, nie wiem czy to prawda, ale tłumaczyłoby dlaczego działa na vga a nie rivie)

No, ja tak mam. Masz mój fragment configa (sekcja dot. FB):
#
# Frame-buffer support
#
CONFIG_FB=y
CONFIG_DUMMY_CONSOLE=y
CONFIG_FB_LOGO_POWEREDBY=y
CONFIG_FB_VESA=y
CONFIG_VIDEO_SELECT=y
CONFIG_FBCON_SPLASHSCREEN=y
CONFIG_FBCON_CFB16=y
CONFIG_FBCON_CFB8=y
CONFIG_FBCON_CFB16=y
CONFIG_FBCON_CFB24=y
CONFIG_FBCON_CFB32=y
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y

Wkleiłem tylko te, w których zaznaczyłem na \\'yes\\', pozostałe są na \\'no\\', cztli \\'... is not set\\'. Używam kernela 2.4 ze splashscreenem.

 > PS Mam nadzieję, że tak długa wypowiedź nie zostanie uznana za forumowy spam :D. A jeśli, to
 > bardzo przepraszam.

Przynajmniej piszesz na temat. Na ogół tak długie posty to flame\\'y ;)

Podziwiam Twój upór i szkoda mi Ciebie, że tak się męczysz, a mi - wprawdzie na Rivie (ale to jeden pies chyba) udało się odpalić fb bez absolutnie żadnego kłopotu.

Mam takie pytanie kontrolne: czy różne LiveCD (np. to z gentoo) uruchamiają Ci domyślnie fb w dużej rozdzielczości?

Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #27 dnia: 2005-09-02, 19:03:06 »
2005-09-02 18:04:34 xis napisał:

 > No, ja tak mam. Masz mój fragment configa (sekcja dot. FB):
 (...)
 > Używam kernela 2.4 ze splashscreenem.

 Z jądrem 2.4 dałam sobie spokój na samym początku, po tym, jak po ściągnięciu źródeł kernela  już w momencie rozpakowywania pojawił się error (o ile dobrze pamiętam niespójność czegoś tam, bardzo przepraszam, ale to było dość dawno i nie pamiętam :D), ale po niezwykle ułatwiajacej życie poradzie kolegi Chmooreck\\'a (jeszcze raz ogromne podziękowania), jak skompilować ponownie to samo jądro bez nadpisania modułów, chyba przekompiluję zgodnie z Twoimi wskazówkami kernela którego \\"nabyłam\\" z dystrybucją, chociaż muszę przyznać, że jestem już raczej sceptyczna :D

 > (...) mi - wprawdzie na Rivie (ale to
 > jeden pies chyba) udało się odpalić fb bez absolutnie żadnego kłopotu.

Nie wiem jak to jest, ale wszystkim się to udaje :-(
 
 > Mam takie pytanie kontrolne: czy różne LiveCD (np. to z gentoo) uruchamiają Ci domyślnie fb w
 > dużej rozdzielczości?

Jeśli chodzi o liveCD to posiadam tylko Knoppixa i świeżo sprawdzone:
jeśli uruchamiam go na domyślnym jądrze 2.4 to pojawia mi się komunikat (skąd inąd dobrze znany...)  \\"You passed an undefined mode number...\\" i w podpowiedziach mam - oczywiście - tylko tryby tekstowe dla VESA VGA. Nie muszę chyba nadmieniać, że to nie JA wybrałam błędny tryb, tylko został on zdefiniowany na starcie Knoppixa. System uruchamia sie bez framebuffera

Jeśli wybiorę inne z dostępnych jąder:
boot: fb800x600
system uruchamia się z fb trybie 800x600-75 na sterowniku VESA VGA
innych trybów nie testowałam.

Jeśli miałoby to pomóc przetestuję inne liveCD (tylko w tem celu muszę ję ściągnąć :D)

dzięĸi ogromne
olka

Offline Aleksandra Brzezińska

  • Users
  • Guru
  • *****
  • Wiadomości: 776
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #28 dnia: 2005-09-02, 20:55:57 »
2005-09-02 18:04:34 xis napisał:
>(...) Masz mój fragment configa (sekcja dot. FB):
 > #
 > # Frame-buffer support
 > #
 > CONFIG_FB=y
 > CONFIG_DUMMY_CONSOLE=y
 > CONFIG_FB_LOGO_POWEREDBY=y
 > CONFIG_FB_VESA=y
 > CONFIG_VIDEO_SELECT=y
 > CONFIG_FBCON_SPLASHSCREEN=y
 > CONFIG_FBCON_CFB16=y
 > CONFIG_FBCON_CFB8=y
 > CONFIG_FBCON_CFB16=y
 > CONFIG_FBCON_CFB24=y
 > CONFIG_FBCON_CFB32=y
 > CONFIG_FONT_8x8=y
 > CONFIG_FONT_8x16=y
 >
 > Wkleiłem tylko te, w których zaznaczyłem na \\'yes\\', pozostałe są na \\'no\\', cztli \\'... is not
 > set\\'. Używam kernela 2.4 ze splashscreenem.
 
No więc zrobiłam TO ;-), już mi się nie chciało jak ... bo to chyba 5 kompilacja jądra od wczoraj :D. Ustawiłam dokładnie j/w z pominięciem
> CONFIG_FB_LOGO_POWEREDBY=y
> CONFIG_FBCON_SPLASHSCREEN=y
(rozumiem, że to od patcha splashscreen\\'owego, bo u mnie nie było takich opcji w .configu)

Niestety, fb nie działa :-( , open /dev/fb0: No such device

Obejrzałam sobie przy okazji domyślnego konfiga (tego od jądra, które dostałam gratis z dystrybucją ;) no i tam niby też jest wkompilowana obsługa fb, Vesa VGA jako * i cała masa modułów, ale fb oczywiście nigdy nie działał.

Tak a propos: pisałeś, że uruchamiasz fb na rivie, a z konfiga wynika, że na VESIE ? (jakby nie było ani na samej vesie, ani na samej rivie u mnie pod slackiem nie działa - jak już pisałam, na samej vesie działa tylko pod archlinuxem)

A tak na marginesie w związku z tematem chociaż nie wiem czy ma jakieś znaczenie, ale przypomniałao mi się właśnie:
kiedyś, na samym początku używania linuxa (czyli jakies pół roku temu :) na mdk 10.0 miałam straszny problem z konsolą (tą prawdziwą, nie pseudo, pod x-ami), czciona na pół ekranu, zamazana i zero odświeżania - konsoli, nie monitora (przy zamykaniu systemu, kiedy to przez ekran \\"przesuwają się\\" komunikaty o zamykaniu poszczególnych usług itp u mnie się to nakładało jedno na drugie i widać było tylko rozpikselizowany na biało ekran, istna ekspresja ;) i pamiętam, że na pewno pomógł wpis do lilo vga=792 - dokładnie taki, systemu już dawno nie mam ale wydruk lilo.conf się zachował ... - aczkolwiek może inny też odniósłby skutek, wtedy nie sprawdzałam, umierając ze strachu na samą myśl, że mam \\"przeładować lilo\\" ;-)
Po tym zabiegu starsznie upaciana na na biało konsola zamieniła się w normalną, \\"straszną czarną konsolę\\" ;), ale straciłam bootsplasha (graficzne lilo pozostało). Czy był w tym momencie fb trudno mi powiedzieć, wtedy nie miałam nawet pojęcia co to takiego :D

pozdrawiam
olka

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
Irda, panasonic CF-35 i slackware...
« Odpowiedź #29 dnia: 2005-09-02, 21:38:48 »
> Tak a propos: pisałeś, że uruchamiasz fb na rivie, a z konfiga wynika, że na VESIE ? (jakby nie

mysle, ze chodzilo o typ karty graficznej - przynajmniej ja to tak zrozumialem ;-)

 > A tak na marginesie w związku z tematem chociaż nie wiem czy ma jakieś ( ...ciach...)
 > czarną konsolę\\" ;), ale straciłam bootsplasha (graficzne lilo pozostało). Czy był w tym
 > momencie fb trudno mi powiedzieć, wtedy nie miałam nawet pojęcia co to takiego :D

tak, to byla konsola na fb

osobiscie odpalalem u siebie fb na riva tnt2 m64 (jadra od 2.6.5 do 2.6.9) i na 6600gt (od 2.6.9 do 2.6.12) - nie mialem zadnych problemow z vesafb... jak chcesz mojego calego configa (z patchami gentoo), to daj znac na maila - podesle (nie bede przeciez zasmiecal forum ;-) )