Nowe posty

xx Strona o testach penetracyjnych, hackingu (20)
2021-11-28, 20:39:47
xx Przydatne Linki (11)
2021-11-18, 01:50:23
xx Lekka przeglądarki (4)
2021-11-13, 10:58:18
xx Przejście z iptables na nftables. Serwer z DNS i VPN... (0)
2021-11-12, 11:20:40
xx SSH (5)
2021-11-11, 09:11:41
xx audio debian problem (12)
2021-11-09, 12:01:43
xx czyszczenie systemu (31)
2021-11-07, 14:41:26
xx Jak przekierować port (1)
2021-11-06, 09:52:44
xx kdenlive nie chce się uruchomić (14)
2021-10-29, 08:38:52
xx Aktualizacja Ubuntu 20.4 do 21.10. Kmail nie zapisuje haseł (10)
2021-10-28, 16:48:20

Autor Wątek: gentoo - brak cd-rom'u  (Przeczytany 24391 razy)

  • Gość
gentoo - brak cd-rom'u
« dnia: 2006-11-16, 23:50:19 »
Witam,
Mam problem w linuxie gentoo. System nie widzi cd-romu, a co mało, komendy na mount'a nie pomagają. W programie konqueror pisze, że cd-rom jest odmontowany. Przy próbie komendą:
mount -t vfat /dev/cdrom /mnt/cdrom
otrzymuję:
 mount: special device /dev/cdrom does not exist
a stosując:
mount -t vfat /dev/hdc /mnt/cdrom
otrzymuję:
mount: /dev/hdc is not a valid block device
Macie jakieś pomysły? Trochę niewygodnie korzystać z systemu bez zewnętrznego nośnika danych... ;-)


chmooreck

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #1 dnia: 2006-11-17, 07:07:05 »
jaką płytkę masz w napędzie ?

gomath

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #2 dnia: 2006-11-17, 16:10:27 »
2006-11-16 23:50:19 _elvis_ napisał:


 > Macie jakieś pomysły?

Nie wiem jak nazywa się plik w /dev dowiązany do Twojego cdromu, ale prawdopodobnie powinieneś użyć opcji '-t iso9660' zamiast '-t vfat' :)


  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #3 dnia: 2006-11-21, 21:29:04 »
powinieneś
 > użyć opcji '-t iso9660' zamiast '-t vfat' :)
 
Spróbowałem tego co mówiłeś, ale wtedy nic się niedzieje, tylko otrzymuje wiadomość z bash'a o możliwych opcjach tzn. :
Usage: mount -V                 : print version
       mount -h                 : print this help
       mount                    : list mounted filesystems
       mount -l                 : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
       mount device             : mount device at the known place
       mount directory          : mount known device here
       mount -t type dev dir    : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using  -L label  or by uuid, using  -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say  man 8 mount .

a po opcji mount -t iso9660 /dev/cdrom /mnt/cdrom
otrzymałem komunikat, że:
mount: special device /dev/cdrom does not exist

Nie działa dla żadnej płyty, sprawdzałem dla płyt z muzyką, danymi i ciągle to samo...

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #4 dnia: 2006-11-21, 21:51:31 »
2006-11-16 23:50:19 _elvis_ napisał:

> Witam,
 > Mam problem w linuxie gentoo. System nie widzi cd-romu, a co mało, komendy na mount'a nie
 > pomagają. W programie konqueror pisze, że cd-rom jest odmontowany. Przy próbie komendą:
 > mount -t vfat /dev/cdrom /mnt/cdrom
 > otrzymuję:
 >  mount: special device /dev/cdrom does not exist
 > a stosując:
 > mount -t vfat /dev/hdc /mnt/cdrom
 > otrzymuję:
 > mount: /dev/hdc is not a valid block device
 > Macie jakieś pomysły? Trochę niewygodnie korzystać z systemu bez zewnętrznego nośnika danych...
 > ;-)
 >
 >
 > A nie jest to montowane w /media a nie w /dev ?
 > Jeśli instalowaleś gentoo korzystając z instalatora (a nawet i z palca tylko z genkernelem) to najpewniej tak masz.

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #5 dnia: 2006-11-21, 23:41:44 »
 >  > A nie jest to montowane w /media a nie w /dev ?
 >  > Jeśli instalowaleś gentoo korzystając z instalatora (a nawet i z palca tylko z
 > genkernelem) to najpewniej tak masz.

Raczej nie ma takiej opcji żeby tak było, bo nawet nie istnieje katalog media. A gentoo był instalowany z wiersza poleceń... Poza tym montowane dyski są przechowywane w katalogu mnt.

Offline Robert

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2516
    • Zobacz profil
gentoo - brak cd-rom'u
« Odpowiedź #6 dnia: 2006-11-22, 00:10:04 »
Pierdyknij tu swojego fstaba, moze się coś wymyśli.

P.S.
Sam instalowałeś gentoo?
Zanim popełnisz grafomaństwo: 1 | 2 | 3
Baza RPM Jak szukać informacji

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #7 dnia: 2006-11-22, 07:09:14 »
2006-11-21 23:41:44 _elvis_ napisał:
 
 > Raczej nie ma takiej opcji żeby tak było, bo nawet nie istnieje katalog media. A gentoo był
 > instalowany z wiersza poleceń... Poza tym montowane dyski są przechowywane w katalogu mnt.
 >
 >
 > A masz coś takiego jak hal i dbus ?

greg000

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #8 dnia: 2006-11-22, 17:42:32 »
A tak z ciekawosci sie zapytam masz wogole w katalogu /dev urzadzenie cdrom ? Bo z tego co widze to dostajesz komunikat ze nie ma takiego czegos. Sprawdz jakie masz urzadzenia dostepne w /dev. Jezeli np twoj cdrom jest na master slave to powinien byc dostepny pod /dev/hdc. Zreszta mozesz zobaczyc co pokazuje dmesg, napoczatku powinno pisac jak zostal wykryty cdrom i inne dyski.

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #9 dnia: 2006-11-26, 21:42:26 »
2006-11-22 17:42:32 greg000 napisał:

> A tak z ciekawosci sie zapytam masz wogole w katalogu /dev urzadzenie cdrom ? Bo z tego co widze
 > to dostajesz komunikat ze nie ma takiego czegos. Sprawdz jakie masz urzadzenia dostepne w /dev.
 > Jezeli np twoj cdrom jest na master slave to powinien byc dostepny pod /dev/hdc. Zreszta mozesz
 > zobaczyc co pokazuje dmesg, napoczatku powinno pisac jak zostal wykryty cdrom i inne dyski.
 
greg000 chyba trafiłeś... w dev'ie nie mam nic co by przypominało cd rom. to samo jest w dmesg - niema ani jednej linijki związanej z cdrom'em. więc to teraz proponujesz?

greg000

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #10 dnia: 2006-11-26, 22:33:04 »
Napisz na jakim kanale masz wpiety cdrom.

g-dreamer

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #11 dnia: 2006-11-27, 23:48:39 »
#dmesg |grep hd.
u mnie cdrom wyglada tak:
hdd: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, DMA

hda - primary master
hdb - primary slave
hdc -
hdd - secondary slave

robisz dowiazanie symboliczne:
#cd /dev
#ln -s /dev/hdx cdrom     - gdzie hdx to Twoj cdrom
montujesz:
#mount -t iso9660 /dev/hdx /mnt/cdrom
albo po utworzeniu symlinka:
#mount -t iso9660 /dev/cdrom /mnt/cdrom
Poczytaj też o pliku /etc/fstab.

chmooreck

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #12 dnia: 2006-11-28, 07:46:52 »
2006-11-26 21:42:26 _elvis_ napisał:

 > w dev'ie nie mam nic co by przypominało cd rom. to samo jest w dmesg
 > - niema ani jednej linijki związanej z cdrom'em. więc to teraz proponujesz?

proponuje załadować moduł obsługujący kontroler IDE (skoro dmesg nic nie pisze o cdrom'ie)

Edit:
P.S. być może nie skompilowałes modułu do obsługi twojego kontrolera IDE, w tym wypadku nie musisz przekompilowywać całego jajka, wystarczy zaznaczyć jako moduł i przekompilować same moduły (make modules && make modules_install)

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #13 dnia: 2006-11-30, 22:29:24 »
2006-11-26 22:33:04 greg000 napisał:

> Napisz na jakim kanale masz wpiety cdrom.

greg000 - nie bardzo rozumiem co masz na myśli mówiąc na którym kanale??

danielk

  • Gość
gentoo - brak cd-rom'u
« Odpowiedź #14 dnia: 2006-12-02, 17:41:39 »
Witam,
mam identyczny problem w Mandrivie 2006.
Brak CDROMu: special device /dev/hda does not exist.
W katalogu "dev" nie mam ani podkatalogu "cdrom", ani "hda".
W "dmesg" nie ma słowa o CDROMie.
W BIOSie cdrom mam jako ide master. Na płycie głównej taśma wpięta do ATA. Przy starcie komputera pojawia się komunikat:
Autodetecting Primary Master Atapi Cdrom.
CHMOORECK pisał coś o kontrolerach IDE lub kompilacji modułów, możecie napisać coś więcej?
P.S.
Aha, jestem elektrykiem a nie informatykiem, więc jeśli moglibyście lekko łopatologicznie to byłbym bardzo wdzięczny!
Pozdrawiam
Daniel