Nowe posty

xx Debian 9 Stretch, linuxcnc i restart przy uruchamianiu (1)
Wczoraj o 11:09:50
xx Zakup sprzętu bez preinstalowanego windowsa (8)
2019-10-17, 16:50:51
xx Problem z pocztą Dovecot+Postfix+MySQL (3)
2019-10-16, 14:43:41
xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
2019-10-15, 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36
xx Problem z instalacją sterowników TL-WN821N (4)
2019-10-11, 23:15:00
xx Sprzet z Linuxem (1)
2019-10-11, 10:06:24
xx nadpisanie partycji domowej (6)
2019-10-03, 03:27:28
xx Screen flickering Deepin (4)
2019-10-02, 20:32:56

Autor Wątek: miganie w wygaszaczach opengl (nvidia)  (Przeczytany 8376 razy)

Offline Adam Szemraj

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 44
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« dnia: 2005-07-06, 23:34:59 »
mam mandrive le 2005. i mam kolejny problem :D
a mianowicie chodzi o to ze nie wylacza sie :P tzn gdy leci pasek wylaczania to pod koniec sie zatrzymuje. jest napisane ze naciskajac esc pokaza sie dodatkowe informacje itd... jest na to jakies \\"lekarstwo\\"???

Offline Jakub Guzik

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #1 dnia: 2005-07-07, 11:16:32 »
2005-07-06 23:34:59 adamski89 napisał:

> mam mandrive le 2005. i mam kolejny problem :D
 > a mianowicie chodzi o to ze nie wylacza sie :P tzn gdy leci pasek wylaczania to pod koniec sie
 > zatrzymuje. jest napisane ze naciskajac esc pokaza sie dodatkowe informacje itd... jest na to
 > jakies \\"lekarstwo\\"???

Napisz w jakim momencie sie zatrzymują te \\"OK\\" (tzn przy jakiej fukcji)

Offline Adam Szemraj

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 44
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #2 dnia: 2005-07-07, 15:52:14 »
> Napisz w jakim momencie sie zatrzymują te \\"OK\\" (tzn przy jakiej fukcji)
 >

no zatrzymuje sie po komunikacie ze wylaczono dysk ... zhaltowano system. ale sam komputer nie chce sie wylaczyc.

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #3 dnia: 2005-07-07, 16:45:02 »
2005-07-07 15:52:14 adamski89 napisał:

>  > Napisz w jakim momencie sie zatrzymują te \\"OK\\" (tzn przy jakiej fukcji)
 >  >
 >
 > no zatrzymuje sie po komunikacie ze wylaczono dysk ... zhaltowano system. ale sam komputer nie
 > chce sie wylaczyc.

Zainstaluj program \\"acpid\\" i być może będziesz musiał dopisać do lilo/grub (odpowiednio pole append i kernel) wpis \\"acpi=on\\". Jeżeli masz starszy komputer, który nie wspiera ACPI, to może konieczne będzie zainteresowanie się APM.

Offline Adam Szemraj

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 44
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #4 dnia: 2005-07-07, 23:15:06 »
> Zainstaluj program \\"acpid\\" i być może będziesz musiał dopisać do lilo/grub
 > (odpowiednio pole append i kernel) wpis \\"acpi=on\\". Jeżeli masz starszy komputer,
 > który nie wspiera ACPI, to może konieczne będzie zainteresowanie się APM.

no acpid zainstalowalem. dalej sie nie wylacza. prosilbym o dokladniejszy opis tego dopisywania w lilo/grub. no bo jak narazie to nie bardzo wiem o co chodzi :D

pozdro

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #5 dnia: 2005-07-08, 09:37:08 »
2005-07-07 23:15:06 adamski89 napisał:


 > no acpid zainstalowalem. dalej sie nie wylacza. prosilbym o dokladniejszy opis tego dopisywania
 > w lilo/grub. no bo jak narazie to nie bardzo wiem o co chodzi :D
 >
 > pozdro

Lilo nie posiadam wiec nie pomogę. Zdaje się, że w /etc/lilo.conf w opcjach jadra, w polu \\"append\\" dopisujesz: acpi=on.

W Grub jest tak:

W /boot/grub/menu.lst dopisujesz \\"acpi=on\\" tak jak na przykładzie:

title      Debian GNU/Linux, kernel 2.4.27-2-k7
root      (hd0,5)
kernel      /boot/vmlinuz-2.4.27-2-k7 root=/dev/hda6 ro hdb=ide-scsi acpi=on
initrd      /boot/initrd.img-2.4.27-2-k7
savedefault
boot

Ponadto (po restarcie) zobacz czy po wydaniu polecenia lsmod (jako root) zobaczysz miedzy innymi coś podobnego (dla jadra 2.6.12.2):

thermal                13512  0
fan                     4548  0
button                  6608  0
processor              17380  1 thermal
ac                      4804  0
battery                10116  0

--
Maciek

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #6 dnia: 2005-07-08, 09:54:27 »
jak masz lilo, to nie zapomnij go przeladowac (tzn. uruchomic lilo) po zmianie konfiguracji...

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #7 dnia: 2005-07-08, 10:48:09 »
2005-07-08 09:54:27 chmooreck napisał:

> jak masz lilo, to nie zapomnij go przeladowac (tzn. uruchomic lilo) po zmianie konfiguracji...

Właśnie, dzięki za przypomnienie :-)

Offline Adam Szemraj

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 44
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #8 dnia: 2005-07-08, 22:15:19 »
tylko ze ja tu mam trzy pola append w pliku lilo.conf :image=/boot/vmlinuz
   label=\\"linux\\"
   root=/dev/hdd6
   initrd=/boot/initrd.img
   append=\\"acpi=ht resume=/dev/hdd7 splash=silent\\"
   vga=788
   read-only
image=/boot/vmlinuz
   label=\\"linux-nonfb\\"
   root=/dev/hdd6
   initrd=/boot/initrd.img
   append=\\"acpi=ht resume=/dev/hdd7\\"
   read-only
image=/boot/vmlinuz
   label=\\"failsafe\\"
   root=/dev/hdd6
   initrd=/boot/initrd.img
   append=\\"failsafe acpi=ht resume=/dev/hdd7 devfs=nomount\\"
   read-only
other=/dev/hdd1
   label=\\"windows\\"
   table=/dev/hdd
...
nie chce niczego rozwalic. w sumie to moglbym we wszystkich wpisac ale sie pytam dla pewnosci :P

Offline Adam Szemraj

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 44
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #9 dnia: 2005-07-08, 22:20:39 »
a tak w ogole to jak mam wlaczyc lilo w linuxie. chodiz o to zeby po prostu zrestartowac go? czy co? no bo nie rozumiem [poczatkujacy w 100procentach :P wiec nie nasmiewac sie]

Offline Remigiusz Witkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #10 dnia: 2005-07-08, 22:33:44 »
demon \\" acpid\\"
mcc - lilo - włącz ACPI
bios - włącz - acpi
i będzie grało...
 mcc to ....centrum sterowania mdk...

Offline Adam Szemraj

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 44
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #11 dnia: 2005-07-09, 00:27:13 »
ale jak mam zrestartowac LILO? ...
w mmc klikalem przy acpi na uruchom ale nic sie nie dzialo :| ...

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #12 dnia: 2005-07-09, 11:19:35 »
2005-07-08 22:15:19 adamski89 napisał:

> tylko ze ja tu mam trzy pola append w pliku lilo.conf :image=/boot/vmlinuz
 >    label=\\"linux\\"
 >    root=/dev/hdd6
 >    initrd=/boot/initrd.img
 >    append=\\"acpi=ht resume=/dev/hdd7 splash=silent\\"

Zmień na:

append=\\"acpi=on resume=/dev/hdd7 splash=silent\\"

 >    vga=788
 >    read-only
 > image=/boot/vmlinuz
 >    label=\\"linux-nonfb\\"
 >    root=/dev/hdd6
 >    initrd=/boot/initrd.img
 >    append=\\"acpi=ht resume=/dev/hdd7\\"
 >    read-only
 > image=/boot/vmlinuz
 >    label=\\"failsafe\\"
 >    root=/dev/hdd6
 >    initrd=/boot/initrd.img
 >    append=\\"failsafe acpi=ht resume=/dev/hdd7 devfs=nomount\\"
 >    read-only
 > other=/dev/hdd1
 >    label=\\"windows\\"
 >    table=/dev/hdd
 > ...
 > nie chce niczego rozwalic. w sumie to moglbym we wszystkich wpisac ale sie pytam dla pewnosci
 > :P

Na koniec wpisz w konsoli jako root polecenie \\"lilo\\"

I już

No i oczywiście restart systemu :-)

--
Maciek

Offline Andrzej Kruk

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 20
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #13 dnia: 2005-07-09, 19:54:22 »
Tyle pisania o nic!!!
W centrum sterowania kliknij \\"uruchamianie\\" następnie
\\"konfiguracja sposobu uruchamiania systemu\\" zaznacz pierwszą opcję czyli \\"włączanie ACPI\\" kliknij dalej i \\"zakończ\\"
Zrestaruj komputer i po sprawie.
Jeśli w biosie jest opcja ACPI też musi byc uruchomiona.

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 337
    • Zobacz profil
miganie w wygaszaczach opengl (nvidia)
« Odpowiedź #14 dnia: 2005-07-06, 23:21:55 »
witam. nie wiem dlaczego migają mi niektóre wygaszacze pisane w oparciu o OpenGL. Dodatkowo niektóre gry nie wykrywają akceleracji graficznej.

Mam kartę riva128 na następujących ustawieniach:
    Identifier  "riva128"
    Driver      "nvidia"
    Option   "RenderAccel"
    Option   "HWcursor"
    Option   "NvAGP"   "1"

kompletnie nie wiem dlaczego mi miga....

mogę prosic o Waszą pomoc?