Nowe posty

xx Sensowny podział partycji (2)
Dzisiaj o 16:03:14
xx Programy antywirusowe - gdzie mają zastosowanie (8)
Dzisiaj o 15:49:24
question rDNS i directadmin (0)
Wczoraj o 15:59:15
xx Edycja pliku tekstoego (1)
Wczoraj o 09:27:03
xx Teraz a kiedyś (3)
2019-02-21, 20:24:05
xx modem od dostawcy (1)
2019-02-21, 19:52:56
xx Postfix jako SMTP Proxy (1)
2019-02-13, 17:01:01
xx Zabezpieczenie przed nieautoryzowanym serwerem DHCP (2)
2019-02-13, 16:24:09
xx Kompilacja kernela. (6)
2019-02-07, 12:08:41
xx Od jakiego linuxa zacząć (1)
2019-02-06, 14:53:46

Autor Wątek: runlevel 1 ??????????nie rozumiem  (Przeczytany 6172 razy)

Offline Marcin K

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« dnia: 2005-07-06, 13:20:49 »
Witam
Wszedłem w posiadanie starego notebook\\'a CA 4400 (konfiguracja jak w tytule). Jest na nim zainstalowany windows95 ale zarządznie procesami trwa b.długo. Stąd planuje przesiadkę na linuksa. Prawdopodobnie najlepszym wyborem będzie gentoo lub puppy linuks.
Moje pytanie: czy na tym sprzcie, z którąś z powyższych distro, możliwe będzie sprawne działanie na jakimkolwiek menadzerze okien (może byc nawet twm)?
Jakie menadzery proponujecie?

Offline Jakub Guzik

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #1 dnia: 2005-07-06, 18:29:54 »
2005-07-06 13:20:49 etilen napisał:

> Witam
 > Wszedłem w posiadanie starego notebook\\'a CA 4400 (konfiguracja jak w tytule). Jest na nim
 > zainstalowany windows95 ale zarządznie procesami trwa b.długo. Stąd planuje przesiadkę na
 > linuksa. Prawdopodobnie najlepszym wyborem będzie gentoo lub puppy linuks.
 > Moje pytanie: czy na tym sprzcie, z którąś z powyższych distro, możliwe będzie sprawne
 > działanie na jakimkolwiek menadzerze okien (może byc nawet twm)?
 > Jakie menadzery proponujecie?

Według mnie najlepszy system na taką maszyne to Slackware Linux. A co do środowiska graficznego to albo Xfce albo IceWM. Radze zacząc sprawdzanie od pierwszego, dopiero jak nie pujdzie radze spróbowac IceWM

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #2 dnia: 2005-07-05, 23:07:48 »
instarowałem już z dwa razy sterowniki nvidi i zawsze dobrze było
teraz mam mandrejka 10.2 i wyskakuje mi taki komunikat którego nie rozumiem.prosił bym wskrócie o objeśnienie   :"You appear to be running in runlevel 1; this may cause problems.For example: some distributions that use devfs do not run the devfs daemon in runlevel 1, making it difficult for 'nvidia-installer' to correctly setup the kernel module configuration files.It is recommended that you quit installation now and switch to run runlevel 3 ('telinit 3' )before installing.
Quit installation now??    "

prosze o wytłumaczenie ,z góry dziękuje.

Offline Marcin Maćczak

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 235
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #3 dnia: 2005-07-05, 23:19:35 »
plumka sie, ze masz uruchomiony system w trybie single, czyli bez zadnych dodatkowych programow uruchomionych, bez dostepu do sieci itp. jest to tryb do naprawiania system. chce zebys uruchomil system na runlevel 3 wpisz tak jak mowi
telinit 3
i jeszcze raz odpal instalatora to powinien smigac

pozdrawiam
Maciasz

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #4 dnia: 2005-07-06, 11:54:25 »
2005-07-05 23:19:35 maciasz napisał:

> plumka sie, ze masz uruchomiony system w , czyli bez zadnych dodatkowych programow
 > uruchomionych, bez dostepu do sieci itp. jest to tryb do naprawiania system. chce zebys
 > uruchomil system na runlevel 3 wpisz tak jak mowi
 > telinit 3
 > i jeszcze raz odpal instalatora to powinien smigac
 >
 > pozdrawiam
 > Maciasz
 >
>>>>>>>>>>>>>><<<<<<<<<<<<<<<<<<<<>>>>>>>>>>>>>>
dzienki serdecznie faktycznie miałem uruchomiony trybie single.mam teraz jeszcze jeden problem ,wyskakuje mi jescze taki komuniat (pierwszy taki):No precompiled kernel iinterface was found to match your kernel; this means that theinstaller will need to compile a new kernel interace."
 moim skromnym zdaniem wynika z niedo żemusze zainstalować nowszy kernel
Nastę
 daje ok i pokazuje mi sie drugi komunikat :"WARNING: Your kernel was configured to include rivafb support as a loadable kernel module."
ej juz sam niewiem co ja mam zrobić prosze o pomoc

Offline tom kobi

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #5 dnia: 2005-07-06, 14:00:10 »
"WARNING: Your kernel was configured to
 > include rivafb support as a loadable kernel module."

Miałem to samo, pewnie trzeba ponownie zkompilować kernel, ale mozna to ominąć instalując sterowniki dla nvidii w wersji 1.0-7667. W tej wersji nie mojawia się ten błąd.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #6 dnia: 2005-07-06, 17:01:14 »
2005-07-06 14:00:10 tomasz_kob napisał:

> "WARNING: Your kernel was configured to
 >  > include rivafb support as a loadable kernel module."
 >
 > Miałem to samo, pewnie trzeba ponownie zkompilować kernel, ale mozna to ominąć instalując
 > sterowniki dla nvidii w wersji 1.0-7667. W tej wersji nie mojawia się ten błąd.
<<<<<<<<<<<<<>>>>>>>>>>>>>>>>><<<<<<<<<<<<<>>>

to nie wina wersji sterowników bo ściągnołem tą co poradziłeś i wersje z 2004 roku i wyskakują te same komunikaty.jak zminić wersje kernela ---chyba o to chodzi
w mandraku 10 instalowało sie bez problemu a przy wersji10.2 takie jaja.plissssssssssss pomocy

Offline de Laurent

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1197
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #7 dnia: 2005-07-06, 19:30:53 »
No precompiled kernel interface was found to match your kernel; this means that theinstaller will need to compile a new kernel interace."
moim skromnym zdaniem wynika z niedo żemusze zainstalować nowszy kernel

Otoz nie. Chodzi o to, ze nie znalazl skompilowanego wczesniej interfejsu do kernela, wiec musi sobie skompilowac nowy, pasujacy do twojego jajka...

Tutaj chodzi o to, ze ster nvidii nie moze dzialac ze sterem rivafb, ktory to masz wkompilowany w jadro. Musisz sie zdecydowac ktory chcesz wybrac. Najlepiej byloby gdybys skompilowal swoje wlasne jajko, ew. jezeli mozesz zainstalowac ster nvidii, to zadbaj o to, zeby modul rivafb nie ladowal sie przy starcie...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #8 dnia: 2005-07-06, 21:19:43 »
 > Otoz nie. Chodzi o to, ze nie znalazl skompilowanego wczesniej interfejsu do kernela, wiec musi
 > sobie skompilowac nowy, pasujacy do twojego jajka...
 >
 > Tutaj chodzi o to, ze ster nvidii nie moze dzialac ze sterem rivafb, ktory to masz wkompilowany
 > w jadro. Musisz sie zdecydowac ktory chcesz wybrac. Najlepiej byloby gdybys skompilowal swoje
 > wlasne jajko, ew. jezeli mozesz zainstalowac ster nvidii, to zadbaj o to, zeby modul rivafb nie
 > ladowal sie przy starcie...


*******//*****///****///****///**/////******//////**********

ach to dobrze to teraz musze zainstalować jądro -najlepiej pewnie jakieś nowsze.to kurcze bede musiał na forum poszukać jak to zrobić bo jeszcze tego nie robiłem-kagbyście mogli to możecie mi stronke podrzucić  krok po kroku ,dzienki

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #9 dnia: 2005-07-06, 21:32:41 »
 > Nastę
 >  daje ok i pokazuje mi sie drugi komunikat :"WARNING: Your kernel was configured to
 > include rivafb support as a loadable kernel module."

ludzie.. czy wy nie umiecie czytac ? to jest WARNING czyli OSTRZEŻENIE i to o tym, ze modul rivafb zostal skompilowany jako MODUL, a nie wkompilowany w jadro

z mojego punktu widzenia powinienes dac tu OK, kompilacja powinna przejsc i wszystko bedzie dobrze, tylko nie laduj modulu rivafb...

Offline Jakub Guzik

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #10 dnia: 2005-07-06, 21:34:45 »
2005-07-06 21:19:43 bober77 napisał:

>
 >  > Otoz nie. Chodzi o to, ze nie znalazl skompilowanego wczesniej interfejsu do kernela,
 > wiec musi
 >  > sobie skompilowac nowy, pasujacy do twojego jajka...
 >  >
 >  > Tutaj chodzi o to, ze ster nvidii nie moze dzialac ze sterem rivafb, ktory to masz
 > wkompilowany
 >  > w jadro. Musisz sie zdecydowac ktory chcesz wybrac. Najlepiej byloby gdybys skompilowal
 > swoje
 >  > wlasne jajko, ew. jezeli mozesz zainstalowac ster nvidii, to zadbaj o to, zeby modul
 > rivafb nie
 >  > ladowal sie przy starcie...
 >
 >
 > *******//*****///****///****///**/////******//////**********
 >
 > ach to dobrze to teraz musze zainstalować jądro -najlepiej pewnie jakieś nowsze.to kurcze bede
 > musiał na forum poszukać jak to zrobić bo jeszcze tego nie robiłem-kagbyście mogli to możecie
 > mi stronke podrzucić  krok po kroku ,dzienki


po pierwsze musisz odszukac na płytkach lub zassac z neta pakiet rpm o nazwie kernel-source pozniej według artykułu którego bedziesz uzywał (najlepiej wpisz w googlach "kompilacja jądra linuxa" i wybieerz dla siebie najlepszy artykuł :P ) odszukaj tylko funkcje związaną z sterownikiem i odznacz. Jądro bedziesz miał praktycznie to samo co wczesniej (o ile sciągniesz lub zainstalujesz zródła zgodne z tym numerem jądra jakiego uzywasz ) tylko bez tego jednego stera. Pozniej dzięki zainstalowanym zródłom bedziesz mógł bez problemu instalnąc stery NVIDII (dzięki nim nie wyskoczy ten "pierwszy błąd ;)" )

Offline Jakub Guzik

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 116
    • Zobacz profil
runlevel 1 ??????????nie rozumiem
« Odpowiedź #11 dnia: 2005-07-06, 21:36:29 »
w sumie moj poprzednik ma racje z tym modułem, nie trzeba kompilowac jądra ale źródła musisz zainstalowac :D:D:D