Nowe posty

xx Przy uploadzie przerywane są wszystkie połączenia (9)
Dzisiaj o 20:13:01
xx Apache2 i twarde https (3)
2020-05-25, 15:53:43
xx Czy istnieje emulator terminala który zapamieta komendy na jakiejś liście? (9)
2020-05-23, 17:04:57
xx RTLinux wybór dystrybucji (0)
2020-05-23, 15:42:54
xx Problem z instalacją Ubuntu na bootowalnym pendrajwie (9)
2020-05-22, 15:08:12
xx Ubuntudde 20.04 LTS nie działa Lightdm (8)
2020-05-22, 09:16:42
xx [Gra za darmo] GTA5 (1)
2020-05-20, 21:49:26
xx Marketing (1)
2020-05-13, 08:00:41
xx Polecenia Debian (1)
2020-05-10, 19:58:54
xx Uruchamianie pliku z każdego katlogu (2)
2020-05-10, 19:23:33

Autor Wątek: [mysql] kodowanie pliterek  (Przeczytany 7866 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 32
    • Zobacz profil
[mysql] kodowanie pliterek
« dnia: 2006-09-08, 21:06:10 »
Mam niemały problem z odtwarzaniem tego filmiku http://www.torun.mm.pl/~g2/cap.wmv  Obraz jest a dźwięku ni chusteczki. Mam zainstalowane chyba wszystkie znane mi zestawy kodeków i nic. Ciekawe jest również to że nie mogę tego odtworzyć również pod windozą- ten sam efekt. Mój kolega od którego \\"toto\\" przegrałem odtwarza bez problemu. Może ktoś wie co za diabeł mi w tym przeszkada.

Offline heniek m.

  • Users
  • Guru
  • *****
  • Wiadomości: 697
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #1 dnia: 2006-09-08, 22:47:19 »
2006-09-08 21:06:10 kleszek napisał:

> Mam niemały problem z odtwarzaniem tego filmiku http://www.torun.mm.pl/~g2/cap.wmv  Obraz jest a
 > dźwięku ni chusteczki. Mam zainstalowane chyba wszystkie znane mi zestawy kodeków i nic. Ciekawe
 > jest również to że nie mogę tego odtworzyć również pod windozą- ten sam efekt. Mój kolega od
 > którego \\"toto\\" przegrałem odtwarza bez problemu. Może ktoś wie co za diabeł mi w tym
 > przeszkada.

Zainteresuj sie ffmpeg (libavcodec).

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 32
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #2 dnia: 2006-09-09, 03:38:50 »
2006-09-08 22:47:19 zebra napisał:

> 2006-09-08 21:06:10 kleszek napisał:
 >
 > > Mam niemały problem z odtwarzaniem tego filmiku http://www.torun.mm.pl/~g2/cap.wmv  Obraz
 > jest a
 >  > dźwięku ni chusteczki. Mam zainstalowane chyba wszystkie znane mi zestawy kodeków i nic.
 > Ciekawe
 >  > jest również to że nie mogę tego odtworzyć również pod windozą- ten sam efekt. Mój kolega
 > od
 >  > którego \\"toto\\" przegrałem odtwarza bez problemu. Może ktoś wie co za diabeł mi
 > w tym
 >  > przeszkada.
 >
 > Zainteresuj sie ffmpeg (libavcodec).
 >
mam to zainstalowane

Offline heniek m.

  • Users
  • Guru
  • *****
  • Wiadomości: 697
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #3 dnia: 2006-09-09, 06:55:08 »
Odpal odtwarzacz w konsoli, najlepiej
gmplayer scieszka/do/filmu

moze wtedy wyczytasz co jest nie tak.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 32
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #4 dnia: 2006-09-09, 17:49:44 »
2006-09-09 06:55:08 zebra napisał:

> Odpal odtwarzacz w konsoli, najlepiej
 > gmplayer scieszka/do/filmu
 >
 > moze wtedy wyczytasz co jest nie tak.
konsola wypluwa mi coś takiego:
MPlayer dev-CVS-051220-04:08-4.0.1 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Celeron 4 Northwood; Pentium 4 EE/Xeon Prestonia,Gallatin (Family: 15, Stepping: 7)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.



89 audio & 203 video codecs
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding \\"echo 1024 > /proc/sys/dev/rtc/max-user-freq\\" to your system startup scripts.
Opening joystick device /dev/input/js0
Can\\'t open joystick device /dev/input/js0: No such file or directory
Can\\'t init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing /home/leszek/media:/hdd/cap.wmv.
nie wiem jak do tego podejść i nic nie rozumiem

Offline heniek m.

  • Users
  • Guru
  • *****
  • Wiadomości: 697
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #5 dnia: 2006-09-09, 21:05:14 »
2006-09-09 17:49:44 kleszek napisał:

> 2006-09-09 06:55:08 zebra napisał:
 >
 > > Odpal odtwarzacz w konsoli, najlepiej
 >  > gmplayer scieszka/do/filmu
 >  >
 >  > moze wtedy wyczytasz co jest nie tak.
 > konsola wypluwa mi coś takiego:
 > MPlayer dev-CVS-051220-04:08-4.0.1 (C) 2000-2005 MPlayer Team
 > CPU: Intel Pentium 4/Celeron 4 Northwood; Pentium 4 EE/Xeon Prestonia,Gallatin (Family: 15,
 > Stepping: 7)
 > CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
 > Compiled with runtime CPU detection - WARNING - this is not optimal!
 > To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
 >
 >
 >
 > 89 audio & 203 video codecs
 > Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
 > Try adding \\"echo 1024 > /proc/sys/dev/rtc/max-user-freq\\" to your system startup
 > scripts.
 > Opening joystick device /dev/input/js0
 > Can\\'t open joystick device /dev/input/js0: No such file or directory
 > Can\\'t init input joystick
 > Setting up LIRC support...
 > mplayer: could not connect to socket
 > mplayer: No such file or directory
 > Failed to open LIRC support.
 > You will not be able to use your remote control.
 > Playing /home/leszek/media:/hdd/cap.wmv.
 > nie wiem jak do tego podejść i nic nie rozumiem

No dobra, ale interesujące dane są niżej, więc przewiń i wklej całośc. To o joysticku mozna olać.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 32
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #6 dnia: 2006-09-10, 07:08:39 »
> No dobra, ale interesujące dane są niżej, więc przewiń i wklej całośc. To o joysticku mozna
 > olać.
 >
OK dalej jest to, sorki nie tego nie  wkleiłem
Trying to force audio codec driver family dmo...
Opening audio decoder: [dmo] Win32/DMO decoders
======= WAVE Format =======
Format Tag: 353 (0x161)
Channels: 2
Samplerate: 44100
avg byte/sec: 8005
Block align: 1487
bits/sample: 16
cbSize: 10
Unknown extra header dump:
  • [88]
  • [f]
  • [79] [2e]

===========================
======= WAVE Format =======
Format Tag: 1 (0x1)
Channels: 2
Samplerate: 44100
avg byte/sec: 176400
Block align: 4
bits/sample: 16
cbSize: 0
===========================
GetOutput r=0x0   size:16384  align:1
StreamCount r=0x0  1  1
AUDIO: 44100 Hz, 2 ch, s16le, 64,0 kbit/4,54% (ratio: 8005->176400)
Selected audio codec: [wmadmo] afm: dmo (Windows Media Audio DMO)
==========================================================================
==========================================================================
Trying to force video codec driver family realvid...
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:230400  align:1
StreamCount r=0x0  1  1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 320 x 240 (preferred colorspace: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 320x240 => 320x240 Planar YV12  [zoom]
Selected video codec: [wmv9dmo] vfm: dmo (Windows Media Video 9 DMO)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
Starting playback...

Offline heniek m.

  • Users
  • Guru
  • *****
  • Wiadomości: 697
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #7 dnia: 2006-09-10, 13:32:27 »
2006-09-10 07:08:39 kleszek napisał:


 > ===========================
 > GetOutput r=0x0   size:16384  align:1
 > StreamCount r=0x0  1  1
 > AUDIO: 44100 Hz, 2 ch, s16le, 64,0 kbit/4,54% (ratio: 8005->176400)
 > Selected audio codec: [wmadmo] afm: dmo (Windows Media Audio DMO)
 > ==========================================================================
 > ==========================================================================


 
==========================================================================
 > Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
 > AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
 > Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
 > Starting playback...
 >

Nie widzi ffmpeg, na dmo nie da rady.
Albo xle zainstalowany ffmpeg albo brak bibliotek libffmpeg. Powinieneś mieś w usr/lib plik libavcodec.so.0, jesli nie ma to doinstaluj wspomniane biblioteki.

Powodzenia.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 32
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #8 dnia: 2006-09-10, 16:30:11 »
 > Nie widzi ffmpeg, na dmo nie da rady.
 > Albo xle zainstalowany ffmpeg albo brak bibliotek libffmpeg. Powinieneś mieś w usr/lib plik
 > libavcodec.so.0, jesli nie ma to doinstaluj wspomniane biblioteki.
 >
 > Powodzenia.
 
Biblioteki oczywiście mam, przeinstalowałem ffmpeg-a i dalej nic. Moze potrzebne jakieś dowiązania? Nawet nie wiedziałem że jeszcze jestam taki zielony.

Offline Robert

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2505
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #9 dnia: 2006-09-10, 20:43:49 »
Jak już ci nic nie pomoże, to wypróbuj GeexBoxa. On sobie na pewno poradzi.
Zanim popełnisz grafomaństwo: 1 | 2 | 3
Baza RPM Jak szukać informacji

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 32
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #10 dnia: 2006-09-11, 08:54:44 »
2006-09-10 20:43:49 roca napisał:

> Jak już ci nic nie pomoże, to wypróbuj GeexBoxa. On sobie na pewno poradzi.
No i dalej kiszka. GeexBox też nie pomógł. Wychodzi nato że coś z tym plikiem jest nie tak, ale miałem go z różnych źródeł więc sam już nie wiem. Zazwyczaj wszystkie wmv otwieram a tu przykra niespodzianka, ani linux ani windows. Nie wiem jakim cudem u kolegi to chodzi.Sprawdzę jeszcze na innym sprzęcie. Jeśli to rozgryzę oczywiście o tym napiszę. Dzięki wszystkim za zainteresowanie i chęć pomocy.

Offline Matthias Kunka

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #11 dnia: 2006-09-22, 21:39:31 »
2006-09-11 08:54:44 kleszek napisał:

> 2006-09-10 20:43:49 roca napisał:
 >
 > > Jak już ci nic nie pomoże, to wypróbuj GeexBoxa. On sobie na pewno poradzi.
 > No i dalej kiszka. GeexBox też nie pomógł. Wychodzi nato że coś z tym plikiem jest nie tak, ale
 > miałem go z różnych źródeł więc sam już nie wiem. Zazwyczaj wszystkie wmv otwieram a tu przykra
 > niespodzianka, ani linux ani windows. Nie wiem jakim cudem u kolegi to chodzi.Sprawdzę jeszcze
 > na innym sprzęcie. Jeśli to rozgryzę oczywiście o tym napiszę. Dzięki wszystkim za
 > zainteresowanie i chęć pomocy.
u mnie wyglada sprawa odwrotnie: mam glos a nie mam wizji. i to na wszystkich progsach (mam madrive2006). sprobuje z ffmpeg i zobacze...

Offline Łukasz Kisiel

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 47
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #12 dnia: 2006-09-08, 15:19:47 »
Dokonałem zmiany serwera stara baze przenioslem cala na nowy serwer.
W miejscu pliterek sa znaki zapytania czytalem rozne fora o importowaniu i exporcie bazy zmiany kodowania i nic jedyme co uzyskalem to miejscowe zmiany na pliterki wiec tak. Na nowym serwerze przekompilowalem mysqla z opcjami ./configure --prefix=/usr/local/mysql --with-charset=latin2 --with-collation=latin2_general_ci i nic.....
mysql> show variables like "%character%";
+--------------------------+----------------------------------------+
| Variable_name            | Value                                  |
+--------------------------+----------------------------------------+
| character_set_client     | latin1                                 |
| character_set_connection | latin1                                 |
| character_set_database   | latin2                                 |
| character_set_results    | latin1                                 |
| character_set_server     | latin2                                 |
| character_set_system     | utf8                                   |
| character_sets_dir       | /usr/local/mysql/share/mysql/charsets/ |
+--------------------------+----------------------------------------+
7 rows in set (0,01 sec)

mysql> SHOW VARIABLES LIKE 'collation%';
+----------------------+-------------------+
| Variable_name        | Value             |
+----------------------+-------------------+
| collation_connection | latin1_swedish_ci |
| collation_database   | latin2_general_ci |
| collation_server     | latin2_general_ci |
+----------------------+-------------------+
3 rows in set (0,00 sec)

Ggy zmienie to na poprawne i quitne nie zachowuje mi zmian... nie mam zadnego my.cnf config etc.. na starym serwerze nie bylo tez... a sprawdzalem i mam latin2 wszedzie jak to odkrecic moze ktos z Was wie... jak zmusic go do zahcowania tego co zmienie.

Offline Łukasz Kisiel

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 47
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #13 dnia: 2006-09-08, 16:32:03 »
Właśnie doszedłem jak zmienic dla danej bazy... odpowiednimi dyrektywami w pehapie ;) Globalne ustawienia nadal nie zmienione nie moge znalesc jak w my.cnf je podac ;/ wszystko odrzuca ;/

Offline Krzychu S

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
[mysql] kodowanie pliterek
« Odpowiedź #14 dnia: 2006-09-09, 15:58:13 »
Zmień kodowanie pliku z którego odtwarzasz baze
np:

recode latin2..utf-8 nazwa_zrzutu.sql.gz