Nowe posty

xx Uprawnienia (0)
Wczoraj o 18:39:23
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (1)
2019-04-19, 11:11:08
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50
xx Xubuntu i VirtualBox (2)
2019-04-11, 23:24:54
xx problem konfiguracji sieci (3)
2019-04-10, 17:19:19
xx Wykonam strone internetowa. Tworzenie i projektowanie stron www (0)
2019-04-10, 12:37:26

Autor Wątek: XKB, XBD w xorg i polska klawiatura  (Przeczytany 3437 razy)

Offline Krystian Paczkowski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
XKB, XBD w xorg i polska klawiatura
« dnia: 2005-05-16, 00:40:34 »
Witam,

Jestem szczesliwym poki co uzytkownikiem MDK 10.0 Community. Korzystam z przegladarki Firefox i rzecz jasna zainstalowalem juz pewien czas temu plug flasha ze strony www.macromedia.com.

Pojawia sie jednak problem, w miejscu gdy jest cokolwiek flashowego z dzwiekiem, dziwek zacina sie, a dokladniej opisujac pierdzi, skacze niesamowicie. Niczym przekaz radiowy z Tadzykistanu zaklucany przez sluzby wywiadu Rosji :)

Probowlame googlac, polskie strony, zagraniczne, jednakze nie uzyskalem zadnej zadowalajacej odpowiedzi.

Jesli ktos bylby w stanie cokolwiek poradzic bylbym wdzieczny. Pozdrawiam!

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 38
    • Zobacz profil
XKB, XBD w xorg i polska klawiatura
« Odpowiedź #1 dnia: 2005-05-19, 19:59:11 »
Podejrzewam ze masz problem z audio ja tez go mialem i sciagnolem Nvidia i real-player teraz  z gtk jawa pasi wszystko super  .Jey.

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 337
    • Zobacz profil
XKB, XBD w xorg i polska klawiatura
« Odpowiedź #2 dnia: 2005-05-15, 22:46:58 »
Witam.

Szukalem sporo na Google i wszystko co znalazlem odnosilo sie jednak do mojej zaistnialej konfiguracji.

Problem moj polega na tym, ze XKB z XOrg przy uruchomieniu Gnome, wywala blad XKB i nie moge uzywac polskich liter (porobily sie skroty jak na layout EN czy US).

Dzialalo mi wsystko do momentu, gdy nie zachcialo mi sie zainstalowac jakiegos pakietu (abiword-cos), ktory wyrzucil mi slownik polski. Potem go sobie i tak doinstalowalem.

Pamietam, ze gdy system bym swieRZo po instalacji, to mialem ten sam problem, ale nagrzebalem cos w xorg, co spowodowalo pojawienie sie okienka GNOME z zapytaniem jakiej konfiguracji uzyc (Gnome czy Xorg) dla klawiatury.

Ponizej podaje moje ustawienia i zwracam uwage, ze na Driver "Keyboard" mi wywala wogole X'y.

xorg.conf
{
Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "kbd"

#    Identifier "Keyboard1"
#    Driver "Keyboard"
#    Option "XkbModel" "pc104"
#    Option "XkbLayout" "pl"
#    Option "XkbOptions" "grp:alt_shift_toggle"

    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc104"
    Option "XkbLayout"   "pl"
    Option "XkbVariant"   "pl"

EndSection
}

Jak widac probowalem z obecnie zakomentarzowanymi ustawieniami. Tylko nie znam sie na "XkbOptions" :-)

W Gnome mam ustawiony Leyout Polish, jako domyslny i dla wszystkich okien (jedna grupa).

Bez wzgledu co robie wyskakuje mi przy odpalaniu Gnome ponizszy blad w okienku (w dwuch okienkach hehe):
{
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
}

Tak wieNc sprawdzilem:
{
 [dla]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc104", "pl", "pl", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc104", "pl", "pl", ""
 [dla]# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [pl  pl]
 model = pc104
 overrideSettings = false
 options = [altwin      altwin:super_win,grp    grp:alts_toggle]
}

Nie wiem co jest nie tak. Moze ktos poradzic? Aha. Polskie czcionki mam :-)

Z gory dzieNkuje :-)
Marcel

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 337
    • Zobacz profil
XKB, XBD w xorg i polska klawiatura
« Odpowiedź #3 dnia: 2005-05-15, 22:50:39 »
EDYTUJE:
Moze pomoze ponowne odpalenie tego programu do wybierania konfiguracji? Wie ktos jak go uruchomic? Bo jest on zasyty. Szukalem go w systemie pod slowem kluczowym xkb - bo nic innego nie wymyslilem...

Pozdrawiam
(milo mi ze jestem pierwszy na nowym forum)
Fajnie wymyslone - Dzieki TFURCOM :P

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 337
    • Zobacz profil
XKB, XBD w xorg i polska klawiatura
« Odpowiedź #4 dnia: 2005-05-15, 23:51:02 »
POŁOWA ROZWIĄZANA

Słuchajcie, głupia sprawa. Samo ustawiło się w pliku xorg.con coś takiego:
{
Option "XkbVariant" "pl"
}
z głupa dałem
{
Option "XkbVariant" ""
}
I mam polskie literki :-). Niestety nadal error wyskakuje :|

Pozdrawiam

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
XKB, XBD w xorg i polska klawiatura
« Odpowiedź #5 dnia: 2007-01-03, 18:53:11 »
Zasugerowany jedna z ksiazek o Linuksie utworzylem w katalogu domowym plik .gnomerc o zawartosci:

# ---- language-env DON'T MODIFY THIS LINE!

#set LANG
LANG="pl_PL"
MM_CHARSET="iso-8859-2"
SP_CHARSET="iso-8859-2"
exprot LANG MM_CHARSET SP_CHARSET

# ---- language-env end DON'T MODIFY THIS LINE!


Blad zniknal.

U mnie nie mozna wpisywac polskich znakow (XFree86) :(