Nowe posty

Autor Wątek: /boot na oddzielnej partycji i problem z lilo  (Przeczytany 1192 razy)

PussyHunter

  • Gość
/boot na oddzielnej partycji i problem z lilo
« dnia: 2006-07-12, 01:48:19 »
Witam.
Mam od niedawna Mandrive 2006 na laptopie Asus. Chciałem do niej podłączyć moją Nokię 6020. Znalazłem w sieci, że trzeba zainstalować irda-utils, więc ściągnąłem i zacząłem wg instrukcji, przy czym na polecenie modprobe irtty
odpowiada
FATAL: Module irtty not found.
Pomocy, gdzie tego modułu szukać?
Z góry dziękuję za szybką odpowiedź.

voice

  • Gość
/boot na oddzielnej partycji i problem z lilo
« Odpowiedź #1 dnia: 2006-07-11, 22:24:33 »
hej
mam zamiar zainstalowac 2 linuxy i winxp. Narazie zainstalowalem windows i slackware'a no i mam problem z konfiguracja lilo z tego wzgledu ze katalog /boot zrobilem na oddzielnej partycji zeby tam wrzucic jadra slacka i debiana. jak powinna teraz wygladac poprawna konfiguracja lilo, jezeli plik

/proc/partitions ma taka postac:

3   64   117220824   hdb
3   65     10241406   hdb1   ( win c  - ntfs )
3   66                 1   hdb2        ( po co to jest ? )
3   69     85714776   hdb5   ( win d  - fat32 )
3   70        104391   hdb6    ( /boot  - ext3 )
3   71     10241406   hdb7   ( slackware /   - ext3 )
3   72     10241406   hdb7   ( debian /   - ext3 )
3   73        674698   hdb9   ( swap )

natomiast lilo.conf u mnie narazie (bez debiana) wyglada tak:

------
boot = /dev/hdb
message = /boot/boot_message.txt
...
#Windows bootable partition config begins
other = /dev/hdb1
label = Windows
table = /dev/hdb
#Windows bootable partition config ends
#Linux bootable partition config begins
image = /boot/vmlinux    

// (jak podaje image = /dev/hdb6/vmlinux to tez jest blad bo nie znajduje // czegos takiego jak /dev/hdb6, musialbym to najpierw podmontowac,   // tylko gdzie zeby montowalo ta partycje caly czas przy starcie !lilo i nie // wyskakiwalo kernel panic albo cos)

root = /dev/hdb7
label = Linux
read-only
#Linux bootable partition config ends
------

w kazdym razie nie wiem jak to zrobic

jezeli ktos mialby chwilke czasu to bardzo prosze o podanie konfiguracji lilo jak bedzie dodatkowo jeszcze debian bo pewnie tez jakis problem mnie czeka:)

z gory dzieki za odpowiedz

de_laurent

  • Gość
/boot na oddzielnej partycji i problem z lilo
« Odpowiedź #2 dnia: 2006-07-12, 13:37:37 »
> 3   65     10241406   hdb1   ( win c  - ntfs )
 > 3   66                 1   hdb2        ( po co to jest ? )
 > 3   69     85714776   hdb5   ( win d  - fat32 )
 > 3   70        104391   hdb6    ( /boot  - ext3 )
 > 3   71     10241406   hdb7   ( slackware /   - ext3 )
 > 3   72     10241406   hdb7   ( debian /   - ext3 )
 > 3   73        674698   hdb9   ( swap )

Czy mozesz mi wytlumaczy jak udalo ci sie zainstalowac Slacka i Damiana na jedej partycji??

 > 3   66                 1   hdb2        ( po co to jest ? )
To jest oznaczenie partycji rozszezonej. Na tej partycji zawieraja sie wszystkie majace wieksze numery, np. hdb7, itd... Wydaje mi sie... Jak bys pokazl mi fdisk -l (jako root), to bym wiedzial na 100%...

voice

  • Gość
/boot na oddzielnej partycji i problem z lilo
« Odpowiedź #3 dnia: 2006-07-12, 19:03:13 »
2006-07-12 13:37:37 de_laurent napisał:

>  > 3   65     10241406   hdb1   ( win c  - ntfs )
 >  > 3   66                 1   hdb2        ( po co to jest ? )
 >  > 3   69     85714776   hdb5   ( win d  - fat32 )
 >  > 3   70        104391   hdb6    ( /boot  - ext3 )
 >  > 3   71     10241406   hdb7   ( slackware /   - ext3 )
 >  > 3   72     10241406   hdb7   ( debian /   - ext3 )
 >  > 3   73        674698   hdb9   ( swap )
 >
 > Czy mozesz mi wytlumaczy jak udalo ci sie zainstalowac Slacka i Damiana na jedej partycji??
 >
 >  > 3   66                 1   hdb2        ( po co to jest ? )
 > To jest oznaczenie partycji rozszezonej. Na tej partycji zawieraja sie wszystkie majace wieksze
 > numery, np. hdb7, itd... Wydaje mi sie... Jak bys pokazl mi fdisk -l (jako root), to bym
 > wiedzial na 100%...


to hdb7 dla debiana to literowka tylko tak naprawde mam hdb8 sory za to ale przepisywalem to  na innym kompie..

sprawa sie juz wyjasnila

jezeli chodzi o to hdb2 to zgadza sie jest to partycja rozszerzona na ktorej mam logiczne partycje: hdb5 - hdb9
jezeli chodzi o rozwiazanie problemu to nalezalo podmontowac partycje /dev/hdb6 do katalogu /boot

mimo wszystko dzieki za odpowiedz
pozdrawiam