Nowe posty

xx Migracja GRUB2 (0)
2019-08-24, 12:30:46
xx Przydatne Linki (4)
2019-08-23, 14:13:00
xx Awstat (0)
2019-08-22, 14:55:15
xx SMB - Access denied z Windows (9)
2019-08-19, 11:27:24
xx Kali Linux - książka. (0)
2019-08-19, 00:20:25
xx Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera (6)
2019-08-18, 14:37:04
xx Nie moge urchmomic laptopa - grub rescue. (1)
2019-08-17, 18:24:00
xx Po aktualizacji zniknęły niektóre funkcje (45)
2019-08-14, 06:39:01
xx Operacje na bitach. (4)
2019-08-10, 21:44:36
xx Pblem z montowaniem dysku sieciowego (1)
2019-08-09, 23:36:45

Autor Wątek: winmodem  (Przeczytany 10093 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #15 dnia: 2006-06-20, 14:06:23 »
2006-06-20 13:48:38 chmooreck napisał:

> 2006-06-20 13:12:50 ozyr napisał:
 >
 >  > Podpowiedz jak zakomentować glx
 >
 > tak jak cala reszta komentarzy w tym pliku
 >
 > #
Dziękuję za podpowiedź \\"#\\". Powinienem pamiętać ale to pewnie przez to że w domu nie mam dojścia do netu bo jadę tylko na linuxie a konsoli nie opanowałem na tyle by czuć się w niej swobodnie. Teraz jestem w pracy i potrzebuje łopatologicznych podpowiedzi bo mam troche stresa że nie uda mi się przywrócić X-ów.
 Dla pewności glx powinien być w xorg.conf?

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
winmodem
« Odpowiedź #16 dnia: 2006-06-20, 15:09:31 »
2006-06-20 14:06:23 ozyr napisał:

 >  Dla pewności glx powinien być w xorg.conf?

dla nv i vesa powinien byc zakomentowany

dla nvidia moze byc odkomentowany (odpowiada za akceleracje)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #17 dnia: 2006-06-20, 16:13:45 »
2006-06-20 15:09:31 chmooreck napisał:

> 2006-06-20 14:06:23 ozyr napisał:
 >
 >  >  Dla pewności glx powinien być w xorg.conf?
 >
 > dla nv i vesa powinien byc zakomentowany
 >
 > dla nvidia moze byc odkomentowany (odpowiada za akceleracje)
Dziękuję Ci chmoreck za uratowanie. Teraz już siedzę na swoim kompie i X po zakomentowaniu glx pod nv działa. Nie zminia to faktu że nvidia za pierona nie chce ruszyć. Może masz na to jakiś lek.

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
winmodem
« Odpowiedź #18 dnia: 2006-06-20, 21:48:09 »
jak dotychczas mandrive udawalo mi sie ominac szerokim lukiem ;-)
w slacku i gentoo nie natrafilem na zadne problemy...

moze to ci pomoze:
http://mandriva.org.pl/content/view/31/28/

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #19 dnia: 2006-06-20, 22:26:47 »
2006-06-20 21:48:09 chmooreck napisał:

> jak dotychczas mandrive udawalo mi sie ominac szerokim lukiem ;-)
 > w slacku i gentoo nie natrafilem na zadne problemy...
 >
 > moze to ci pomoze:
 > http://mandriva.org.pl/content/view/31/28/
Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to przychodzą komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam :-) i chyba coś faktycznie się namieszało w jądrze bo nie mogę odpalić nic z programów multimedialnch. Chyba pomyślę na poważnie o powrocie do auroxa bo z mandrivą mam sporo problemów - a to kompilacja nie zawsze wychodzi, a to aparatu za nic nie można zamontować a teraz jeszcze doszła grafika. Ale chociaż człowiek się czegoś nauczy :-) a to już jakaś pociecha.

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
winmodem
« Odpowiedź #20 dnia: 2006-06-21, 00:25:13 »
2006-06-20 22:26:47 ozyr napisał:


 > Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to przychodzą
 > komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam :-)

to napisz o jakie moduly sie rzuca... bo faktycznie niektore sie gryza z modulem nvidia (chyba rivafb, ale nie jestem do konca pewny.... )

najprawdopodobniej wystarczy tych modulow nie ladowac na starcie, a zamiast nich zaladowac vesafb lub vesafb-tng czy jakos tak... a potem normalnie modul nvidia i start Xow...

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #21 dnia: 2006-06-21, 17:29:16 »
2006-06-21 00:25:13 chmooreck napisał:

> 2006-06-20 22:26:47 ozyr napisał:
 >
 >
 >  > Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to przychodzą
 >  > komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam :-)
 >
 > to napisz o jakie moduly sie rzuca... bo faktycznie niektore sie gryza z modulem nvidia (chyba
 > rivafb, ale nie jestem do konca pewny.... )
 >
 > najprawdopodobniej wystarczy tych modulow nie ladowac na starcie, a zamiast nich zaladowac
 > vesafb lub vesafb-tng czy jakos tak... a potem normalnie modul nvidia i start Xow...
To walczmy dalej!
Takie wpisy znalazłem:
(EE) NVIDIA (0): Failed go initialize the GLX module; please check in jour X
(EE)                        log file that the GLX module has been loaded in your X
(EE)                   server and that the module to encounter problems, PLEASE try reinstaling the NVIDIA driver.
FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko): Invalid module format
(EE) Failed to load the NVIDIA kernel module!
(EE) *** Aborting ***
Scern found, but none have usable configuration.
Tak to wygląda w logach.
Mam monitor samtron ustawiony w X86Config jako:
Section \\"Monitor\\"
Identifier  \\"montor1\\"
VendorName   \\"Plug\\'n Play\\"
HorizSync      30.0 - 71.0
W Section  \\"Module\\"
Load \\"dbe\\" # Double-Buffering Extension
Load \\"v4l\\"  # Video for Linux
Load \\"extpod\\"
Load \\"freetype\\"
# Load \\"glx\\" # 3D layer
VertRefresh    50.0 - 160.0
Jakie sugestie?

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
winmodem
« Odpowiedź #22 dnia: 2006-06-21, 18:53:42 »
2006-06-21 17:29:16 ozyr napisał:

> 2006-06-21 00:25:13 chmooreck napisał:
 >
 > > 2006-06-20 22:26:47 ozyr napisał:
 >  >
 >  >
 >  >  > Dzięki za adres. Nistety już go przerobiłem. Jak próbuję załadować nvidię to
 > przychodzą
 >  >  > komunikaty że coś nie tak z modułami w kernelu, a na tym to się jeszcze nie znam
 > :-)
 >  >
 >  > to napisz o jakie moduly sie rzuca... bo faktycznie niektore sie gryza z modulem nvidia
 > (chyba
 >  > rivafb, ale nie jestem do konca pewny.... )
 >  >
 >  > najprawdopodobniej wystarczy tych modulow nie ladowac na starcie, a zamiast nich
 > zaladowac
 >  > vesafb lub vesafb-tng czy jakos tak... a potem normalnie modul nvidia i start Xow...
 > To walczmy dalej!
 > Takie wpisy znalazłem:
 > (EE) NVIDIA (0): Failed go initialize the GLX module; please check in jour X
 > (EE)                        log file that the GLX module has been loaded in your X
 > (EE)                   server and that the module to encounter problems, PLEASE try reinstaling
 > the NVIDIA driver.
 > FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko):
 > Invalid module format
 > (EE) Failed to load the NVIDIA kernel module!
 > (EE) *** Aborting ***
 > Scern found, but none have usable configuration.
 > Tak to wygląda w logach.
 > Mam monitor samtron ustawiony w X86Config jako:
 > Section \\"Monitor\\"
 > Identifier  \\"montor1\\"
 > VendorName   \\"Plug\\'n Play\\"
 > HorizSync      30.0 - 71.0
 > W Section  \\"Module\\"
 > Load \\"dbe\\" # Double-Buffering Extension
 > Load \\"v4l\\"  # Video for Linux
 > Load \\"extpod\\"
 > Load \\"freetype\\"
 > # Load \\"glx\\" # 3D layer
 > VertRefresh    50.0 - 160.0
 > Jakie sugestie?

jesli korzystasz ze sterownika nvidia ladowanie modulu glx powinno byc odkomentowane

po pierwsze sprawdz, czy zodla jadra jakie zainstalowales odpowiadaja DOKLADNIE wersji jadra, ktora chodzi ( $ uname -r )

po zainstalowaniu sterownika sprobuj recznie zaladowac modul nvidia (# modprobe nvidia )... i daj znac co sie stalo :-)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #23 dnia: 2006-06-21, 19:05:43 »
> jesli korzystasz ze sterownika nvidia ladowanie modulu glx powinno byc odkomentowane
 >
 > po pierwsze sprawdz, czy zodla jadra jakie zainstalowales odpowiadaja DOKLADNIE wersji jadra,
 > ktora chodzi ( $ uname -r )
 >
 > po zainstalowaniu sterownika sprobuj recznie zaladowac modul nvidia (# modprobe nvidia )... i
 > daj znac co sie stalo :-)
wersja jądra jest porawna  a po modprobe przychodzi:
[root@localhost video]# modprobe nvidia
FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko): Invalid module format
Coś się pochrzaniło w kernelu bo np. xine uruchamie się i zaraz wyłancza.

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
winmodem
« Odpowiedź #24 dnia: 2006-06-21, 20:45:45 »
2006-06-21 19:05:43 ozyr napisał:

 > [root@localhost video]# modprobe nvidia
 > FATAL: Error inserting nvidia (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko):
 > Invalid module format

u mnie modul do nvidii instaluje sie do /lib/modules/wersja_jadra/video.. ale to moze wynikac z tego, ze uzywam gentoo i instalacja sterownikow wyglada to troche inaczej...

sprobuj wyrzucic ten modul i skompilowac jeszcze raz...


 > Coś się pochrzaniło w kernelu bo np. xine uruchamie się i zaraz wyłancza.

sprobuj przeinstalowac paczke jadra... skoro cos sie pochrzanilo... ;-)
btw... kompilowales jadro samodzielnie, czy masz z paczki ?

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #25 dnia: 2006-06-21, 21:20:40 »
>  > [root@localhost video]# modprobe nvidia
 >  > FATAL: Error inserting nvidia
 > (/lib/modules/2.6.8.1-12mdk/kernel/drivers/video/nvidia.ko):
 >  > Invalid module format
 >
 > u mnie modul do nvidii instaluje sie do /lib/modules/wersja_jadra/video.. ale to moze wynikac z
 > tego, ze uzywam gentoo i instalacja sterownikow wyglada to troche inaczej...
 >
 > sprobuj wyrzucic ten modul i skompilowac jeszcze raz...
 >
 >
 >  > Coś się pochrzaniło w kernelu bo np. xine uruchamie się i zaraz wyłancza.
 >
 > sprobuj przeinstalowac paczke jadra... skoro cos sie pochrzanilo... ;-)
 > btw... kompilowales jadro samodzielnie, czy masz z paczki ?
Łatwo powiedzieć (napisać) :-). Nie kompilowałem jeszcze jądra i mam stracha że coś namieszam bo przeważnie zawsze coś wyskoczy niemiłego. Jądro mam z rpma z płyt instalacyjnych. Zanim się zabiorę za taką zabawę muszę zarchiwizowć dane. Szkoda by ich było. Zaskoczeniem dla mnie jest np. to że po pierwszej instalacji sterownikó nwidi co prawda nie startowały ale dały się odinstalować a teraz już nie dają się odinstalować. Przychodzi komunikat
Segmentation fault i nie wiem o co chodzi.
Z wyrzuceniem modułu i ponowną instalacją też nie bardzo wiem który modół wyrzucić i jak go ponownie zainstalować.

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
winmodem
« Odpowiedź #26 dnia: 2006-06-21, 22:25:24 »
2006-06-21 21:20:40 ozyr napisał:

 > Łatwo powiedzieć (napisać) :-). Nie kompilowałem jeszcze jądra i mam stracha że coś namieszam
 > bo przeważnie zawsze coś wyskoczy niemiłego. Jądro mam z rpma z płyt instalacyjnych. Zanim się
 > zabiorę za taką zabawę muszę zarchiwizowć dane. Szkoda by ich było.

I bardzo dobrze.. tzn poki co nie bierz sie za kompilacje (z drugiej strony nie jest to nic niebezpiecznego i nie utrata danych nie grozi - chyba, ze sam je usuniesz ;-) )


 > Zaskoczeniem dla mnie jest
 > np. to że po pierwszej instalacji sterownikó nwidi co prawda nie startowały ale dały się
 > odinstalować a teraz już nie dają się odinstalować. Przychodzi komunikat

w jaki sposob probujesz je \\"odinstalowac\\" ?

chodzi o reczne usuniecie pliku modulu nvidia.ko (wskazanego wczesniej) i powtorne zainstalowanie sterownika nvidii (uruchomienie instalatora, itd)

mozesz podac nazwy paczki z jadrem i nazwe paczki ze zrodlami jadra jakie masz aktualnie zainstalowane ?

podaj co wyswietla
# lsmod

jaka jest zawartosc katalogu /usr/src ?

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #27 dnia: 2006-06-22, 16:25:43 »
2006-06-21 22:25:24 chmooreck napisał:

> 2006-06-21 21:20:40 ozyr napisał:
 >
 >  > Łatwo powiedzieć (napisać) :-). Nie kompilowałem jeszcze jądra i mam stracha że coś
   
 >  > Zaskoczeniem dla mnie jest
 >  > np. to że po pierwszej instalacji sterownikó nwidi co prawda nie startowały ale dały się
 >  > odinstalować a teraz już nie dają się odinstalować. Przychodzi komunikat
 >
 > w jaki sposob probujesz je \\"odinstalowac\\" ?
 wpisuję polecenie # nvidia-installer --uninstall
Segmentation fault
[root@localhost j]#

 > chodzi o reczne usuniecie pliku modulu nvidia.ko (wskazanego wczesniej) i powtorne
 > zainstalowanie sterownika nvidii (uruchomienie instalatora, itd)
 >
 > mozesz podac nazwy paczki z jadrem i nazwe paczki ze zrodlami jadra jakie masz aktualnie
 > zainstalowane ?
 #  rpm -qa | grep kernel
kernel-source-2.6-2.6.8.1-12mdk
kernel-2.6.8.1.12mdk-1-1mdk

 > podaj co wyswietla
 > # lsmod
 # lsmod
Module                  Size  Used by
md5                     3584  1
ipv6                  230916  10
rfcomm                 32348  0
l2cap                  19876  5 rfcomm
bluetooth              39076  4 rfcomm,l2cap
snd-pcm-oss            49480  0
snd-mixer-oss          17376  2 snd-pcm-oss
snd-cmipci             28228  3
snd-pcm                81800  2 snd-pcm-oss,snd-cmipci
snd-page-alloc          7400  1 snd-pcm
snd-opl3-lib            8448  1 snd-cmipci
snd-timer              20356  2 snd-pcm,snd-opl3-lib
snd-hwdep               6916  1 snd-opl3-lib
gameport                3328  1 snd-cmipci
snd-mpu401-uart         5856  1 snd-cmipci
snd-rawmidi            19300  1 snd-mpu401-uart
snd-seq-device          6344  2 snd-opl3-lib,snd-rawmidi
snd                    45988  14 snd-pcm-oss,snd-mixer-oss,snd-cmipci,snd-pcm,snd-opl3-lib,snd-timer,snd-hwdep,snd-mpu401-uart,snd-rawmidi,snd-seq-device
soundcore               7008  2 snd
ppp_async               8896  1
ppp_generic            24468  5 ppp_async
slhc                    6112  1 ppp_generic
crc-ccitt               1664  1 ppp_async
af_packet              16072  2
floppy                 55088  0
ide-cd                 37280  0
cdrom                  37724  1 ide-cd
loop                   12520  0
tsdev                   5824  0
joydev                  8032  0
usbmouse                4256  0
evdev                   7648  0
usbhid                 41088  0
eagle-usb             123520  0
ohci-hcd               18468  0
usbcore               103172  6 usbmouse,usbhid,eagle-usb,ohci-hcd
ext3                  120680  5
jbd                    49080  1 ext3

 > jaka jest zawartosc katalogu /usr/src ?
/RPM
~linux
/linux-2.6.15.2
/linux-2.6.8.1-12mdk

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
winmodem
« Odpowiedź #28 dnia: 2006-06-22, 18:19:10 »
2006-06-22 16:25:43 ozyr napisał:

 >  > jaka jest zawartosc katalogu /usr/src ?
 > /RPM
 > ~linux
 > /linux-2.6.15.2
 > /linux-2.6.8.1-12mdk

skad sie wzial linux-2.6.15.2 ?
na co wskazuje ~linux ?

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 186
    • Zobacz profil
winmodem
« Odpowiedź #29 dnia: 2006-06-22, 18:36:34 »
2006-06-22 18:19:10 chmooreck napisał:

> 2006-06-22 16:25:43 ozyr napisał:
 >
 >  >  > jaka jest zawartosc katalogu /usr/src ?
 >  > /RPM
 >  > ~linux
 >  > /linux-2.6.15.2
 >  > /linux-2.6.8.1-12mdk
 >
 > skad sie wzial linux-2.6.15.2 ?
Tam są rozpakowane źródła które kiedyś pobrałem ale nic z tym jeszcze nie robiłem.
 > na co wskazuje ~linux ?
ten skrót idzie na /usr/src/linux-2.6.8.1-12mdk