Nowe posty

Autor Wątek: [Debian Etch] X.Org 7.0 i sterowniki do Rivy TNT 2  (Przeczytany 2040 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 43
    • Zobacz profil
[Debian Etch] X.Org 7.0 i sterowniki do Rivy TNT 2
« dnia: 2006-06-09, 00:39:36 »
Witam, mój problem przedstwia sie następująco, nie moge odtworzyć pewnych plików np. wmv (choć niektóre wmv mi ida) rmvb. Pisze mi że:

This steam \\"nazwa.wmv\\" use an unsupported codec:
Video Codec MS WMV 9 (win32) (WMV3)
A problem occur while loading library or a decoder:
wmvdmod.dll

Problem polega na tym że mam kodeki tylko ich nie widzi, co zrobić by widział je zarówno xine jak i mplayer?
Kodeki mam w /usr/local/lib/codecs , mam slackware 10.2 (kolega mi zainstalował mówił że łatwy a teraz mam za dużo danych by móc zmienić dystrybucje :( )

Z góry wielkie dzieki

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 55
    • Zobacz profil
[Debian Etch] X.Org 7.0 i sterowniki do Rivy TNT 2
« Odpowiedź #1 dnia: 2006-06-09, 10:47:51 »
2006-06-09 00:39:36 Slonzok napisał:

> Witam, mój problem przedstwia sie następująco, nie moge odtworzyć pewnych plików np. wmv (choć
 > niektóre wmv mi ida) rmvb. Pisze mi że:
 >
 > This steam \\"nazwa.wmv\\" use an unsupported codec:
 > Video Codec MS WMV 9 (win32) (WMV3)
 > A problem occur while loading library or a decoder:
 > wmvdmod.dll
 >
 > Problem polega na tym że mam kodeki tylko ich nie widzi, co zrobić by widział je zarówno xine
 > jak i mplayer?
 > Kodeki mam w /usr/local/lib/codecs , mam slackware 10.2 (kolega mi zainstalował mówił że łatwy
 > a teraz mam za dużo danych by móc zmienić dystrybucje :( )
 >
 > Z góry wielkie dzieki

No to kolega ci wycioł numer - slackware łatwy :D?? nie powiedziałbym, to jest jeden z cięższych linuksów( a już napewno do korzystania w domu) i jeden z najstarszych.

A co do problemu - jeżeli jesteś pewien że masz potrzebne codeki to popatrz w ustawieniach konkretnych programów(xine,mplayer) tam powinny być opcje dotyczące ustawienia ścieżki do codeków. Ale moim zdaniem to niemasz w32codecs(czy jakoś tak), można je pobrać ze strony http://www1.mplayerhq.hu/design7/codecs.html.

Powodzenia.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 43
    • Zobacz profil
[Debian Etch] X.Org 7.0 i sterowniki do Rivy TNT 2
« Odpowiedź #2 dnia: 2006-06-09, 23:34:17 »
2006-06-09 10:47:51 flejtuch napisał:

> 2006-06-09 00:39:36 Slonzok napisał:
 >
 > > Witam, mój problem przedstwia sie następująco, nie moge odtworzyć pewnych plików np. wmv
 > (choć
 >  > niektóre wmv mi ida) rmvb. Pisze mi że:
 >  >
 >  > This steam \\"nazwa.wmv\\" use an unsupported codec:
 >  > Video Codec MS WMV 9 (win32) (WMV3)
 >  > A problem occur while loading library or a decoder:
 >  > wmvdmod.dll
 >  >
 >  > Problem polega na tym że mam kodeki tylko ich nie widzi, co zrobić by widział je zarówno
 > xine
 >  > jak i mplayer?
 >  > Kodeki mam w /usr/local/lib/codecs , mam slackware 10.2 (kolega mi zainstalował mówił że
 > łatwy
 >  > a teraz mam za dużo danych by móc zmienić dystrybucje :( )
 >  >
 >  > Z góry wielkie dzieki
 >
 > No to kolega ci wycioł numer - slackware łatwy :D?? nie powiedziałbym, to jest jeden z
 > cięższych linuksów( a już napewno do korzystania w domu) i jeden z najstarszych.
 >
 > A co do problemu - jeżeli jesteś pewien że masz potrzebne codeki to popatrz w ustawieniach
 > konkretnych programów(xine,mplayer) tam powinny być opcje dotyczące ustawienia ścieżki do
 > codeków. Ale moim zdaniem to niemasz w32codecs(czy jakoś tak), można je pobrać ze strony
 > http://www1.mplayerhq.hu/design7/codecs.html.
 >
 > Powodzenia.

PO zainstalowaniu ich na nowo, nadal nie było efektu, nie mogłem też znaleść zadnej innej lokalizacji pliku config poza katalogiem domowym :( co wydało mi się dziwne, bo gdzieś taki plik powinien chyba byc.
W każdym bądz razie w \\"localnym\\" config (prawie na samym końcu) znalazłem info że kodeki win32 powinny być w katalogu /usr/lib/win32 więc w /usr/lin stworzyłem sobie link o nazwie win32 do katalogu z kodekami. Teraz mi wszystko działa, wielkie dzięki za podpowiedz :)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 22
    • Zobacz profil
[Debian Etch] X.Org 7.0 i sterowniki do Rivy TNT 2
« Odpowiedź #3 dnia: 2006-06-08, 18:14:54 »
Sterowniki się ładnie kompilują (na kernelku 2.6.15), wszystko ładnie i pięknie, tylko po wystartowaniu X'ów (z odpowiednio zedytowanym plikeim konfiguracyjnym pod sterowniki nvidii) same się wyłączają i pokazują się dwa błędy:
- nie może znaleźć modułu glx
- nie może znaleźć modułu nvidia (sterowników)


Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
[Debian Etch] X.Org 7.0 i sterowniki do Rivy TNT 2
« Odpowiedź #5 dnia: 2006-06-22, 17:33:25 »
2006-06-08 18:14:54 Matthew87 napisał:

> Sterowniki się ładnie kompilują (na kernelku 2.6.15), wszystko ładnie i pięknie, tylko po
 > wystartowaniu X'ów (z odpowiednio zedytowanym plikeim konfiguracyjnym pod sterowniki nvidii)
 > same się wyłączają i pokazują się dwa błędy:
 > - nie może znaleźć modułu glx
 > - nie może znaleźć modułu nvidia (sterowników)

Ostatnie drivery obsługujace TNT2 to 7471 i są one w repozytorium!!!
Instalujesz paczki:
-nvidia-kernel-common
-nvidia-glx-legacy
-nvidia-kernel-legacy-2.6.15-1-686 ( ewentulanie nvidia-kernel-legacy-2.6.15-1-486 jesli masz takie jajko )
-nvidia-kernel-legacy-source
I wszystko dziala odrazu, bez zbednej kompilacji w wyniku ktorej dostajesz dokladnie ( no chyba ze dodajesz jakies kosmiczne flagi ) to samo co w tej paczce ( z optymalizacja pod 686 ).
Nowsze paczki driverow i tak sie nie zainstaluja bo wersje nie badce legacy sa w konflikcie z X.org'iem.