Nowe posty

Autor Wątek: invalid ELF header  (Przeczytany 225 razy)

Offline Kamil

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 449
    • Zobacz profil
invalid ELF header
« dnia: 2006-05-24, 15:56:22 »
Witam. Instaluje debiana sarge z plyty netinstall. Mam siec radiowa, karte rtl 8139 i lacze sie przez pppoe. Zainstalowalem z plyty netinstall system bazowy, i pozniej podczas wybierania rezpozytorium wylaczylem konfigurator, i skonfigurowalem internet. Ladnie wszedzie pinguje (wp.pl, onet.pl, brama, inne komputery w sieci), ale nie chce za nic sciagac... wget\\'em daje jakis prosty link to pokazuje ip serwera ale poprzestaje na
> Translacja ftp.de.debian.org... 141.76.2.4
> Łączenie się z ftp.de.debian.org[141.76.2.4]:80...

Niewiem co moze byc zle skonfigurowane.... prosze o pomoc. Dzieki i pozdrawiam

Offline konrad okurowski

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 463
    • Zobacz profil
invalid ELF header
« Odpowiedź #1 dnia: 2006-05-24, 18:43:02 »
2006-05-24 15:56:22 matulik napisał:

> Witam. Instaluje debiana sarge z plyty netinstall. Mam siec radiowa, karte rtl 8139 i lacze sie
 > przez pppoe. Zainstalowalem z plyty netinstall system bazowy, i pozniej podczas wybierania
 > rezpozytorium wylaczylem konfigurator, i skonfigurowalem internet. Ladnie wszedzie pinguje
 > (wp.pl, onet.pl, brama, inne komputery w sieci), ale nie chce za nic sciagac... wget\\'em daje
 > jakis prosty link to pokazuje ip serwera ale poprzestaje na
 > > Translacja ftp.de.debian.org... 141.76.2.4
 > > Łączenie się z ftp.de.debian.org[141.76.2.4]:80...
 >
 > Niewiem co moze byc zle skonfigurowane.... prosze o pomoc. Dzieki i pozdrawiam

A jaką masz wersje płyty instalacyjnej?
może spóbuj etcha http://cdimage.debian.org/cdimage/daily-builds/etch_d-i/current/i386/iso-cd/debian-testing-i386-netinst.iso
Jest nowszy i w grudniu wyjdzie jako stable;)

Offline Kamil

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 449
    • Zobacz profil
invalid ELF header
« Odpowiedź #2 dnia: 2006-05-24, 18:51:15 »
2006-05-24 18:43:02 kfiaciarka napisał:
 > A jaką masz wersje płyty instalacyjnej?
 > może spóbuj etcha
 > http://cdimage.debian.org/cdimage/daily-builds/etch_d-i/current/i386/iso-cd/debian-testing-i386-netinst.iso
 > Jest nowszy i w grudniu wyjdzie jako stable;)
zaisntalowalem aktualna stable...
a testing oplaca sie instalowac? nie bedzie z nia problemow?

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
invalid ELF header
« Odpowiedź #3 dnia: 2006-05-24, 20:10:37 »
2006-05-24 18:51:15 matulik napisał:

> 2006-05-24 18:43:02 kfiaciarka napisał:
 >  > A jaką masz wersje płyty instalacyjnej?
 >  > może spóbuj etcha
 >  >
 > http://cdimage.debian.org/cdimage/daily-builds/etch_d-i/current/i386/iso-cd/debian-testing-i386-netinst.iso
 >  > Jest nowszy i w grudniu wyjdzie jako stable;)
 > zaisntalowalem aktualna stable...
 > a testing oplaca sie instalowac? nie bedzie z nia problemow?

Nie będzie, choć czasem warto czytać komunikaty podczas aktualizacji pakietów i nie naciskać bezmyślnie \\"T\\" ;-) Bo często nie wszystkie pakiety  jednocześnie przechodzą  z unstable do testing i są problemy z zależnościami. Generalnie można używać spokojnie unstable, lub (jak ja) coś pomiędzy testing a unstable.

--
Maciek

Offline Kamil

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 449
    • Zobacz profil
invalid ELF header
« Odpowiedź #4 dnia: 2006-05-24, 22:05:45 »
2006-05-24 20:10:37 Maciek_Rutecki napisał:

> 2006-05-24 18:51:15 matulik napisał:
 >
 > > 2006-05-24 18:43:02 kfiaciarka napisał:
 >  >  > A jaką masz wersje płyty instalacyjnej?
 >  >  > może spóbuj etcha
 >  >  >
 >  >
 > http://cdimage.debian.org/cdimage/daily-builds/etch_d-i/current/i386/iso-cd/debian-testing-i386-netinst.iso
 >  >  > Jest nowszy i w grudniu wyjdzie jako stable;)
 >  > zaisntalowalem aktualna stable...
 >  > a testing oplaca sie instalowac? nie bedzie z nia problemow?
 >
 > Nie będzie, choć czasem warto czytać komunikaty podczas aktualizacji pakietów i nie naciskać
 > bezmyślnie \\"T\\" ;-) Bo często nie wszystkie pakiety  jednocześnie przechodzą  z
 > unstable do testing i są problemy z zależnościami. Generalnie można używać spokojnie unstable,
 > lub (jak ja) coś pomiędzy testing a unstable.
 >
 > --
 > Maciek


jednak troche sie testing rozni od stable.. np instalator...
ja, by zaczac instalacje online musze skonfigurowac siec z lini polecen, a instalator chce juz to robic podczas instalacji...

w dodatku rp-pppoe nie ma na plycie, ale z tym juz jakos poradze...

no powiedzmy ze skonfigurowalem siec, co teraz zrobic by jeszcze raz wszystko zassysalo, wszystkie pakiety etc.? bedzie dzialalo base-config?

Offline Mariusz Kocoń

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 25
    • Zobacz profil
invalid ELF header
« Odpowiedź #5 dnia: 2006-05-24, 10:16:03 »
Czy ktoś ma pomysł skąd się bierze taki błąd: "dirname: error while loading shared libraries: /usr/lib/libc.so.6: invalid ELF header". Biblioteka jest, zwraca go dwa programy ZENWorks Management Daemon i instalator JBuildera 2005, i oba potrzebne i za Chiny Ludowe (w demokratyczne nie wierzę) nie wiem co z tym zrobić. Doinstalowalem pakiet libelf, przeinstalowałem wszystkie glib* i smotrisz w knigu widzisz fugu. Okoniem stoi jak stał. Może ktoś ma pomysł co go boli i jak wyleczyć. Dystrybucja SUSE 10.1 DVD, na 10 chodził.