Nowe posty

Autor Wątek: Problemy z JFS  (Przeczytany 6472 razy)

  • Gość
Problemy z JFS
« dnia: 2006-04-23, 00:53:49 »
Witam:)

Wiem, że pytanie pewnie jest dla większości banalne ale ja dopiero zaczynam przygodę z linuxem i nie mam o nim praktycznie pojęcia. Jestem zielona w temacie zupełnie. Mam nadzieję, że nie wykasujecie tego posta :)

Czy ktoś byłby tak uprzejmy i napisał mi jak zainstalować na jednym dysku Mandrivę 2006 Free na DVD razem z XP. Coś tam kombinowałam, za dużo by pisać  W każdym razie potem nie ładuje mi się w tym programie rozruchowym na początku windows (nie ma go na liście do wyboru) a nawet jak za, którymś tam razem się pojawiał to nie odpalał. Zależy mi narazie, żeby mieć Linuxa i Windowsa na jednym dysku bo jeszcze kompletnie nie znam tego pierwszego.

Napiszę może tylko tak skrótowo, że dysk mam 60 GB. Na partycji C, którama 8 GB jest XP. Reszte podzieliłam na 3 partycje pod Mandrivą. Pierwszą partycję utworzyłam pod  linuxa (19 GB) - \\"ext3\\", zamontowałam jako \\"/\\". Druga to Swap zrobiłam 1.6 GB bo mam 768 MB RAMu. I ta reszta jako \\"/home\\" też \\"ext3\\" na jakieś dokumenty, około 30 GB. Próbowałam też tylko z dwoma partycjami pod linux. Windows albo nie pojawia się na tym programie rozruchowym (tj. chyba LILO w trybie graficznym?) albo jak się nawet pojawi to nie uruchamia się ani Win ani Linux. Czy ktoś jeszcze mógłby mi wytłumaczyć co to jest to LILO i czym się różni od tego drugiego (nie pamiętam nazwy, chyba na \\"G\\" jakoś). Przepraszam ale naprawdę nie znam się i nie wiem co zrobić.

Pozdrawiam i z góry dzięki za pomoc :)

kmp

  • Gość
Problemy z JFS
« Odpowiedź #1 dnia: 2006-04-23, 01:24:50 »
2006-04-23 00:53:49 Nolis napisał:

> Witam:)
 >
 > Wiem, że pytanie pewnie jest dla większości banalne ale ja dopiero zaczynam przygodę z linuxem
 > i nie mam o nim praktycznie pojęcia. Jestem zielona w temacie zupełnie. Mam nadzieję, że nie
 > wykasujecie tego posta :)
 >
 > Czy ktoś byłby tak uprzejmy i napisał mi jak zainstalować na jednym dysku Mandrivę 2006 Free na
 > DVD razem z XP. ...


Nieco teorii na poczatek:
http://www.linuxdlafirm.pl/linux_podstawy/instalacja_systemu_linux/linux_i_ms_windows_na_jednym_dysku.html


marecki71

  • Gość
Problemy z JFS
« Odpowiedź #2 dnia: 2006-04-23, 10:09:30 »
Poczytaj sobie:
http://strefamandrivy.pl/baza_wiedzy/starter/index.html
Z tymi partycjami toś zaszalał.
/ - 5 do 6 Giga
swap - 0,5 Giga w twoim przypadku wystarczy
/home - reszta

marecki71

  • Gość
Problemy z JFS
« Odpowiedź #3 dnia: 2006-04-23, 10:26:14 »
Jeśli zaczynasz zabawe z Linuksem to pozostaw wykonanie partycji Mandrivie, po prostu wybierz opcję \\"Wykorzystaj wolne miejsce na partycji Windows\\" a w następnym oknie za pomocą suwaka zmniejszysz obszar zajmowany przez Win (D) o potrzebną ci wielkość.
Resztę Mandriva zrobi sama.


dzordz

  • Gość
Problemy z JFS
« Odpowiedź #4 dnia: 2006-04-23, 11:50:06 »
 >
 > Czy ktoś byłby tak uprzejmy i napisał mi jak zainstalować na jednym dysku Mandrivę 2006 Free na
 > DVD razem z XP. Coś tam kombinowałam, za dużo by pisać  W każdym razie potem nie ładuje mi się w
 > tym programie rozruchowym na początku windows (nie ma go na liście do wyboru) a nawet jak za,
 > którymś tam razem się pojawiał to nie odpalał. Zależy mi narazie, żeby mieć Linuxa i Windowsa
 > na jednym dysku bo jeszcze kompletnie nie znam tego pierwszego.
 >

 >  
Nolis ja kiedyś robiłem tak :
1 dzieliłem dysk mniej wiecej tak C:/ -10 GB (ntsf) D:/ -20 GB (fat32) reszta dysku w jednym kawałku.
2 instaluje winxp na C:/   a D:/ służy mi jako posrednik
3 instaluje mandrive i przy podziale na partycje wskazuje reszte dysku tak aby mandriva podzieliła automatycznie.
4 instalacja
5 w twoim przypadku program rozruchowy lilo lub grub powinien sam skonfigurowac ale poczytaj najpierw tutaj http://gorzow-wlkp.pl/linux/xp_win.php
a po tem to juz tylko sie meczyc i nie poddawac

pozdr
dzordz

  • Gość
Problemy z JFS
« Odpowiedź #5 dnia: 2006-04-23, 12:59:30 »
Ja korzystałam wecześniej ze wskazówek zawartych na forum Mandrivy.

Dzięki wszystkim za pomoc. Udało się! :) Zrobiłam po prostu tak, że weszłam w zaawansowany podział na partycję ale nic nie kombinowałam sama tylko zrobiłam rozmieść automatycznie i wszystko działa ok teraz :]

Teraz się męczę z neostradą :D Pozdrawiam i jeszcze raz dziękuję za poświęcony czas i pomoc.

trupek

  • Gość
Problemy z JFS
« Odpowiedź #6 dnia: 2006-04-23, 20:54:34 »
ja zrobiłem tak podczas instalacij xp podzieliłem dysk na patycje i zostawiłem 10 giga wolnego nie podzielonego miejsca.
Podczas instalacij mandrivy zaznaczyłem zeby instalowała sie na wolnym miejscu i działa lilo działa poprawnie .

                       jeśli chodzi o linuxa to tez dopiero zaczynam jak cos żle napisałem to sory nara.

lynczu

  • Gość
Problemy z JFS
« Odpowiedź #7 dnia: 2006-04-22, 17:56:53 »
Witajcie,

dysk bodajze WD Caviara (nie jestem pewien) 80GB podzielilem na dwie partycje - pierwsze 40GB na XFS do przechowywania filmow itp., drugie 40 GB na JFS. Z tym wyborem systemu plikow wiaze sie dluga historia, poniewaz druga partycja sformatowana Reiserfs'em/Reiser4 w ogole nei chiala sie zamontowac - przy poleceniu mount po prostu nie pojawial sie znak zachety, zwiastujacy pomyslne montowanie - tak jakby sie zacial. No ale nie tu problem. Przegralem pare bardzo waznych rzeczy na partycje z JFS i gdy minelo odpowiednio duzo czasu, bym doszedl do wniosku jaki ze mnie kretyn bylo jzu za pozno. Chcialem przegrac te dane spowrotem na pierwsza partycje, usunac ta z JFS i rozszerzyc ta z XFS. Ale podczas kopiowania plikow z drugiej partycji dysk jakby sie wiesza - caly proces kopiowania rozpedza sie do zawrotnej predkosci 64kB/s po czym spada do 0 i ow okopiowanie zostaje w stadium "Stalled".. przekompilowalem kernel (2.6.16-rc3-nitro1) z obsluga JFS bez zadnych innych bajerow, sprawdzilem doglebnie partycje JFS fsck'iem i dalej to samo. Czy ktos wie lub podejzewa w czym problem?

flak

  • Gość
Problemy z JFS
« Odpowiedź #8 dnia: 2006-04-22, 18:13:59 »
2006-04-22 17:56:53 lynczu napisał:

> Witajcie,
 >
 > dysk bodajze WD Caviara (nie jestem pewien) 80GB podzielilem na dwie partycje - pierwsze 40GB
 > na XFS do przechowywania filmow itp., drugie 40 GB na JFS. Z tym wyborem systemu plikow wiaze
 > sie dluga historia, poniewaz druga partycja sformatowana Reiserfs'em/Reiser4 w ogole nei chiala
 > sie zamontowac - przy poleceniu mount po prostu nie pojawial sie znak zachety, zwiastujacy
 > pomyslne montowanie - tak jakby sie zacial. No ale nie tu problem. Przegralem pare bardzo
 > waznych rzeczy na partycje z JFS i gdy minelo odpowiednio duzo czasu, bym doszedl do wniosku
 > jaki ze mnie kretyn bylo jzu za pozno. Chcialem przegrac te dane spowrotem na pierwsza
 > partycje, usunac ta z JFS i rozszerzyc ta z XFS. Ale podczas kopiowania plikow z drugiej
 > partycji dysk jakby sie wiesza - caly proces kopiowania rozpedza sie do zawrotnej predkosci
 > 64kB/s po czym spada do 0 i ow okopiowanie zostaje w stadium "Stalled"..
 > przekompilowalem kernel (2.6.16-rc3-nitro1) z obsluga JFS bez zadnych innych bajerow,
 > sprawdzilem doglebnie partycje JFS fsck'iem i dalej to samo. Czy ktos wie lub podejzewa w czym
 > problem?

Ja bym powiedział że winą jest... nitro. To kernel dla ricerów, więc jest nieobliczalny.

lynczu

  • Gość
Problemy z JFS
« Odpowiedź #9 dnia: 2006-04-22, 18:48:04 »
2006-04-22 18:13:59 flak napisał:

 > Ja bym powiedział że winą jest... nitro. To kernel dla ricerów, więc jest nieobliczalny.

no nie wiem, mam jeszcze eksperymentalnie dwie partycje z JFS na innym dysku i one dzialaja.. ale mam jeszcze vanille, odpale system na niej i zobacze, moze jest rzeczywiscie, tak jak mowisz :)

lynczu

  • Gość
Problemy z JFS
« Odpowiedź #10 dnia: 2006-04-23, 15:27:02 »
2006-04-22 18:48:04 lynczu napisał:

> 2006-04-22 18:13:59 flak napisał:
 >
 >  > Ja bym powiedział że winą jest... nitro. To kernel dla ricerów, więc jest nieobliczalny.
 >
 > no nie wiem, mam jeszcze eksperymentalnie dwie partycje z JFS na innym dysku i one dzialaja..
 > ale mam jeszcze vanille, odpale system na niej i zobacze, moze jest rzeczywiscie, tak jak
 > mowisz :)

No więc odpaliłem system na kernelu vanilla 2.6.17-rc2 i jest to samo, nawet gorzej, bo rozpędza się tylko do 11kB/s ;-) myślałem, że to może skutek przekombinowania jakiś ustawień hdparm, więc kombinowaem z c0, c1, c2 itp. włączając/wyłączając unmasking i inne takie - jednym słowem nic nie działa.. być może dysk jest wadliwy? (wątpię, bo pierwsza partycja śmiga idealnie)?

lynczu

  • Gość
Problemy z JFS
« Odpowiedź #11 dnia: 2006-05-02, 12:37:10 »
Usunalem w koncu wszystkie partycje i od nowa sformatowalem dysk. Teraz w biosie wyskakuje mi, ze dysk jest be, ("Status BAD, backup and replace")

Troche mi sie wierzyc nie chce, ze dysk juz umiera, probowalem zobaczyc go za pomoca HDD regeneratora, ale idzie jak krew z nosa, wiec zrezygnowalem. To chyba pytanie nie na to forum, ale moze ktos ma jakies doswiadczenie co moglbym w tej sytuacji zrobic? ( poza wybraniem sie do sklepu po nowy dysk ;)