Nowe posty

xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
Wczoraj o 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36
xx Problem z instalacją sterowników TL-WN821N (4)
2019-10-11, 23:15:00
xx Sprzet z Linuxem (1)
2019-10-11, 10:06:24
xx nadpisanie partycji domowej (6)
2019-10-03, 03:27:28
xx Screen flickering Deepin (4)
2019-10-02, 20:32:56
xx Pisanie bezpiecznych skryptow. (0)
2019-10-01, 19:42:01
xx Ciągle pojawiają się nowe wpisy w auth.log (1)
2019-09-27, 21:09:45
xx Pblem z montowaniem dysku sieciowego (3)
2019-09-22, 22:05:08

Autor Wątek: Czarny ekran po wyjściu z Xow  (Przeczytany 4986 razy)

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 254
    • Zobacz profil
Czarny ekran po wyjściu z Xow
« Odpowiedź #15 dnia: 2006-04-13, 13:48:51 »
2006-04-13 13:11:46 natrent napisał:

> to z AGP zaraz sprawdze :) tylko przeczytam gdzies jak to zrobic :)
 >
 > nerwowy troszke jestem - taka ma natura ;]
 >
 >
 > co do zachowania sie konsol. Jezeli juz włącze xy... to konsoli nie widać bez różnicy ile razy
 > tego nie odświeże. Wszystkie konsole są czarne. Ponad to nie moge wrocić do xow bo nawet
 > konsola pod którą są wlaczone xy jest wtedy czarna.
 >

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 254
    • Zobacz profil
Czarny ekran po wyjściu z Xow
« Odpowiedź #16 dnia: 2006-04-13, 14:36:02 »
2006-04-13 13:11:46 natrent napisał:

> to z AGP zaraz sprawdze :) tylko przeczytam gdzies jak to zrobic :)
 >
 > nerwowy troszke jestem - taka ma natura ;]
 
To teraz nerwy na bok, bo będziesz potrzebował dużo cierpliwości i czasu
żadnej gwarancji, że to co robisz pomoże.
Masz przecież, sprawny komputer,xterm na pewno działa, konsole w zasadzie też,
tyle że fglrx przejeło kontrolę nad wyświetlaniem , i twoja konsola to już nie jest
vga. Spawdź jeszcze w  /var/log /messages fragment dotyczący wyjścia z x-ów,
może tam coś będzie, zrób próbę wyjścia z x-ów poprzez init runlevel 3, albo podobna komenda w zależności od systemu, sprawdź też czy biosie nie przyciemniasz niepotrzebnie jakiś obszarów pamięci  (opcje vgashadow).

Jeśli nic nie pomaga to masz dwa wyjścia:
1. Przystosować jądro do do współpracy z fglrx - wydaje mi się, że na stronie
ATI są jakieś łaty na jądro,  tu zakładamy że konsola nadal pracuje w trybie vga.

2. Zmienić ustawienia konsoli tak, żeby umiała wyświetlać tryb narzucony przez
fglrx. Tu znowu masz do wyboru:
 wyświetlanie zgodne z   svgą   SVGA-textmode albo podobnie  lub
 zmiana frame-buffora, program nazywa się fb. (jeszcze jedna litera -łatwo znaj dziesz)

Tak czy owak nie spiesz się, poczytaj o wszytkim zanim przystąpisz do działania, może jeszcze ktoś znajdzie inne rozwiązanie albo skrytykuje moje uwagi, do czego zachęcam