Nowe posty

Autor Wątek: 3CXE589EC nie dziala internet mandriva2006free  (Przeczytany 4308 razy)

mspider

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« dnia: 2006-04-02, 11:49:06 »
Czy jest mozliwe zainstalowanie linuxa na dysku slave? Chodzi mi o to ze na pierwszym dysku, czyli master mam winxp i narazie przynajmniej nie chce sie go pozbywac. Na drugim dysku chce zainstalowac linuxa np. mandrive. Czy jest wogole cos takiego mozliwe i czy potem system normalnie by mi wystartowal?

zebra

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #1 dnia: 2006-04-02, 12:02:45 »
2006-04-02 11:49:06 mspider napisał:

> Czy jest mozliwe zainstalowanie linuxa na dysku slave? Chodzi mi o to ze na pierwszym dysku,
 > czyli master mam winxp i narazie przynajmniej nie chce sie go pozbywac. Na drugim dysku chce
 > zainstalowac linuxa np. mandrive. Czy jest wogole cos takiego mozliwe i czy potem system
 > normalnie by mi wystartowal?

Instalacja bez problemu. Jedynie pytanie gdzie zainstalijesz program rozruchowy? Bo tu jest kilka wyjść. Jak masz stacje dyskietek to może byc na dyskietce. Wtedy do uruchomienia linuksa wkładasz ją i start komputera. Dysk z windowsem pozostaje nietknięty.
Jak zainstalujesz w MBR pierwszego dysku to bedziesz miał przy starcie mozliwość wyboru systemu, ale to rozwiazanie moze stworzyc malutkie komplikacje w przyszłości w przypadku potrzeby przeinstalowania windowsa.
Trzecie wyjście to instalacja rozruchu linuksa w MBR drugiego dysku. Dysk pierwszy zostaje nienaruszony, ale do urychomienia linuksa trzebą bedzie każdorazowo w biosie ustawiać boot z hd slave, więc niepraktyczne.

medevacs

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #2 dnia: 2006-04-02, 01:40:11 »
Witam!

Pisze po raz pierwszy na forum. Tych wszystkich, ktorzy z rozpedu beda chcieli odeslac mnie do niedawno rozwiazanego bardzo podobnego watku w tym dziale uprzedzam, iz uwaznie czytalem ten watek i choc problem podobny to u mnie sytuacja lekko inna i problem mam nadal.

Mam starego lapa toshiba satellite 2100 cds (k6-2 400MHz, 160MB RAM, hdd 4,3 GB, grafa s3 virge itp.), dokupilem sobie do niego niedawno sieciowke 3com 3CXE589EC 16-bitowa na pcmcia. Mialem na lapie zainstalowany windows98, wszystko dzialalo jak nalezy czyli sieciowka, kabel itp sprawne. Zainstalowalem sobie mandrive 2006 free i internet nie dziala.

Mam neostrade i rozdzielam na kilka kompow routerem, NIE MAM wlaczonego DHCP, adresy IP przydzielam recznie. Adres routera 10.0.0.2 maska podsieci 255.0.0.0. Adres IP lapa na ktorym win98 dzialal bez problemu to 10.0.0.4. Na kompie stacjonarnym z ktorego teraz pisze, na ktorym mam rowniez ta sama mandrivie IP to 10.0.0.6 maska podsieci 255.0.0.0 router 10.0.0.2 DNS 10.0.0.2. W laptopie w konfiguracji komputera mandrivy robie identyczne ustawienia jak w stacjonarnym z wyjatkiem oczywiscie IP kompa i internet nie dziala. Moge jedynie spingowac "samego siebie", ping do routera czy do drugiego kompa to generalnie "destination host unreachable". Gdy kabel jest podlaczony do sieciowki dioda w sieciowce swieci. Dioda w switchu od portu do ktorego jest podlaczony kabel od sieciowki z lapa rowniez swieci, a gdy probuje cos pingowac to mruga.

ifconfig daje to:

eth0      Link encap:Ethernet  HWaddr 00:00:86:51:A1:26  
          inet addr:10.0.0.4  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:2589 (2.5 KiB)
          Interrupt:3 Base address:0x300

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:27 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3024 (2.9 KiB)  TX bytes:3024 (2.9 KiB)

dmesg | grep eth daje z kolei to:

eth0: 3Com 3c589, io 0x300, irq 3, hw_addr 00:00:86:51:A1:26
eth0: flipped to 10baseT
eth0: flipped to 10baseT
eth0: interrupt(s) dropped!

Nie znam sie na linuxach niestety ale co sam podejzewam to:
- dziwi mnie to carrier:1 w ifconfig, gdzies w necie ktos mial tez problem z karta na pcmcia i mial carrier:6 i mu powiedzieli, ze to zle, ze w zasadzie powinno byc 0, a ja mam 1.
- zastanawiam mnie rowniez to eth0: interrupt(s) dropped! Nie wiem o co w tym chodzi.

Zauwazylem, ze w linuxie IRQ sieciowki to 3. Czytajac jednak rozne watki na forach w sieci zauwazylem, ze problemem moze byc, iz jesli jest to karta combo to linux probuje laczyc sie nie tym wyjsciem dlatego nie dziala. Za radami z for sciagnalem ze strony 3com program do testowania i konfigurowania sieciowki i zeby poustawiac ja jak trzeba. Moge zmieniac wyjscie z auto sensne na TP (RJ45) albo Coax i nic to nie daje, z trybu windows/os2 na server, rowniez nic to nie dalo. Wlaczylem test i okazalo sie, ze test wywala sie przy sprawdzaniu przerwan, wypisuje ze jest konflikt. Sprawdzilem IRQ sieciowki i pokazalo 10 (a pod linuxem 3). Zmiana na irq=5 nic nie dala, linux i tak daje swoje 3. Zmienilem wiec w tym programie na 3 i co? program sie wywalil i robi tak zawsze gdy probuje ustawiac IRQ=3. Da sie ustawic tylko 5 albo 10, reszta ponoc zajeta. Nie moge poprzestawiac irq np karty dzwiekowej bo w biosie nie mam takiej mozliwosci.

Co z tym fantem zrobic? czy to faktycznie wina IRQ? mozna je gdzies zmienic pod linuxem? Prosze o pomoc.

zebra

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #3 dnia: 2006-04-02, 10:11:40 »
A jaki jest wynik:
route
?

medevacs

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #4 dnia: 2006-04-02, 15:10:16 »
2006-04-02 10:11:40 zebra napisał:

> A jaki jest wynik:
 > route
 > ?

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.0.0.0        *               255.0.0.0       U     10     0        0 eth0
default         10.0.0.2        0.0.0.0         UG    10     0        0 eth0

Nie znam sie ale nie wyglada to chyba to jak powinno prawda? Czy destination w pierwszej linijce nie powinno byc 10.0.0.2 (taki mam adres routera/bramy)?

zebra

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #5 dnia: 2006-04-02, 17:10:48 »
2006-04-02 15:10:16 medevacs napisał:

> 2006-04-02 10:11:40 zebra napisał:
 >
 > > A jaki jest wynik:
 >  > route
 >  > ?
 >
 > Kernel IP routing table
 > Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
 > 10.0.0.0        *               255.0.0.0       U     10     0        0 eth0
 > default         10.0.0.2        0.0.0.0         UG    10     0        0 eth0
 >
 > Nie znam sie ale nie wyglada to chyba to jak powinno prawda? Czy destination w pierwszej
 > linijce nie powinno byc 10.0.0.2 (taki mam adres routera/bramy)?

Tu jest ok. Zapytałem o to by wyeliminować najbardziej prostą  możliwą przyczynę. Ciekawe jednak, ze Twoja karta coś odbiera, tylko nic nie wysyła. Ja więcej nic nie potrafie pomóc.

medevacs

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #6 dnia: 2006-04-02, 22:57:25 »
2006-04-02 17:10:48 zebra napisał:

 > Tu jest ok. Zapytałem o to by wyeliminować najbardziej prostą  możliwą przyczynę. Ciekawe
 > jednak, ze Twoja karta coś odbiera, tylko nic nie wysyła. Ja więcej nic nie potrafie pomóc.

Dzieki za dobre checi, moze ktos inny pomoze?

Przegladam inne watki w podobnej tematyce ale do niczego nie moge sam dojsc :(

mastergda

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #7 dnia: 2006-04-03, 09:54:19 »
Pokaz co Ci wychodzi po wykonaniu komendy " ip a s "

medevacs

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #8 dnia: 2006-04-03, 11:41:29 »
2006-04-03 09:54:19 mastergda napisał:

> Pokaz co Ci wychodzi po wykonaniu komendy " ip a s "

szymon@laptop:~$ ip a s
1: lo: mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:00:86:51:a1:26 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.4/8 brd 10.255.255.255 scope global eth0
    inet6 fe80::200:86ff:fe51:a126/64 scope link
       valid_lft forever preferred_lft forever
3: sit0: mtu 1480 qdisc noop
    link/sit 0.0.0.0 brd 0.0.0.0

Tylko co istotne, to co wklejam tu wynik tej komendy ale uzyskany pod UBUNTU 5.10, bo dzisiaj w nocy zainstalowalem zeby sprawdzic czy tylko mandriva nie widzi netu. Ubuntu na tych samych ustawieniach rowniez ma identyczny problem. Co wiecej Feather Linux Live CD w ogole sie nie wlacza, zawiesza sie przy starcie w momencie gdy inicjuje sieciowke czy jakos tak (juz nie pamietam co tam dokladnie wypisywalo ale najpierw cos o pcmcia a potem o sterowniku od sieciowki).

medevacs

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #9 dnia: 2006-04-03, 22:36:26 »
Dodam wiecej, ze sprawdzilem na innym dzialajacym kablu sieciowke i dalej nic. Zainstalowalem na kompie WinXP zeby sprawdzic czy sieciowka sie w miedzyczasie nie popsula i pod XP jest ok. Jakby ktos nie wierzyl wrzucam pare logow:

ipconfig /all :

Konfiguracja IP systemu Windows
        Nazwa hosta . . . . . . . . . . . : LAPTOP
        Sufiks podstawowej domeny DNS . . . . . . :
        Typ węzła . . . . . . . . . . . . : Nieznany
        Routing IP włšczony . . . . . . . : Nie
        Serwer WINS Proxy włšczony. . . . : Nie
Karta Ethernet Połšczenie lokalne:
        Sufiks DNS konkretnego połšczenia :
        Opis . . . . . . . . . . . . . . :  Karta PC 3Com Megahertz LAN (589E) (Ethernet)
        Adres fizyczny. . . . . . . . . . : 00-00-86-51-A1-26
        DHCP włšczone . . . . . . . . . . : Nie
        Adres IP. . . . . . . . . . . . . : 10.0.0.4
        Maska podsieci. . . . . . . . . . : 255.0.0.0
        Brama domyœlna. . . . . . . . . . : 10.0.0.2
        Serwery DNS . . . . . . . . . . . : 10.0.0.2

ping do routera:

Badanie 10.0.0.2 z užyciem 32 bajt˘w danych:
OdpowiedŤ z 10.0.0.2: bajt˘w=32 czas<1 ms TTL=64
OdpowiedŤ z 10.0.0.2: bajt˘w=32 czas<1 ms TTL=64
OdpowiedŤ z 10.0.0.2: bajt˘w=32 czas<1 ms TTL=64
OdpowiedŤ z 10.0.0.2: bajt˘w=32 czas=1ms TTL=64

Statystyka badania ping dla 10.0.0.2:
    Pakiety: Wysˆane = 4, Odebrane = 4, Utracone = 0 (0% straty),
Szacunkowy czas bˆĽdzenia pakiet˘w w millisekundach:
    Minimum = 0 ms, Maksimum = 1 ms, Czas ˜redni = 0 ms

ping do onetu:

Badanie www.onet.pl [213.180.130.200] z užyciem 32 bajt˘w danych:
OdpowiedŤ z 213.180.130.200: bajt˘w=32 czas=137ms TTL=60
OdpowiedŤ z 213.180.130.200: bajt˘w=32 czas=131ms TTL=60
OdpowiedŤ z 213.180.130.200: bajt˘w=32 czas=32ms TTL=60
OdpowiedŤ z 213.180.130.200: bajt˘w=32 czas=32ms TTL=60

Statystyka badania ping dla 213.180.130.200:
    Pakiety: Wysˆane = 4, Odebrane = 4, Utracone = 0 (0% straty),
Szacunkowy czas bˆĽdzenia pakiet˘w w millisekundach:
    Minimum = 32 ms, Maksimum = 137 ms, Czas ˜redni = 83 ms

Winde juz wywalilem, w tej chwili na kompie znow jest Mandriva 2006 free. Prosze o pomoc.

medevacs

  • Gość
3CXE589EC nie dziala internet mandriva2006free
« Odpowiedź #10 dnia: 2006-04-04, 22:31:17 »
Dobra, mam gdzies ta sieciowke, sprzedam ja komus kto potrzebuje do windowsa bo w nim dziala, a sam do linuxa poszukam innej, bo widze, ze nic tylko problemy z nia w tym systemie.

Dzieki tym, ktorzy sie zainteresowali i probowali pomoc!