Nowe posty

Autor Wątek: bascom  (Przeczytany 4665 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
bascom
« dnia: 2006-03-27, 20:08:35 »
Witam!

Mam mały problem. Zinstalowalem sobie sterownuiki ATI w wersji 8.23.7 na moim SuSE 10.0 do Radeona 9250. Wszystko elegancko poszlo, stworzylem rpm\\'a, zainstalowalem i skonfigurowalem sax\\'em Xorg\\'a, a po resecie akceleracja juz dzialala.
Problem polega na tym, ze X\\'y mi sie teraz czasem wieszaja jak uzywam wygaszacza albo gry 3d. A najdziwniejsze jest  to, ze czesc wygaszaczy i gier dziala normalnie, a przy niektorych zawias, tak jak przy foobilard np. Komputer zdycha, caps lock nie dziala i pozostaje tylko hard reset.
Nie mam juz zadnych pomyslow co robic uruchamialem opcje \\"InternalAGPguart\\" ale to nie pomaga, moze wy macie jakies pomysly, pomocy......

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
bascom
« Odpowiedź #1 dnia: 2006-03-30, 16:48:03 »
dolanczam jeszcze output komendy glxinfo, moze ktos zauwazy tu cos nieprawidlowego...

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
 ...
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
 ...  
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9200 Series DDR Generic
OpenGL version string: 1.3.1050 (X4.3.0-8.23.7)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
bascom
« Odpowiedź #2 dnia: 2006-03-30, 17:03:46 »
no i jeszcze konfiguracja karty graficznej....

Section \\"Device\\"
  BoardName    \\"RV280 5960\\"
  BusID        \\"1:0:0\\"
  Driver       \\"fglrx\\"
  Identifier   \\"Device[0]\\"
  Option       \\"UseInternalAGPGART\\" \\"no\\"
  Option       \\"mtrr\\" \\"off\\"
  Option       \\"VideoOverlay\\" \\"on\\"
  Option       \\"OpenGLOverlay\\" \\"off\\"
  Option       \\"IgnoreEDID\\" \\"off\\"
  Option       \\"ScreenOverlap\\" \\"0\\"
  Option       \\"NoTV\\" \\"yes\\"
  Option       \\"TVStandard\\" \\"NTSC-M\\"
  Option       \\"TVHSizeAdj\\" \\"0\\"
  Option       \\"TVVSizeAdj\\" \\"0\\"
  Option       \\"TVHPosAdj\\" \\"0\\"
  Option       \\"TVVPosAdj\\" \\"0\\"
  Option       \\"TVHStartAdj\\" \\"0\\"
  Option       \\"TVColorAdj\\" \\"0\\"
  Option       \\"GammaCorrectionI\\" \\"0x00000000\\"
  Option       \\"GammaCorrectionII\\" \\"0x00000000\\"
  Option       \\"Capabilities\\" \\"0x00000000\\"
  Option       \\"CenterMode\\" \\"off\\"
  Option       \\"PseudoColorVisuals\\" \\"off\\"
  Option       \\"Stereo\\" \\"off\\"
  Option       \\"StereoSyncEnable\\" \\"1\\"
  Option       \\"FSAAEnable\\" \\"no\\"
  Option       \\"FSAAScale\\" \\"1\\"
  Option       \\"FSAADisableGamma\\" \\"no\\"
  Option       \\"FSAACustomizeMSPos\\" \\"no\\"
  Option       \\"FSAAMSPosX0\\" \\"0.000000\\"
  Option       \\"FSAAMSPosY0\\" \\"0.000000\\"
  Option       \\"FSAAMSPosX1\\" \\"0.000000\\"
  Option       \\"FSAAMSPosY1\\" \\"0.000000\\"
  Option       \\"FSAAMSPosX2\\" \\"0.000000\\"
  Option       \\"FSAAMSPosY2\\" \\"0.000000\\"
  Option       \\"FSAAMSPosX3\\" \\"0.000000\\"
  Option       \\"FSAAMSPosY3\\" \\"0.000000\\"
  Option       \\"FSAAMSPosX4\\" \\"0.000000\\"
  Option       \\"FSAAMSPosY4\\" \\"0.000000\\"
  Option       \\"FSAAMSPosX5\\" \\"0.000000\\"
  Option       \\"FSAAMSPosY5\\" \\"0.000000\\"
  Option       \\"UseFastTLS\\" \\"0\\"
  Option       \\"BlockSignalsOnLock\\" \\"on\\"
  Option       \\"ForceGenericCPU\\" \\"no\\"
  VendorName   \\"ATI\\"
EndSection

moze ktos zauwazy cos nieprawilowego, bo ja juz nie mam pomyslow, na suse 9.3 tez mi sie tak dzialo i mam juz szczerze awersje do ati....

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
bascom
« Odpowiedź #3 dnia: 2006-03-31, 09:49:38 »
Spróbuj pokombinować z opcjami – na początek może z:
Option       \\"UseInternalAGPGART\\" \\"yes\\"
Option       \\"mtrr\\" \\"on\\"


Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
bascom
« Odpowiedź #4 dnia: 2006-04-10, 17:26:35 »
2006-03-31 09:49:38 sikorm7 napisał:

> Spróbuj pokombinować z opcjami – na początek może z:
 > Option       \\"UseInternalAGPGART\\" \\"yes\\"
 > Option       \\"mtrr\\" \\"on\\"
 >
 >

niestety, kombinowalem z opcjami i nic to nie daje, moze ktos by mogl zalonczyc swoja konfiguracje X\\'ow, albo zna jakis link gdzie sa te wszystkie opcje karty graficznej opisane...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
bascom
« Odpowiedź #5 dnia: 2006-03-27, 18:52:00 »
Witam
Chciałby spytać czy istnieje kompilator bascoma pod linuxa
Pozdrawiam

Offline jan karwowski

  • Users
  • Guru
  • *****
  • Wiadomości: 844
    • Zobacz profil
bascom
« Odpowiedź #6 dnia: 2006-03-27, 19:39:59 »
Hmm.. Nigdy z tego nie korzystałem,
ale czy to nie jest normalny basic?

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 372
    • Zobacz profil
bascom
« Odpowiedź #7 dnia: 2006-03-27, 19:52:12 »
To najzwyklejszy basic z tym że to pakietu dołączone są gotowe biblioteki do obsługi peryferji takich jak układy
 1-wire czy chociażby wyświetlacze lcd . Oczywiście nie jest to sam kompilator tak jak np: avr-gcc bascom to całe środowisko począwszy od edytora przez kompilator i symulator a na programatorze kończąc.