Nowe posty

Autor Wątek: Anjuta -problem z linkowaniem pthread_create  (Przeczytany 4362 razy)

Offline bartek hudoba

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Anjuta -problem z linkowaniem pthread_create
« dnia: 2006-01-25, 16:40:25 »
Zainstalowalem program,wbijam sie na serwer i nie moge mowic :/
Wszystkich slychac tylko ja mowic nie moge. Sprawdzalem  na dwoch mikrofonach. Prosze o pomoc.

Offline asd asd

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 12
    • Zobacz profil
Anjuta -problem z linkowaniem pthread_create
« Odpowiedź #1 dnia: 2006-04-21, 11:42:38 »
2006-01-25 16:40:25 CormaCk napisał:

> Zainstalowalem program,wbijam sie na serwer i nie moge mowic :/
 > Wszystkich slychac tylko ja mowic nie moge. Sprawdzalem  na dwoch mikrofonach. Prosze o pomoc.
 
Odmutować mikrofon w stawieniach ?

Offline Marcin K

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
Anjuta -problem z linkowaniem pthread_create
« Odpowiedź #2 dnia: 2006-01-25, 14:49:27 »
Witam

Pracuje na Debianie Etch, jako ide wykożystuje Anjuta 1.2.4.
Definicja funkcji pthread_create() zawarta jest w pthread.h który jest włączony w źródło. Kompilacja programu przebiega bez problemu. Podczas linkowania dostaję komunikat:

/tmp/ccmKFdNL.o: In function 'main':dummy.c:(text+0xc8): undefined reference to 'pthread_create'
collect2: ld returned 1 exit status

Rozumiem że brakuje mi jakiejś dynamicznej biblioteki. Tylko nie wiem jakiej oraz gdzie i to jest właśnie moje pytanie.

Pozdrowienia

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
Anjuta -problem z linkowaniem pthread_create
« Odpowiedź #3 dnia: 2006-01-25, 15:09:45 »
-lpthread
?

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 10
    • Zobacz profil
Anjuta -problem z linkowaniem pthread_create
« Odpowiedź #4 dnia: 2006-01-25, 15:27:02 »
dokladnie jak poprzednik

gcc polik.c -lpthread

Offline Marcin K

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
Anjuta -problem z linkowaniem pthread_create
« Odpowiedź #5 dnia: 2006-01-25, 17:00:12 »
OK działa.

Wielkie dzięki. To było głupie pytanie :)

Pozdrowienia