Oprogramowanie > Instalacja oprogramowania

Instalacja DosBox

(1/2) > >>

:
Witam.

Szukalem sporo na Google i wszystko co znalazlem odnosilo sie jednak do mojej zaistnialej konfiguracji.

Problem moj polega na tym, ze XKB z XOrg przy uruchomieniu Gnome, wywala blad XKB i nie moge uzywac polskich liter (porobily sie skroty jak na layout EN czy US).

Dzialalo mi wsystko do momentu, gdy nie zachcialo mi sie zainstalowac jakiegos pakietu (abiword-cos), ktory wyrzucil mi slownik polski. Potem go sobie i tak doinstalowalem.

Pamietam, ze gdy system bym swieRZo po instalacji, to mialem ten sam problem, ale nagrzebalem cos w xorg, co spowodowalo pojawienie sie okienka GNOME z zapytaniem jakiej konfiguracji uzyc (Gnome czy Xorg) dla klawiatury.

Ponizej podaje moje ustawienia i zwracam uwage, ze na Driver \\"Keyboard\\" mi wywala wogole X\\'y.

xorg.conf
{
Section \\"InputDevice\\"

    Identifier   \\"Keyboard1\\"
    Driver   \\"kbd\\"

#    Identifier \\"Keyboard1\\"
#    Driver \\"Keyboard\\"
#    Option \\"XkbModel\\" \\"pc104\\"
#    Option \\"XkbLayout\\" \\"pl\\"
#    Option \\"XkbOptions\\" \\"grp:alt_shift_toggle\\"

    Option \\"XkbRules\\"   \\"xorg\\"
    Option \\"XkbModel\\"   \\"pc104\\"
    Option \\"XkbLayout\\"   \\"pl\\"
    Option \\"XkbVariant\\"   \\"pl\\"

EndSection
}

Jak widac probowalem z obecnie zakomentarzowanymi ustawieniami. Tylko nie znam sie na \\"XkbOptions\\" :-)

W Gnome mam ustawiony Leyout Polish, jako domyslny i dla wszystkich okien (jedna grupa).

Bez wzgledu co robie wyskakuje mi przy odpalaniu Gnome ponizszy blad w okienku (w dwuch okienkach hehe):
{
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
}

Tak wieNc sprawdzilem:
{
 [dla]# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = \\"xorg\\", \\"pc104\\", \\"pl\\", \\"pl\\", \\"\\"
_XKB_RULES_NAMES(STRING) = \\"xorg\\", \\"pc104\\", \\"pl\\", \\"pl\\", \\"\\"
 [dla]# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [pl  pl]
 model = pc104
 overrideSettings = false
 options = [altwin      altwin:super_win,grp    grp:alts_toggle]
}

Nie wiem co jest nie tak. Moze ktos poradzic? Aha. Polskie czcionki mam :-)

Z gory dzieNkuje :-)
Marcel

:
EDYTUJE:
Moze pomoze ponowne odpalenie tego programu do wybierania konfiguracji? Wie ktos jak go uruchomic? Bo jest on zasyty. Szukalem go w systemie pod slowem kluczowym xkb - bo nic innego nie wymyslilem...

Pozdrawiam
(milo mi ze jestem pierwszy na nowym forum)
Fajnie wymyslone - Dzieki TFURCOM :P

:
POŁOWA ROZWIĄZANA

Słuchajcie, głupia sprawa. Samo ustawiło się w pliku xorg.con coś takiego:
{
Option \\"XkbVariant\\" \\"pl\\"
}
z głupa dałem
{
Option \\"XkbVariant\\" \\"\\"
}
I mam polskie literki :-). Niestety nadal error wyskakuje :|

Pozdrawiam

:
Zasugerowany jedna z ksiazek o Linuksie utworzylem w katalogu domowym plik .gnomerc o zawartosci:

# ---- language-env DON\\'T MODIFY THIS LINE!

#set LANG
LANG=\\"pl_PL\\"
MM_CHARSET=\\"iso-8859-2\\"
SP_CHARSET=\\"iso-8859-2\\"
exprot LANG MM_CHARSET SP_CHARSET

# ---- language-env end DON\\'T MODIFY THIS LINE!


Blad zniknal.

U mnie nie mozna wpisywac polskich znakow (XFree86) :(

matt11:
Mam Mandrake'a 10.0 . Ściągnąłem DosBox'a (nie RPM'a, tylko pakiet źródłowy). Po wydaniu polecenia ./configure , po jakimś czasie program wyskakuje mi błąd: SDL version 1.2.0 not found . Co robić? W instalacki dodatkowego oprogramowania nie znalazłem żadnego SDL

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

Idź do wersji pełnej