Nowe posty

Autor Wątek: kernelu 2.6.11 i stery ATI  (Przeczytany 4821 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« dnia: 2005-06-08, 23:02:53 »
Sprawa jest taka ze boje sie wlaczac zbyt wiele programow. W pewnym momencie zaczyna dyskiem krecic tak ze wszystkie programy przestaja dzialac - nawet mysz nie reaguje. Raz go zostawilem zeby sie wyszumial ale krecil 2 godziny i nie dawal znaku zycia wiec wymieklem - pomaga tylko reset...

Czego on szuka na tym dysku i jak to wylaczyc?

Offline Remigiusz Witkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« Odpowiedź #1 dnia: 2005-06-08, 23:24:00 »
 > Czego on szuka na tym dysku i jak to wylaczyc?

  Ctrl+Alt+BackSpace - wylogowanie
  Ctrl+Alt+F1..F6 przejście do tekstowej powłoki
  Tak to wyłączyć :-)
  Wyłącz niepotrzebne usługi , albo ........dodaj RAM - u :-(
  Albo więcej informacji ...

Offline de Laurent

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1197
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« Odpowiedź #2 dnia: 2005-06-09, 11:19:25 »
Zobacz czy masz ustawiony plik wymiany swap i ile masz na niego przeznaczone...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 28
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« Odpowiedź #3 dnia: 2005-06-09, 23:12:36 »
 >   Ctrl+Alt+BackSpace - wylogowanie
 >   Ctrl+Alt+F1..F6 przejście do tekstowej powłoki
 >   Tak to wyłączyć :-)

jak sie rozkreci to nie reaguje ani na klawisze ani nie rusza kursorem myszy...

 >   Wyłącz niepotrzebne usługi , albo ........dodaj RAM - u :-(

RAMu ostatnio dowalilem :)

> Zobacz czy masz ustawiony plik wymiany swap i ile masz na niego przeznaczone...

ok troche sie pobawilem mksap i swapon mam nadzieje ze pomoze

Offline Kuba Gocławski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 15
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« Odpowiedź #4 dnia: 2005-06-08, 22:03:03 »
Witam!

Dziś cały dzień kombinowałem jakby te nieszczesne sterowniki zainstalować... Na Mandrake 9.2 i 10 szło mi zawsze bez problemu... teraz mam LE 2005 i w ogóle sprawa nie działa, niby rozpakowuję rpm, niby robię fglrxconfig, wszyskto jak trzeba... Zastosowałem chyba ze trzy artykuły dotyczące instalacji tych sterów (dwa z tej stronki, jeden z jakiegoś forum)... ale nadal mam załadowaną MESĘ... W końcu odkryłem, że to te sterowniki nie współdziałają trochę z 2.6.11 kernelem... Nie można go przekopmilowac czy coś (jestem zielony jeśli chodzo o Linuksa, tak btw:P)...
Doczytałem, że ktoś podał jakiegoś patcha, z którym wszystko ma działać... Link do opisu problemu: http://lists.debian.org/debian-user/2005/03/msg00674.html oraz link do udzielonej porady: http://lists.debian.org/debian-user/2005/03/msg00676.html ... Więc, ściągnąłęm tego całego patcha... Ale czy mógłby mi ktoś powiedzieć co ja mam z nim w ogóle zrobić? Tak krok po kroku, BARDZO proszę...

Pozdrawiam,
Gocek

Offline Grzegorz L

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« Odpowiedź #5 dnia: 2005-06-10, 14:57:47 »
Ale to info dotyczy wersji 8.10.19, dla najnowszych nie trzeba zadnego patcha i wszystko smiga jak ma.
Co znaczy nie mozna go przekompilowac ? Chodzi o sterowniki czy o kernel ? Masz najnowsze sterowniki z ATI (wesja 8.12.10)? Jakie bledy ci wyswietla ?

Offline Kuba Gocławski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 15
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« Odpowiedź #6 dnia: 2005-06-10, 21:49:25 »
2005-06-10 14:57:47 greg000 napisał:

> Ale to info dotyczy wersji 8.10.19, dla najnowszych nie trzeba zadnego patcha i wszystko smiga
 > jak ma.
 > Co znaczy nie mozna go przekompilowac ? Chodzi o sterowniki czy o kernel ? Masz najnowsze
 > sterowniki z ATI (wesja 8.12.10)? Jakie bledy ci wyswietla ?

Coś mi w ogóle temat posta dziwny wyszeðł, ale mniejsza z tym:P
Na wsŧepie - dizęki za odpowiedź...
Jest tak: mam Mandrive LE2005 z kernelem 2.6.11-6mdk . Chciałbym zainstalować oficjalne sterowniki od ATI. Wiem doskonale jak to się robi, bo na poprzednich Mandrake'ach mi się udawało. Ogólnie jest tak, że po odpaleniu tych rpmów (fglrx_6_8_0-8.12.10-1.i386.rpm) i zrobieniu fglrxconfig mam w fglrxinfo mense a w glxinfo Direct Rendering: Disabled. Poczytąłem trochę na forach i doszedłem do wniosku, że powinienem wejśc do /lib/modules/fglrx i tam odpalic make.sh (w build_module) a potem make.install w katalogu wyżej. No i tutaj napotykam problemy bo wyświetla mi dużo błędów w których powtarza się "request for member `(różne rzeczy)' in something not a structure or union".
Cały spis błędów kończy:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3313: error: request for member `copy_info' in something not a structure or union
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Błąd 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Błąd 2
make[1]: Leaving directory `/usr/src/linux-2.6.11-6mdk'
make: *** [kmod_build] Błąd 2
build failed with return value 2

I właśnie tu podobno był jakiś błąd związany z jajkiem 2.6.11 i trzeba było użyć patcha na niekŧórych plikach z /lib/modules/fglrx/build_mod/
Po czym make.sh i make_install.sh odpalało... Ale nawet wtedy po zrobieniu fglrxconfig po zresetowaniu kompa nadal mialem stery mensy i brak direct renderingu...
Już w ogóle nie wiem co robić... próbowałem przeróżnych metod, a sterowniki ATI z direct rendeirngiem po prostu się nie ładują :/

Aha, jeszcze próbowałem sterowników DRI (gdzieś w artykułach o tym było) ... Ale wtedy przy uruchamianiu Xów (w logu to wyczytałem) robił się błąd:
R200DRIScreenInit failed
DRI version = 5.0.0, expected 4.1.0). Disabling DRI

i Direct Renderingu nadal nie było :P

Ogólnie rzecz biorąc LE2005 mi się bardzo podoba, bo ma rózne bajerki (n.p. bardzo dobre wsparcie dla kart radiowych), ale z tego co czytałem odpalenie sterów ati na kernelu 2.6.11 graniczy z niemożliwością...
Także chyba będę używał Windy do gier, a jak wymienię sobie kartę grafiki to na GeForce'a :P I tak chcę to zrobić w tym roku, najwyżej trochę gry na linuxie poczekają...

Ale jeśli ktoś miałby jakieś sugestie to nie odrzucę pomocy... albo tutaj albo na gg 91079 (niewidoczny bywam) :)

Pozdrawiam,
Gocek

Offline Grzegorz L

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
kernelu 2.6.11 i stery ATI
« Odpowiedź #7 dnia: 2005-06-11, 11:14:34 »
Racja jednak wymagany jest patch do 2.6.11 :) Jakos to przeoczylem :)
Zglos sie do mnie na emaila to przesle ci patche do ATI.