Nowe posty

xx Pierwsze kroki w Arch (9)
Wczoraj o 23:39:51
xx DBus (0)
Wczoraj o 12:47:35
xx Przedni panel (1)
2022-05-20, 01:34:35
xx Modem Medion S4222 jak zainstalować aplikację do jego obsługi? (52)
2022-05-18, 10:14:49
xx Strona o testach penetracyjnych, hackingu (33)
2022-05-18, 08:09:16
xx Nadawanie uprawnień przy kopiowaniu themes do katalogu (15)
2022-05-17, 21:18:16
xx Pobieraniu pliku zdalnie poprzez VPN (2)
2022-05-16, 20:49:59
xx Obrócony obraz lubuntu, xubuntu na lenovo Miix 320 (5)
2022-05-16, 15:18:17
xx instalacja amdgpu dla RS880 (3)
2022-05-16, 07:21:17
xx Problem z dźwiękiem. (0)
2022-05-15, 18:46:51

Autor Wątek: Failed to initialize nvidia kernel module  (Przeczytany 4462 razy)

adam-s15

  • Gość
Failed to initialize nvidia kernel module
« dnia: 2005-12-26, 16:13:31 »
Witam! Zainstalowaem rozszerzenie MetaBar ( http://www.kde-look.org/content/show.php?content=21168 ) z rpmki, ale nie wiem jak je aktywować. Proszę o pomoc. Dzieki
Adam

kwazar

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #1 dnia: 2005-12-26, 20:27:33 »
2005-12-26 16:13:31 adam-s15 napisał:

> Witam! Zainstalowaem rozszerzenie MetaBar (
 > http://www.kde-look.org/content/show.php?content=21168 ) z rpmki, ale nie wiem jak je
 > aktywować. Proszę o pomoc. Dzieki
 > Adam
po zainstalowaniu metabar uruchom konqerora i na pasku bocznym mozesz go sobie dodac...

debrah

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #2 dnia: 2005-12-26, 13:33:22 »
Niedawno znajomy namowil mnie do zainstalowania Gentoo. Pierwsze, za co zamierzalam sie zabrac, byla instalacja sterownikow do mojej karty GeForce 4 Ti 4200. Postapilam zgodnie z http://www.gentoo.org/doc/pl/nvidia-guide.xml, jednakze x'y nie chca sie odpalic. Fragment Xorg.0.log:

=================================
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 565
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xE8000000
(--) NVIDIA(0): MMIO registers at 0xFD000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
=================================

oraz sekcje module, device i screen z xorg.conf

=================================
Section "Module"
   Load   "bitmap"
   Load   "dbe"
   Load   "ddc"
   #Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "record"
   Load   "type1"
   Load   "vbe"
EndSection

Section "Device"
   Identifier   "NVIDIA Corporation NV25 [GeForce4 Ti 4200]"
   Driver      "nvidia"
   BusID      "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA Corporation NV25 [GeForce4 Ti 4200]"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection
=================================


Podejrzewam, ze ma to cos moze wspolnego z frame bufferem, ale nie mam zupelnie pojecia, gdzie szukac pomocy..

lynczu

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #3 dnia: 2005-12-26, 14:13:20 »
Uruchomilam Gentoo bez framebuffera (tak mi sie przynajniej wydaje, usunalem po prostu opcje kernela do bootowania z fb)
i otrzymalam ten sam wynik, wiec byc moze to nie jest wina konfikltu z fb. Najgorzej, iz nie wiem gdzie szukac, bo informacje o bledzie to jakies takie skromne.. jakies wskazowki?

debrah

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #4 dnia: 2005-12-26, 14:14:43 »
Powyzsza wypowiedz powinna zosta wyslana z mojego konta.. takie to zaslugi korzystania z jednego komputera :-)

gomath

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #5 dnia: 2005-12-26, 15:40:06 »
Nie zapomniałeś załadować modułu nvidii? :)

man lsmod
man modprobe

debrah

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #6 dnia: 2005-12-26, 15:49:49 »
2005-12-26 15:40:06 gomath napisał:

> Nie zapomniałeś załadować modułu nvidii? :)

# lsmod
Module        Size    Used by
nvidia     3465820         0

:)

pisalam, ze dzialam zgodnie z przewodnikiem, wiec wszystkie takie banalne rzeczy sa juz raczej wykonane..

> Nie zapomniałeś

ps. zapomnialas, wczesniej byla literowka ;)

chmooreck

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #7 dnia: 2005-12-26, 15:50:27 »
ktora wersje sterownikow instalujesz ?

debrah

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #8 dnia: 2005-12-26, 15:56:00 »
Problem jest chyba w tym, ze nie zostaje rozpoznana karta

# cat /proc/driver/nvidia/cards/0
Model:           GeForce4 Ti 4200
IRQ:             19
Video BIOS:      ??.??.??.??.??
Card Type:       AGP

podczas startu modul jest chyba ladowany:

# dmesg | grep NVIDIA
nvidia: module license 'NVIDIA' taints kernel.
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-6629  Wed Nov  3 13:12:51 PST 2004

znalazlam, ze to moze byc cos ze sterownikami, dokladnie z wersja 6629

debrah

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #9 dnia: 2005-12-26, 22:09:49 »
> znalazlam, ze to moze byc cos ze sterownikami, dokladnie z wersja 6629

wydawalo mi sie, ze przyczyna tego "niedzialania"moze byc to, ze x'y kompilowane byly starszym kompilatorem niz sterowniki nvidii. dodatkowo znalazlem gdzies na forum, ze flaga -O3 mzoe powodowac takie zachowanie sterownikow. Przekompilowalam wszystko od nowa i niestety dalej uzyskuje to, co wczesniej. Nie mam juz pojecia, co moze byc tego przyczyna. Jak moge sprawdzic, dlaczego nie jest wykrywana moja karta?

debrah

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #10 dnia: 2005-12-26, 22:11:59 »
> dodatkowo znalazlem gdzies na forum, ze flaga -O3

znalazlam*, poza tym czy aby wszystkie wpisy w sekcji Modules sa poprawne? byc moze to tu tkwi problem..

debrah

  • Gość
Failed to initialize nvidia kernel module
« Odpowiedź #11 dnia: 2005-12-26, 22:40:06 »
Wystarczylo zmienic sterowniki na te z serii 8xxx. Rzeczywiscie, te z 6xxx niechetnie wspolpracuja z kernelem 2.6.x