Nowe posty

Autor Wątek: instalacja asystenta google - problem  (Przeczytany 449 razy)

Offline lisman

  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
instalacja asystenta google - problem
« dnia: 2024-02-29, 21:49:16 »
Witam. Mam problem z zainstalowaniem asystenta Google na Armbianie.
Podczas końcowego etapu przesyłania pliku JSON wyłania się ten problem:
- podaje opis z konsoli w załączniku.

Robię asystenta według instrukcji podanej na stronie google.
Chyba brakuje jakieś biblioteki , albo ten plik json jest źle skonfigurowany na stronie developera google .
Kilka razy to instalowałem , nawet jakieś inne sposoby znajdowałem , tez nie mogłem zainstalować tego asystenta.
inne sposoby polegały na instalacji ze skryptu , na tej innej metodzie znów inne błędy były .
Wróciłem do tej wersji instalacji ze strony google .
Lecz nadal ten sam problem.
Będę bardzo wdzięczny za pomoc
« Ostatnia zmiana: 2024-02-29, 21:51:23 wysłana przez lisman »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3062
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: instalacja asystenta google - problem
« Odpowiedź #1 dnia: 2024-03-01, 06:20:59 »
Hmmm... A co mówi przedostatnia linijka pliku?

Plus ImportError: cannot import name Mapping from 'collections'.
« Ostatnia zmiana: 2024-03-01, 16:51:38 wysłana przez Paweł Kraszewski »
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline lisman

  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Odp: instalacja asystenta google - problem
« Odpowiedź #2 dnia: 2024-03-06, 11:16:30 »
Tak , wiem co mówi ostatnia linijka . requests library jest instalowane wraz z narzędziami google , próbowałem zainstalować osobno , lecz jest nadal to samo , gdzieś wyczytałem , że może to byc wina nowszej wersji pythona , na tej wersji armbiana mam wersje 3.10 ,pisało gdzieś , że trzeba 3,9 albo 3,8 (tv box na amalogic s905 )
Tą metodą instalowałem na Raspbian ( raspberry pi 4 ), tam mam wersje pythona 3,9 i wyskoczył komunikat :

(env) pi@raspberrypi:~ $ google-oauthlib-tool --scope https://www.googleapis.com/auth/assistant-sdk-prototype       --save --client-secrets /home/pi/client_secret_xxxxx.apps.googleusercontent.com.json
Traceback (most recent call last):
  File "/home/pi/env/bin/google-oauthlib-tool", line 8, in <module>
    sys.exit(main())
  File "/home/pi/env/lib/python3.9/site-packages/click/core.py", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/home/pi/env/lib/python3.9/site-packages/click/core.py", line 697, in main
    rv = self.invoke(ctx)
  File "/home/pi/env/lib/python3.9/site-packages/click/core.py", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/pi/env/lib/python3.9/site-packages/click/core.py", line 535, in invoke
    return callback(*args, **kwargs)
  File "/home/pi/env/lib/python3.9/site-packages/google_auth_oauthlib/tool/__main__.py", line 95, in main
    creds = flow.run_local_server()
  File "/home/pi/env/lib/python3.9/site-packages/google_auth_oauthlib/flow.py", line 444, in run_local_server
    webbrowser.get(browser).open(auth_url, new=1, autoraise=True)
  File "/usr/lib/python3.9/webbrowser.py", line 65, in get
    raise Error("could not locate runnable browser")
webbrowser.Error: could not locate runnable browser
« Ostatnia zmiana: 2024-03-06, 11:18:09 wysłana przez lisman »