Nowe posty

Autor Wątek: [Rozwiązany] Jak wyłączyć aktualizację jednej , konkretnej paczki ?  (Przeczytany 277 razy)

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 476
    • Zobacz profil
Jak w temacie, nowa wersja modemmanager psuje mi modem LTE. Jak zrobić żeby nie pojawiała się w dostępnych uaktualnieniach ?
« Ostatnia zmiana: 2023-03-05, 11:52:09 wysłana przez mackeire »

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2649
  • 1709
    • Zobacz profil
Odp: Jak wyłączyć aktualizację jednej , konkretnej paczki ?
« Odpowiedź #1 dnia: 2023-03-05, 01:12:14 »
1. Zgaduje że to neon kde

2. Doczytałem że to jest oparte o Ubuntu
( w tej wersji co pobralem tez jest nazwa Ubuntu w "uname -a" )

3. Zgaduję że to może Ci pomóc  https://help.ubuntu.com/community/PinningHowto
Chodzi o to żeby stworzyć odpowiedni plik w katalogu /etc/apt/preferences.d/  tak jak podano w przykładzie
Package: firefox-3.0
Pin: release n=hardy
Pin-Priority: -10

Nazwa pliku powinna mieć teoretycznie znaczenie. A dokładniej jej numer.
Ten numer to oznaczenie priorytetu kolejności wczytywania pliku.
https://manpages.debian.org/testing/apt/apt_preferences.5.pl.html

Więc może coś w tym stylu  pomoże /etc/apt/preferences.d/50-zablokowane
Package: modemmanager
Pin: version 1.18.6-1
Pin-Priority: 1001
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 476
    • Zobacz profil
Odp: Jak wyłączyć aktualizację jednej , konkretnej paczki ?
« Odpowiedź #2 dnia: 2023-03-05, 10:29:40 »
Screen z pierwszego postu to graficzna nakładka na PackageKit i nie używa apta.
Jak to zablokować w apcie to ja wiem, ale nie działa.
Jest jeszcze interfejs tekstowy i tam widać zablokowane paczki , tylko gdzie jest jakiś plik konfig żeby dopisać modemmanagera do listy zablokowanych ?

pkcon get-updates
Pobieranie aktualizacji       [=========================]         
Wczytywanie pamięci podręcznej[=========================]         
Ukończono                    [=========================]         
Zablokowana     grub-efi-amd64-bin-2.06-2ubuntu14.1.amd64 (ubuntu-jammy-updates-main)   GRand Unified Bootloader, version 2 (EFI-AMD64 modules)
Zablokowana     grub-efi-amd64-signed-1.187.3~22.04.1+2.06-2ubuntu14.1.amd64 (ubuntu-jammy-updates-main)     GRand Unified Bootloader, version 2 (EFI-AMD64 version, signed)
Bug fix         modemmanager-1.20.0-1~ubuntu22.04.1.amd64 (ubuntu-jammy-updates-main)   D-Bus service for managing modems
Zablokowana     python3-software-properties-0.99.22.6.all (ubuntu-jammy-updates-main)   manage the repositories that you install software from
Zablokowana     shim-signed-1.51.3+15.7-0ubuntu1.amd64 (ubuntu-jammy-updates-main)      Secure Boot chain-loading bootloader (Microsoft-signed binary)
Zablokowana     software-properties-common-0.99.22.6.all (ubuntu-jammy-updates-main)    manage the repositories that you install software from (common)
Zablokowana     software-properties-qt-0.99.22.6.all (ubuntu-jammy-updates-universe)    manage the repositories that you install software from (Qt)
Zablokowana     tcpdump-4.99.1-3ubuntu0.1.amd64 (ubuntu-jammy-updates-main)     command-line network traffic analyzer

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 476
    • Zobacz profil
Odp: Jak wyłączyć aktualizację jednej , konkretnej paczki ?
« Odpowiedź #3 dnia: 2023-03-05, 11:27:07 »
Okay,
 doczytałem że packagekit to też taka jakby nakładka (ale *****, po co ?)  i w debianowatych używa apta pod spodem.

Pliczek  /etc/apt/preferences.d/modemmanager
Package: modemmanager
Pin: version 1.18.6-1
Pin-Priority: 1001

załatwił sprawę :)

Co ciekawe , próba zablokowania w synapticu nie przyniosła rezultatu. Owszem, synaptic widzi plik z zablokowaną wersją ale packagekit/pkcon/odkrywca już nie i domaga się aktualizacji ...
« Ostatnia zmiana: 2023-03-05, 11:53:56 wysłana przez mackeire »

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2649
  • 1709
    • Zobacz profil
Ja mogę tylko zgadywać.
1. Komuś nie chciało się edytować Synaptic, ale chciało się przystosować PackageKit
- Ponieważ ze strony https://wiki.debian.org/PackageKit można wyczytać że
PackageKit wspiera już  Flatpak, Snap.
Poza tym PackageKit kiedyś był na Fedorę, a tam domyślnie nie było apt-a czy paczek .deb.

2. Zgaduję że
- Może w Synaptiku nie zadziałało bo może inne pakiety lub repozytorium miały wyższy priorytet
- Nie wiem też gdzie Synaptic zapisuje swoją konfigurację, możliwe że w osobnym / swoim miejscu.
Jeśli są w osobnym miejscu to PackageKit  tego nie będzie widział.

Swoją drogą to i tak dobrze że to działa.
Cytuj
The default PackageKit backend in Debian is set to APTcc, as it has less bugs
« Ostatnia zmiana: 2023-03-05, 12:33:19 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.