Nowe posty

Autor Wątek: Samba - demony leża i nie chca sie podnieść!  (Przeczytany 4325 razy)

Offline Kamil B******

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 12
    • Zobacz profil
Samba - demony leża i nie chca sie podnieść!
« dnia: 2005-06-08, 11:42:12 »
Zainstalowałem, żeby wypróbować, shella o nazwie ZSH. Wszystko działa, ale nie wygląda najlepiej.
W bashu na konsoli wyświetla:
nazwa_uzytkownika@tux katalog $

Dzięki czemu wiem bez używania dodatkowych poleceń kim jestem i w jakim katalogu jestem.

W ZSH wyświetla jakąś chińszczyznę:
[033[01;32m]u@h [033[01;34m]W $ [033[00m]

Poza tym chyba wszystko działa dobrze.

Jak zmienić, by wyglądało to podobnie jak w bashu?

Offline Kamil B******

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 12
    • Zobacz profil
Samba - demony leża i nie chca sie podnieść!
« Odpowiedź #1 dnia: 2005-06-08, 13:07:40 »
2005-06-08 11:42:12 profeto napisał:

> Zainstalowałem, żeby wypróbować, shella o nazwie ZSH. Wszystko działa, ale nie wygląda
 > najlepiej.
 > W bashu na konsoli wyświetla:
 > nazwa_uzytkownika@tux katalog $
 >
 > Dzięki czemu wiem bez używania dodatkowych poleceń kim jestem i w jakim katalogu jestem.
 >
 > W ZSH wyświetla jakąś chińszczyznę:
 > [033[01;32m]u@h [033[01;34m]W $ [033[00m]
 >
 > Poza tym chyba wszystko działa dobrze.
 >
 > Jak zmienić, by wyglądało to podobnie jak w bashu?


Sorki za fatygę, już poradziłem sobie.
Były małe błędy w .zshrc, ale już naprawione

Offline Jarosław Bartnicki

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 39
    • Zobacz profil
Samba - demony leża i nie chca sie podnieść!
« Odpowiedź #2 dnia: 2005-06-07, 23:43:17 »
witam
temat napewno wałkowany - ale...moze opowiem

Zainstalowalem sambe 2.2.12 kompilacja przeszla bez problemow, jednak demony nie chca sie odpalac.
Swat startuje jak sie nalezy ale takze z jego poziomu nie moge uruchomic samby.
Nic nie przychodzi mi do glowy.

Jesli ktos by mi powiedzial - jak wywolac logi ktore powiedza mi gdzie jest blad to sam sproboje popracowac nad tym, no ale jesli jest gotowe lekarstwo to z gory dziekuje.

astral

Offline Jarosław Bartnicki

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 39
    • Zobacz profil
Samba - demony leża i nie chca sie podnieść!
« Odpowiedź #3 dnia: 2005-06-08, 00:04:02 »
witam ponownie
no jakos sobie poradzilem :)

ale wracam - moze ktos bedzie mial podobny problem.
wiec.

uruchomilem sambe poprzez funkcje logowania:
./smbd -l /home/log

pozniej loga otworzylem - oto jego zawartosc:
[1999/01/02 01:54:27, 0] smbd/server.c:main(791)
  smbd version 2.2.12 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2002
[1999/01/02 01:54:27, 1] lib/debug.c:debug_message(258)
  INFO: Debug class all level = 1   (pid 553 from pid 553)
[1999/01/02 01:54:27, 0] lib/debug.c:reopen_logs(348)
  Unable to open new log file /var/log/samba/log.smbd: No such file or directory
[1999/01/02 01:54:27, 0] lib/debug.c:reopen_logs(348)
  Unable to open new log file /var/log/samba/log.smbd: No such file or directory
[1999/01/02 01:54:27, 0] passdb/secrets.c:secrets_init(44)
  Failed to open /etc/samba/secrets.tdb
[1999/01/02 01:54:27, 0] smbd/server.c:main(835)
  standard input is not a socket, assuming -D option
[1999/01/02 01:54:27, 0] passdb/machine_sid.c:pdb_generate_sam_sid(163)
  pdb_generate_sam_sid: Failed to store generated machine SID.
[1999/01/02 01:54:27, 0] smbd/server.c:main(877)
  ERROR: Samba cannot create a SAM SID.
[1999/01/02 01:57:15, 0] smbd/server.c:main(791)
  smbd version 2.2.12 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2002
[1999/01/02 01:57:15, 1] lib/debug.c:debug_message(258)
  INFO: Debug class all level = 1   (pid 571 from pid 571)

za pierwszym razem nie mialem wogole ustawionego skryptu smb.conf  w katalogu /usr/local/samba/lib
pozniej bledy w konfiguracji ktore widac o gory.

poprawilem plik i dziala.

Offline Grzegorz Świtkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 516
    • Zobacz profil
Samba - demony leża i nie chca sie podnieść!
« Odpowiedź #4 dnia: 2005-06-08, 08:49:30 »
> Zainstalowalem sambe 2.2.12 kompilacja przeszla bez problemow, jednak demony nie chca sie
 > odpalac.
Jak sie kompiluje program samemu to trzeba byc przygotowanym na to, ze niekoniecznie make install dopisze odpowiednie skrypty startowe. Zatem trzeba pamietac aby je sobie stworzyc/skopiowac lub ewentualnie dopisac smbd/nmbd do inetd.