Nowe posty

Autor Wątek: System pakietów jest uszkodzony (Linux Ubuntu 20.04 LTS)  (Przeczytany 2542 razy)

Offline Trish_Rye

  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Cześć :)

Jestem nowicjuszem w zakresie Linuxa. Dostałam "w spadku" laptop z Ubuntu 20.04 LTS i od 2-3 tygodni próbuję go zaktualizować. Niezależnie od tego czy chodzi o bieżące aktualizacje obecnego systemu, czy próbę przejścia na najnowszy Ubuntu (aktualizacje mi to proponują same), dostaję taki komunikat:

******************************************************************

System pakietów jest uszkodzony
Proszę sprawdzić, czy używane są repozytoria osób trzecich. Jeśli tak, to proszę je wyłączyć, ponieważ są częstym źródłem problemów.
Następnie proszę uruchomić następujące polecenie w terminalu: apt-get install -f
Transaction failed: System pakietów jest uszkodzony
 Zależności dla następujących pakietów, nie zostały spełnione:

apt-utils: Depends: apt (= 2.0.6) ale 2.0.9 jest zainstalowany
           Depends: libc6 (>= 2.14) ale 2.31-0ubuntu9.9 jest zainstalowany
           Depends: libgcc-s1 (>= 3.0) ale 10.3.0-1ubuntu1~20.04 jest zainstalowany
           Depends: libstdc++6 (>= 9) ale 10.3.0-1ubuntu1~20.04 jest zainstalowany

*****************************************************

Nie mam pojęcia jak mam wykorzystać te dane...

Przy ostatniej aktualizacji był jakiś problem z dockerem, ale wszystko się zaktualizowało i nie zapisałam niestety treści komunikatu...

Offline kszyhu

  • Nowy na forum
  • *
  • Wiadomości: 44
    • Zobacz profil
Odp: System pakietów jest uszkodzony (Linux Ubuntu 20.04 LTS)
« Odpowiedź #1 dnia: 2022-09-06, 16:50:43 »
w komunikacie masz napisane, w terminalu wydaj komendę:
sudo apt-get install -f

Offline Profesor101

  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Odp: System pakietów jest uszkodzony (Linux Ubuntu 20.04 LTS)
« Odpowiedź #2 dnia: 2022-09-30, 23:52:37 »
Może Zrób Instalacje Na Nowo? O Ile Nie Masz na nim istotnych danych

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2611
  • 1709
    • Zobacz profil
Odp: System pakietów jest uszkodzony (Linux Ubuntu 20.04 LTS)
« Odpowiedź #3 dnia: 2022-10-01, 15:44:17 »
Cytuj
Nie mam pojęcia jak mam wykorzystać te dane...
Cytuj
apt-utils: Depends: apt (= 2.0.6) ale 2.0.9 jest zainstalowany
Wydaje mi sie że...
Nie możesz zaktualizować apt-utils ponieważ wymaga starszych pakietów.
Zaktualizowanie systemu może grozić jego uszkodzeniem,
dlatego nie jest kontynuowana automatycznie.
Nie polecam aktualizować systemu na siłę.

Doświadczony użytkownik jeśli korzysta z dodatkowych repozytoriów oprogramowania,
to powinien je sprawdzić w pierwszej kolejności.
I odznaczyć jeśli dodatkowe repozytoria są zbyt przestarzałe.
Wtedy aktualizacja powinna być już możliwa.
( Nie używam wersji 20 i nie chce mi się ściągać systemu by sprawdzić jakie repozytoria to są podstawowe )

Jeśli aktualizacja grozi usunięciem jakiegoś ważnego dla użytkownika oprogramowania,
To zalecane jest zaktualizowanie całego systemu do nowszej wersji.
W tym przypadku do Ubuntu 22.04.

Niestety piekło zależności w Linuxie czasami sprawia że nawet podstawowe repozytorium,
może zawierać błędy i aktualizacja może być nie możliwa.
Wtedy także zaleca się aktualizację systemu do nowszej.

Czasami da się zaktualizować cały system do nowszej wersji bez jego ponownego instalowania.
Ale nie jest to zalecane i też nie polecam.
Ponieważ czasami może się nie udać lub powodować problemy.

Przed instalacją systemu zawsze zalecane jest kopiowanie ważnych plików w bezpieczne miejsce.

Bardzo przydatna jest komenda
Cytuj
inxi -Fxxrz
Pokazuje jaki masz system, sprzęt i repozytoria, np. dla 22.04:
 Active apt repos in: /etc/apt/sources.list
    1: deb http://pl.archive.ubuntu.com/ubuntu/ jammy main restricted
    2: deb http://pl.archive.ubuntu.com/ubuntu/ jammy-updates main restricted
    3: deb http://pl.archive.ubuntu.com/ubuntu/ jammy universe
    4: deb http://pl.archive.ubuntu.com/ubuntu/ jammy-updates universe
    5: deb http://pl.archive.ubuntu.com/ubuntu/ jammy multiverse
    6: deb http://pl.archive.ubuntu.com/ubuntu/ jammy-updates multiverse
    7: deb http://pl.archive.ubuntu.com/ubuntu/ jammy-backports main restricted universe multiverse
    8: deb http://security.ubuntu.com/ubuntu jammy-security main restricted
    9: deb http://security.ubuntu.com/ubuntu jammy-security universe
    10: deb http://security.ubuntu.com/ubuntu jammy-security multiverse
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.