Nowe posty

Autor Wątek: audio debian problem  (Przeczytany 893 razy)

Offline ratus

  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
audio debian problem
« dnia: 2021-11-07, 05:15:29 »
W dystrybucjach Debiana-10 (i jedenastej też) występuje problem z podsystemem audio. Mianowicie, sytem audio startuje dopiero w momencie, gdy uruchamia się aplikacja używająca dźwięku (audacious, mpv, film na YT i.t.d.) Zanim to nastapi, w głośnikach słychać brum! Problem ustapił, gdy linux-image-4.19* zastąpiłem linux-image-4.9.0* lub jeszcze starszym. To samo występuje w forkach Debiana (też Ubuntu), ale - nie we wszystkich, np. MX-19 tego nie ma. Co można zrobić, aby podsystem audio "zapinał się" od razu po starcie systemu (tak jak było we wcześniejszych wersjach i jak dalej jest w innych dystrybucjach)?
« Ostatnia zmiana: 2021-11-07, 05:19:10 wysłana przez ratus »

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 405
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #1 dnia: 2021-11-07, 13:26:09 »
a co pokazuje wynik polecenia
systemctl --user status pulseaudio

??

Offline ratus

  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #2 dnia: 2021-11-07, 20:49:27 »
$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2021-11-07 20:45:07 CET; 3min 13s ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 654 (pulseaudio)
      Tasks: 3 (limit: 4414)
     Memory: 19.2M
        CPU: 120ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pulseaudio.service
             └─654 /usr/bin/pulseaudio --daemonize=no --log-target=journal

lis 07 20:45:02 crbang systemd[619]: Starting Sound Service...
lis 07 20:45:07 crbang systemd[619]: Started Sound Service.
-------------------------
Wynik polecenia j.w. jest w momencie, gdy dźwięk nie jest odtwarzany - występuje BRUM!
Po uruchomieniu odtwarzania dźwieku (audacious), brum zanika, dzwięk jest prawidłowy, a polecenie j.w. daje odczyt identyczny (różnica: Memory: 19,4  CPU: 185ms)
-------------------
Próbowałem wywalić Pulseaudio i używać tylko Alsa. Bez zmian - brum, zanikający po uruchomieniu odtwarzania dzw.
« Ostatnia zmiana: 2021-11-07, 21:14:37 wysłana przez ratus »

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 405
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #3 dnia: 2021-11-07, 23:06:01 »
a próbowałeś zmieniać  ustawienia w
alsamixer
  ??
Nie wygląda mi to na problem z pulse.

Jaka tam jest karta dźwiękowa ?  Może potrzebuje firmware którego Debian nie dostarcza 'z pudełka'
« Ostatnia zmiana: 2021-11-07, 23:08:07 wysłana przez mackeire »

Offline ratus

  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #4 dnia: 2021-11-08, 01:46:53 »
Jedyne, co usuwa problem, to zmiana kernela, poprzez zainstalowanie pakietu "linux-image-older" na taki, który nie bruździ, bo jest skompilowany "po staremu". Ale to rozwiązanie mało eleganckie, podpinanie starego kernela do nowego systemu, w dodatku metodą prób i błędów, nie daje mi satysfakcji.  A w ogóle, to szukałem (nie znalazłem) wiadomości, czy ten problem występuje tyko u mnie, czy jest nagminny? A wypróbowałem wiele dystrybucji i to wystepuje tylko w debianowych, z kernelem nowszym niż 4.9-*. czyli od Debiana-10. Występowanie tego brumu można stwierdzić już podczas odpalania "live-cd" z systemem, ale dalsza zabawę, chocby w wymianę kernela można prowadzić dopiero po instalacji na kompie. To, że wymiana kernela pomaga, sugeruje, że problem nie leży w pulse, ani w alsie - może w systemd albo grubie? Na własną kompilację kernela jestem stanowczo zbyt cienki...:-) A może to wina hardware i mój blaszak jest po prostu za stary na nowe ficzery?

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2778
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #5 dnia: 2021-11-08, 07:40:49 »
Ale dalej nie wiemy, o jaki sprzęt chodzi. Z tego co rozumiem, to stacjonarka.

* Jaka płyta główna,
* Jak wyciągany jest dźwięk (analog, SPDIF, HDMI, inaczej) i do czego wprowadzany (słuchawki, głośniki (jakie), monitor)

Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline ratus

  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #6 dnia: 2021-11-08, 17:18:20 »
To jest stacjonarka (ThinkCentre), biurowiec, sound by HDMI do głosniczków aktywnych, komputerowych lub do zestawu audio Hi-Fi Luxman + JBL (wiem, że to jest łączenie kwiatka z kożuchem :-))
Na własny użytek spekuluję, że Debian został tak ogarnięty, by współpracować z laptopami (czyli min. oszczędzać baterię), więc podsystem audio przy stacie załączany (brum zanika), potem jest odłączany od zasilania - stany nieustalone powodują brum - i znowu załączany na żądanie aplikacji dźwiekowej. Taka automatyka oszczędza (?) prąd, ale skutki uboczne są wkurzające!
Na tym samym blaszaku (poświęciłem jedną  partycję na eksperymenty) zainstalowane Gentoo (Calculate), MX Linux, PCLinuxOS, Slackware i stare wersje Debiana (Point)- nie miały problemów z brumem!
« Ostatnia zmiana: 2021-11-08, 17:24:04 wysłana przez ratus »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2778
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #7 dnia: 2021-11-08, 17:28:09 »
Może info z tego wątku pomoże?
Ustawić timeout na 0, czyli wyłączyć powersave.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline ratus

  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #8 dnia: 2021-11-08, 21:44:53 »
Trafione! W moim przypadku pomogło  ustawienie "0" w /sys/module/snd_hda_intel/parameters/power_save
Dzięki bardzo!
« Ostatnia zmiana: 2021-11-08, 21:46:29 wysłana przez ratus »

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 349
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #9 dnia: 2021-11-08, 21:49:40 »
No to teraz trzeba jeszcze sprawić by zmiany przeżyły restart.

Pokaż wynik polecenia:
cat /proc/asound/modules

Offline ratus

  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #10 dnia: 2021-11-09, 03:04:26 »
Prawda. Po restarcie słychać, jak system kilka razy włącza/wyłącza kartę dźwiękową, w końcu pozostawiając wyłącz.
$ cat /proc/asound/modules zwraca:  0 snd_hda_intel

Jakieś sugestie?

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2778
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #11 dnia: 2021-11-09, 11:46:03 »
Wzdeh... Możesz to zrobić na 2 sposoby:

Konfiguracja na poziomie kernela

* Wyedytować plik /etc/default/grub i w linii zawierającej GRUB_CMDLINE_LINUX dodać snd_hda_intel.power_save=0
* Wydać polecenie update-grub2

Konfiguracja na poziomie modułu

* Stworzyć plik /etc/modprobe.d/snd_hda_intel.conf o zawartości
options snd_hda_intel power_save=0
* Przegenerować initramfs update-initramfs -u -k all
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline ratus

  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: audio debian problem
« Odpowiedź #12 dnia: 2021-11-09, 12:01:43 »
Zastosowałem wariant 2. Sukces!
Jeszcze raz dzięki.