Nowe posty

xx Przydatne Linki (11)
2021-11-18, 01:50:23
xx Lekka przeglądarki (4)
2021-11-13, 10:58:18
xx Przejście z iptables na nftables. Serwer z DNS i VPN... (0)
2021-11-12, 11:20:40
xx SSH (5)
2021-11-11, 09:11:41
xx audio debian problem (12)
2021-11-09, 12:01:43
xx Strona o testach penetracyjnych, hackingu (19)
2021-11-07, 22:34:12
xx czyszczenie systemu (31)
2021-11-07, 14:41:26
xx Jak przekierować port (1)
2021-11-06, 09:52:44
xx kdenlive nie chce się uruchomić (14)
2021-10-29, 08:38:52
xx Aktualizacja Ubuntu 20.4 do 21.10. Kmail nie zapisuje haseł (10)
2021-10-28, 16:48:20

Autor Wątek: Problem z instalacja Firebird 2.5.0 na CentOS 7  (Przeczytany 395 razy)

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Problem z instalacja Firebird 2.5.0 na CentOS 7
« dnia: 2021-10-18, 23:04:49 »
Witam Was.
Nie mogę zainstalować Firebird-a wer. 2.5.0 na CentOS 7 dokładnie

uname -rv
3.10.0-1160.45.1.el7.x86_64


W tej wersji Linux-a instaluje się Firebird 2.5.9, a ja muszę mieć 2.5.0.
Próbowałem zainstalować rpm ze strony

https://firebirdsql.org/en/firebird-2-5-0
/FirebirdCS-2.5.0.26074-0.i686.rpm


Transaction check error:
  file / from install of FirebirdCS-2.5.0.26074-0.i686 conflicts with file from package filesystem-3.2-25.el7.x86_64
  file /usr/lib from install of FirebirdCS-2.5.0.26074-0.i686 conflicts with file from package filesystem-3.2-25.el7.x86_64


 i FirebirdSS-2.5.0.26074-0.i686.rpm.

Transaction check error:
  file / from install of FirebirdSS-2.5.0.26074-0.i686 conflicts with file from package filesystem-3.2-25.el7.x86_64
  file /usr/lib from install of FirebirdSS-2.5.0.26074-0.i686 conflicts with file from package filesystem-3.2-25.el7.x86_64


Spróbowałem zainstalować z pakietów
1. FirebirdSS-2.5.0.26074-0.i686.tar.gz
po pierwsze zgłasza
 - grep: /etc/xinetd.d/*: Nie ma takiego pliku ani katalogu
To akurat rozumiem bo xinetd już nie ma
 i dalej
Starting firebird (via systemctl):  Job for firebird.service failed because the  control process exited with error code. See "systemctl status firebird.service" and "journalctl -xe" for details.
                                                           [NIEUDANE]

Fixing firebird's shell to /bin/sh

usermod: bez zmian
Starting firebird (via systemctl):  Job for firebird.service failed because the control process exited with error code. See "systemctl status firebird.service" and "journalctl -xe" for details.
                                                           [NIEUDANE]
Please enter new password for SYSDBA user: masterkey
/opt/firebird/bin/gsec: error while loading shared libraries: libncurses.so.5:
cannot open shared object file: No such file or directory


I tu się wszystko zapętla, i ciągle woła o wpisanie hasła dla SYSDBA.

2.FirebirdCS-2.5.0.26074-0.i686.tar.gz
 to samo.

Problem  jest z libncurses.so.5
Próbowałem zainstalować:

yum install libncurses.so.5*

otrzymałem

Pakiet ncurses-libs-5.9-14.20130511.el7_4.x86_64 jest już zainstalowany w najnowszej wersji
Nie ma niczego do zrobienia


Czy ktoś wie jak sobie poradzić z tą instalacją?

Offline robson75

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 291
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #1 dnia: 2021-10-18, 23:50:04 »
Transaction check error:
  file / from install of FirebirdCS-2.5.0.26074-0.i686 conflicts with file from package filesystem-3.2-25.el7.x86_64
  file /usr/lib from install of FirebirdCS-2.5.0.26074-0.i686 conflicts with file from package filesystem-3.2-25.el7.x86_64

Przecież wyraźnie pisze, że Twój system używa paczek dla architektury x86_64 a nie i686.
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #2 dnia: 2021-10-19, 09:49:02 »
Dziękuję za szybką odpowiedź.
Do znawców to ja raczej się nie zaliczam  - stąd przeoczenie :(
Czy wiesz może gdzie szukać oprogramowania Firebirda 2.5.0  do mojej wersji systemu?
Na stronie https://firebirdsql.org/en/firebird-2-5-0 są tylko i686.
Z góry dziękuję za podpowiedź.

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 396
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #3 dnia: 2021-10-19, 10:26:47 »

Offline robson75

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 291
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #4 dnia: 2021-10-19, 12:02:52 »
Na tej stronie jest paczka firebird dla architektury x86_64
https://rpmfind.net/linux/rpm2html/search.php?query=firebird
na samym końcu po prawej stronie.
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #5 dnia: 2021-10-19, 13:13:06 »
Bardzo dziękuję działam.
Mam nadzieję, że pomożesz mi dalej gdyby były kłopoty.
A na razie  - Miłego Dnia :))

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #6 dnia: 2021-10-19, 13:21:04 »
No i dalej schody:

Transaction check error:
  file / from install of FirebirdCS-2.5.0.26074-0.amd64 conflicts with file from package filesystem-3.2-25.el7.x86_64
  file /usr/lib64 from install of FirebirdCS-2.5.0.26074-0.amd64 conflicts with file from package filesystem-3.2-25.el7.x86_64
  file /usr/lib64/libfbclient.so.2 from install of FirebirdCS-2.5.0.26074-0.amd64 conflicts with file from package firebird-libfbclient-2.5.9.27139.0-1.el7.x86_64
  file /usr/lib64/libfbembed.so.2.5 from install of FirebirdCS-2.5.0.26074-0.amd64 conflicts with file from package firebird-libfbembed-2.5.9.27139.0-1.el7.x86_64
  file /usr/lib64/libib_util.so from install of FirebirdCS-2.5.0.26074-0.amd64 conflicts with file from package firebird-2.5.9.27139.0-1.el7.x86_64

robson75 ratuj !!

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #7 dnia: 2021-10-19, 13:46:00 »
Robię na innym serwerze (też z amd) instalację CentOS 6,4.
Jest mi wszystko jedno czy baza stanie na 6-tce czy7-ce.
Przynajmniej na razie.
Teraz jak już wiem jakiego byka strzeliłem - trochę wstyd :( - to może na 6-tce będzie łatwiej.
Może z bibliotekami mniejszy problem?
Dam znać.
Ale gdybyś miał pomysł co dalej z 7-demką to napisz.
Już się zacząłem do niej przyzwyczajać, a i repozytoria działają :).
Pozdrawiam

Offline pavbaranov

  • Users
  • Guru
  • *****
  • Wiadomości: 807
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #8 dnia: 2021-10-19, 13:58:21 »
Ty w istocie chcesz mieć zainstalowanego Firebirda w wersji 2.5.9 (tę masz już w systemie) oraz 2.5.0 obok niego???
CentOSa nie mam już blisko 20 lat bodaj, ale wg ogólnych reguł gry:
- wersja 2.5.9 jest aktualizacją (ostatnią) dla serii 2.5.x,
- paczki dla poszczególnych wersji "umieszczają" swoje pliki w tych samych lokalizacjach co inne wersje; stąd też masz zonka, że paczka firebird 2.5.9 już zainstalowana dostarczyła Ci np. plik /usr/lib64/libfbembed.so.2.5 i ten plik konfliktuje z plikiem o takiej samej nazwie, którą chcesz obecnie zainstalować z paczki firebird 2.5.0.
Zastrzegając się, że nie wiem w ogóle, czy w przypadku firebird uda się coś takiego zrobić, rozwiązanie, które się samo narzuca, to próba skompilowania paczki firebird 2.5.0, ale w taki sposób, by np. swoje pliki lokowała w /opt. Inne rozwiązanie to być może paczka http://sourceforge.net/projects/firebird/files/firebird-linux-amd64/2.5-Release/FirebirdCS-2.5.0.26074-0.amd64.tar.gz/download, która jest skompresowaną binarką, daje możliwość instalacji w niestandardowych lokalizacjach. Trzecia możliwość - zrobić sobie appimage (chyba najsensowniej). Czwarta możliwość - odinstalować obecną wersję 2.5.9 i zainstalować 2.5.0 (jeśli wersji 2.5.9 nie wykorzystujesz). Piąta - możliwe, że ktoś się pokusił o zrobienie innej jeszcze jakiejś paczki uniwersalnej, bądź tzw. portable; trzeba by poszukać.
Pamiętaj jednak, że w ogóle gwarancji nie masz, że wersja 2.5.0 z sf.net będzie współpracować z Twoim systemem, bo mogą być jakieś kwestie związane z bibliotekami zależnymi w innych wersjach, inaczej skompilowanymi (na innym kompilatorze) itp. itd.
Być może są inne jeszcze jakieś pomysły, ale na szybko nie mam pomysłu.

PS: Odnosząc się do Twojego ostatniego maila: problem jest w dwu instalacjach tej samej wersji 2.5.x, a nie w wersji CentOSa.

Offline robson75

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 291
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #9 dnia: 2021-10-19, 14:00:54 »
Paczka firebird-libfbclient musi być w tej samej wersji co firebird, czyli 2.5.0. Tu masz linka aby pobrać odpowiednia wersje
https://archives.fedoraproject.org/pub/archive/epel/5/x86_64/
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #10 dnia: 2021-10-20, 11:47:36 »
Już wyjaśniam cały problem, bo pewnie niezbyt jasno go określiłem.
Pracujemy na programie RaksSQL firmy Raks.
Program opiera się o starą bazę Firebird 2.5.0 i tylko na niej pracuje stabilnie.
Mam ren program zainstalowany na serwerze MS Windows Server 2012 R2.
Ale przy obecnej bazie głównej programu 2,5 GB strasznie wolno pracuje.
Muszę przenieść go  na platformę Linux-ową.
Kiedyś to mi się udało  (w filii firmy już nie istniejącej ) chyba właśnie na CentOS 6   klientach pracujących bodaj na Wnidows XP.
Ale to było dawno, wszystko poszło do przodu, stąd problemy.
Firma Raks nie wspiera platformy Linux-a. Piszą, że nie mają specjalistów.

A teraz co zrobiłem:

Zrezygnowałem z CentOS 6, bo tam jest samba 1 :(
Wróciłem na CentOS 7  :
1. usunąłem Firebirda 2.5.9
2. pobrałem FirebirdCS-2.5.0.26074-0.amd64.tar.gz
3. rozpakowałem i uruchomiłem install.sh
program zainstalował się w /opt/firebird
poprosił o hasło do SYSDBA - podałem standardowe masterkey
zapisał i  na koniec napisał - install completed
Super !!
4. dodałem port do firewall-a
firewall-cmd --permanent --add-port=3050/tcp
5. SELinux ustawiłem w trybie - permissive

Czyli jest już nieźle :)
ale:
1. Nie umiem uruchomić Firebirda :( , bo go nie ma w systemctl

systemctl status firebird
Unit firebird.service could not be found.

Pewnie trzeba Firebird-a dodać do systemctl, ale ja nie wiem jak to zrobić.
Proces instalacji dopisał w katalogu /etc/xinet.d/firebird a w nim:
 Plik: firebird

 GNU nano 2.3.1             

# default: on
# description: FirebirdSQL server
#
# Be careful when commenting out entries in this file. Active key entry should
# be the first as some scripts (CSchangeRunUser.sh in particular) use sed
# scripting to modify it.

service gds_db
{
        disable = no
        flags           = REUSE
        socket_type     = stream
        wait            = no
        user                    = firebird
# These lines cause problems with Windows XP SP2 clients
# using default firewall configuration (SF#1065511)
#       log_on_success  += USERID
#       log_on_failure  += USERID
        server          = /opt/firebird/bin/fb_inet_server

I tu leżę bo nie wiem co i jak.

Co do firebird-libfbclient  - to czy jest potrzebny do łączenia się z bazą?
Tak po mojemu zapytam - czy pośredniczy z bazą?

Offline pavbaranov

  • Users
  • Guru
  • *****
  • Wiadomości: 807
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #11 dnia: 2021-10-20, 12:01:28 »
I usługi systemd miał nie będziesz, chyba, że ją sam stworzysz posiłkując się np. tą, która w aktualnej paczce dla CentOS jest. Nie będziesz miał, bowiem program, który pobrałeś pochodzi z 2010 r. - dokładnie tego samego, w którym zaczęła się historia systemd. Raczej mało kto wówczas myślał o dostosowaniu firebird to nowego systemu initów.
Możesz też poszukać jakiejś starej dokumentacji do 2.5.0 i pewnie tam będzie opisane jak to wówczas startowało.

Offline robson75

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 291
    • Zobacz profil
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #13 dnia: 2021-10-20, 12:48:14 »
:)
thx, czytam i działam

Offline AndrzejGTex

  • Nowy na forum
  • *
  • Wiadomości: 8
    • Zobacz profil
Odp: Problem z instalacja Firebird 2.5.0 na CentOS 7
« Odpowiedź #14 dnia: 2021-10-25, 12:24:32 »
Firebird 2.5.0 już działa na CentOS 7 :)
Dziękuję za podpowiedzi.

Problem z instalacją  Firebirda 2.5.0. polegał na tym, że  Firebird domyślnie instaluje się w trybie Classic i potrzebuje xinetd.
Wystarczy go przestawić na pracę SuperClassic i wtedy używa systemd.
Teraz kolej na wymianę na szybszą maszynę.
Obecna konfiguracja w stosunku do pracy na Windows Server 2012R2 dała przyrost prędkości o 4,5 S.
To za mało, a procesor ma przy zapisie do bazy zajęte 99,7% mocy.

Pozdrawiam Wszystkich