Nowe posty

Autor Wątek: funkcje w libre oofice  (Przeczytany 448 razy)

Offline karyma

  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
funkcje w libre oofice
« dnia: 2021-09-07, 13:03:44 »
Chcialbym zrobić  funkcje tyu

Jeżeli a1+a2 = 2 lub 4 lub a1+a2=2 wtedy wyświetle 2

w przeciwnym wypadku wyświetl 1

Znalazłem tylk o funkcje zwracająca prawdę lub fałsz i nie mogę zamienić prawda np na liczby


a idąc dalej

jeśli a1 = 1  , a2=2 a3=2 a4=1  wyświetle w komórce np napis telefon w przeciwnym wypadku
jeśli a2=2 ...................           wyświetle napis fajnie w przeciwny m wypadku

itd
Proste rzeczy ale chyba nie da sie za pomoca standardowych funkcji

« Ostatnia zmiana: 2021-09-07, 13:33:27 wysłana przez karyma »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2745
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: funkcje w libre oofice
« Odpowiedź #1 dnia: 2021-09-07, 13:49:14 »
Cytuj
ale chyba nie da sie za pomoca standardowych funkcji

Słabo czytałeś/aś dokumentację...

=JEŻELI(LUB(A1+A2=2;A1+A2=4);"Prawda";"Nieprawda")

; albo nie udokumentowana wersja LUB dla 2 argumentów:
=JEŻELI((A1+A2=2)LUB(A1+A2=4);"Prawda";"Nieprawda")

Dalej idziesz według tego samego schematu.

Matko, jak ja nienawidzę spolonizowanych skryptów. Przypomina mi się koszmar dzieciństwa w postaci polskiego Logo...
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline karyma

  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
Odp: funkcje w libre oofice
« Odpowiedź #2 dnia: 2021-09-07, 13:58:42 »
ok faktycznie nie zwróciłem uwagi że jednak  da się edytować zwracaną wartość. Dzięki

Offline karyma

  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
Odp: funkcje w libre oofice
« Odpowiedź #3 dnia: 2021-09-07, 20:13:51 »
Wprowadziłem z powodzeniem funkcję
=IF((C3=1)AND(C4=1)AND(C5=1)AND(C6=1);"droga")

Teraz jednak próbuję ją zagnieździć, tak aby uwzględnić 16 możliwych kombinacji wartości 1 i 2 w polach c3 ,c4 ,c5 i c6
czyli
=IF((C3=1)AND(C4=1)AND(C5=1)AND(C6=1);"droga")

else
IF ((c3=2) and (c4=2 ) and (c5=2) and (c6=2) than "grupa"
else
i tak dalej 16 razy



Próbowałem tak
=IF((C3=1)AND(C4=1)AND(C5=1)AND(C6=1);"droga"; IF (C3=2)   AND   (C4=2)   AND   (C5=2)   AND   (C6=2); "grupa")

ale jest błąd

W niedalekiej przyszłości powróże za pomoc . ten plik bowiem ma właśnie ułatwiać wrózenie

« Ostatnia zmiana: 2021-09-07, 20:55:46 wysłana przez karyma »

Offline baker

  • Nowy na forum
  • *
  • Wiadomości: 23
    • Zobacz profil

Offline karyma

  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
Odp: funkcje w libre oofice
« Odpowiedź #5 dnia: 2021-09-07, 21:18:36 »
załapałem chwilkę przed tym co napisąłes .

Ale następnego dnia nowe problemy. ;)


« Ostatnia zmiana: 2021-09-08, 12:03:58 wysłana przez karyma »

Offline karyma

  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
Odp: funkcje w libre oofice
« Odpowiedź #6 dnia: 2021-09-09, 09:31:16 »
Bardzo rozbudowałem swój skrypt dzięki wykorzystaniu kilku prostych funkcji.
Zastanawiam się czy są funkcje które kolorują komórkę wg. określonych parametrów  np
jeżeli  (a1=a2) zmień kolor komórki na niebieski

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2745
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: funkcje w libre oofice
« Odpowiedź #7 dnia: 2021-09-09, 12:34:58 »
Może po prostu przeczytasz instrukcję do Calca?

W dodatku to, co robisz średnio nadaje się do realizacji w arkuszu kalkulacyjnym w dłuższej perspektywie. Poszedłbym raczej w HTML5 z odpowiednim osadzonym CSS i JS. Wszystko da się popędzić jednym plikiem HTML.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy