Oprogramowanie > Inne

funkcje w libre oofice

(1/2) > >>

karyma:
Chcialbym zrobić  funkcje tyu

Jeżeli a1+a2 = 2 lub 4 lub a1+a2=2 wtedy wyświetle 2

w przeciwnym wypadku wyświetl 1

Znalazłem tylk o funkcje zwracająca prawdę lub fałsz i nie mogę zamienić prawda np na liczby


a idąc dalej

jeśli a1 = 1  , a2=2 a3=2 a4=1  wyświetle w komórce np napis telefon w przeciwnym wypadku
jeśli a2=2 ...................           wyświetle napis fajnie w przeciwny m wypadku

itd
Proste rzeczy ale chyba nie da sie za pomoca standardowych funkcji

Paweł Kraszewski:

--- Cytuj ---ale chyba nie da sie za pomoca standardowych funkcji
--- Koniec cytatu ---

Słabo czytałeś/aś dokumentację...


--- Kod: ---
=JEŻELI(LUB(A1+A2=2;A1+A2=4);"Prawda";"Nieprawda")

; albo nie udokumentowana wersja LUB dla 2 argumentów:
=JEŻELI((A1+A2=2)LUB(A1+A2=4);"Prawda";"Nieprawda")

--- Koniec kodu ---

Dalej idziesz według tego samego schematu.

Matko, jak ja nienawidzę spolonizowanych skryptów. Przypomina mi się koszmar dzieciństwa w postaci polskiego Logo...

karyma:
ok faktycznie nie zwróciłem uwagi że jednak  da się edytować zwracaną wartość. Dzięki

karyma:
Wprowadziłem z powodzeniem funkcję
=IF((C3=1)AND(C4=1)AND(C5=1)AND(C6=1);"droga")

Teraz jednak próbuję ją zagnieździć, tak aby uwzględnić 16 możliwych kombinacji wartości 1 i 2 w polach c3 ,c4 ,c5 i c6
czyli
=IF((C3=1)AND(C4=1)AND(C5=1)AND(C6=1);"droga")

else
IF ((c3=2) and (c4=2 ) and (c5=2) and (c6=2) than "grupa"
else
i tak dalej 16 razy



Próbowałem tak
=IF((C3=1)AND(C4=1)AND(C5=1)AND(C6=1);"droga"; IF (C3=2)   AND   (C4=2)   AND   (C5=2)   AND   (C6=2); "grupa")

ale jest błąd

W niedalekiej przyszłości powróże za pomoc . ten plik bowiem ma właśnie ułatwiać wrózenie

baker:
https://pl.wikibooks.org/wiki/OpenOffice.org/Calc/Funkcje/Funkcja_JE%C5%BBELI
Przykład nr 2

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

Idź do wersji pełnej