Nowe posty

xx Przydatne Linki (11)
2021-11-18, 01:50:23
xx Lekka przeglądarki (4)
2021-11-13, 10:58:18
xx Przejście z iptables na nftables. Serwer z DNS i VPN... (0)
2021-11-12, 11:20:40
xx SSH (5)
2021-11-11, 09:11:41
xx audio debian problem (12)
2021-11-09, 12:01:43
xx Strona o testach penetracyjnych, hackingu (19)
2021-11-07, 22:34:12
xx czyszczenie systemu (31)
2021-11-07, 14:41:26
xx Jak przekierować port (1)
2021-11-06, 09:52:44
xx kdenlive nie chce się uruchomić (14)
2021-10-29, 08:38:52
xx Aktualizacja Ubuntu 20.4 do 21.10. Kmail nie zapisuje haseł (10)
2021-10-28, 16:48:20

Autor Wątek: Żadna dystrybucja nie uruchamia się po instalacji.  (Przeczytany 588 razy)

Offline diegoxol

  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
Żadna dystrybucja nie uruchamia się po instalacji.
« dnia: 2021-08-04, 18:40:16 »
Witam, nie umiem poradzić sobie z problemem. Próbowałem zainstalować z pendrive minta, opensuse i ubuntu. Za każdym razem po instalacji kiedy trzeba zrestartować komputer, po ponownym uruchomieniu już bez pendrive uruchamia się bios i nie widzi w nim dysku z linuxem. W laptopie jest jeden dysk i tylko z linuxem. Dysk jest sprawny.
Proszę o pomoc!
Pozdrawiam!

Offline kuchtarczyk

  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #1 dnia: 2021-08-04, 19:23:15 »
Przydałoby się napisać jaki laptop, jaki dysk itp.
Instalacja zrobionana w trybie UEFI z partycjami GPT czy LEGACY/MBR??
No i przydałoby się opisać też co widać na ekranie gdy już restart się zrobi...

Offline diegoxol

  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #2 dnia: 2021-08-04, 19:31:56 »
laptop ASUS R556LN dysk ssd ADATA,
szczerze mówiąc nie wiem w jaki sposób dlatego opisze jak to robiłem.
Mint odpala się z pendrive i z pulpitu włączyłem instalator. podczas instalacji kliknąłem wyczyść dysk i zainstaluj i przy inne próbie sam stworzyłem partycje /, /home i swap.
nie wiem jak odpowiedzieć na to pytanie.
Gdy restart się zrobi to od razu włącza się BIOS i koniec, a w biosie nie widać dysku.

PS. dysk jak podpinałem do stacjonarki i formatowałem to wszystko z nim dobrze. w biosie też był widoczny wtedy. zniknął po instalacji minta.
« Ostatnia zmiana: 2021-08-04, 19:34:35 wysłana przez diegoxol »

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2513
  • 1709
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #3 dnia: 2021-08-04, 21:19:05 »
Skoro Tobie w Bios / UEFI widzi dysk to znaczy że dysk jest sprawny.
Jeśli Bios / UEFI nie potrafi znaleźć systemu / partycji rozruchowej, to znaczy że źle zainstalowałeś system.
Polecam obejrzeć poradniki na YouTube.


W przypadku dysku sformatowanego na GPT,
na dysku musi się znajdować partycja EFI z flagą boot
Czy jest wymagane w Biosie ustawione "secure boot = enabled" ?
  Nie wiem, raczej nie powinno nic się psuć, ale może to zależy od płyty głównej.
Zerknij, jest tam
- partycja fat32    /boot/efi     z flagą boot



W przypadku dysku sformatowanego na stary format msdos ( pokazane na obrazku niżej )
Musisz powyłączać nowe technologie w Biosie / UEFI które mogą przeszkadzać ( secure boot , UEFI , lub coś tam jeszcze )
 Legacy BIOS = enabled
( jak znajdę  w internecie to tu dodam, bo pewnie jeszcze coś było )
Na tym dysku nie musisz już tworzyć osobnych partycji.
Na partycji na której będzie system ustawiasz flagę boot
Żeby Bios / UEFI wiedziało gdzie jest system na dysku i żeby mogło go uruchomić przy starcie komputera.



Jeszcze ważna rzecz.
Zmiany w Bios / UEFI dokonujesz w pierwszej kolejności a potem instalujesz system.
W przeciwnym wypadku system może się czasami nie uruchomić.

Jeśli instalator systemu Linux nie pozwala ustawić flagi boot,
 to może jest tam narzędzie GParted z którego się da.

Mam nadzieję że niczego nie pomyliłem.

Inne problemy
- Może problem jeśli to SSD ?
https://forums.linuxmint.com/viewtopic.php?f=50&t=354267&p=2048111&hilit=secure+boot#p2048111
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline robson75

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 291
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #4 dnia: 2021-08-04, 22:03:40 »
Jeżeli Twój komp ma UEFI, to do /boot trzeba dodać flagę esp.
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Offline diegoxol

  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #5 dnia: 2021-08-04, 22:06:33 »
Dysk sformatowany na GPT. Teraz mam coś takiego:

W BIOSie nie widać żadnego dysku i nie uruchamia się system.
Nadal po uruchomieniu komputera od razu włącza się BIOS.

Z tego co wiem to nie mam UEFI, ale ta flaga esp i tak się dodaje mimo wszystko.

Offline diegoxol

  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #6 dnia: 2021-08-04, 22:12:23 »
Nie wiem czy też dobrze zrobiłem ale jako miejsce instalacji grub wybrałem właśnie partycję efi.

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 396
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #7 dnia: 2021-08-04, 22:49:43 »
popatrz dokładnie w ustawieniach bios/uefi  czy na pewno bootowanie systemu jest ustawione na dysk twardy

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2752
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #8 dnia: 2021-08-05, 08:32:35 »
A może choć raz schowaj dumę do kieszeni i wybierz opcję "automatycznie podziel dysk" czy jak to się nazywa w tym konkretnie instalatorze?

Bo na razie jest
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline diegoxol

  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #9 dnia: 2021-08-05, 10:05:46 »
Nie mogę tego sprawdzić bo BIOS nie widzi żadnego dysku dlatego też nie ma co byś ustawione na boot. Jedyne co widać to napęd DVD.

Co do ostatniej wypowiedzi to nie przypominam sobie żebym kiedyś pokazał dumę tutaj. Co do instalatora to kilka razy wybierałem też automatyczne partycjonowanie dysku. I efekt był taki sam.

Mam wrażenie że problem może tkwić w samym laptopie ale nie jestem w stanie tego zdiagnozować. Zaktualizowałem BIOS ale to również nie dało żadnego efektu.

Pozdrawiam!

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2513
  • 1709
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #10 dnia: 2021-08-05, 11:19:17 »
Cytuj
Nie mogę tego sprawdzić bo BIOS nie widzi żadnego dysku
Wymień dysk.

Edytowane. Cofam. Ale możesz sprawdzić z innym dyskiem.
Nie kumam. Linux widzi dysk. Ale Bios już nie.

Może aktualizacja Biosu / UEFI pomoże ?
Albo reset ustawień Biosu ?
« Ostatnia zmiana: 2021-08-05, 11:24:00 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline diegoxol

  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
Odp: Żadna dystrybucja nie uruchamia się po instalacji.
« Odpowiedź #11 dnia: 2021-08-05, 11:41:58 »
Problem dziwny ale rozwiązany. Stwierdziłem, że rozbiorę lapka do części pierwszych i złoże jeszcze raz. Okazało się, że pod płyta główna zapodziała się malutka czarna wtyczka która była odłączona od mniejszej płytki do której podpięty był dysk. Nie wiem czy to było problemem ale po złożeniu wszystkiego linux od razu odpalił. Dziwne, że instalator widział dysk, a bios nie. Jest tez szansa, że coś nie stykało i dlatego teraz po poprawieniu i wyczyszczeniu złączy to działa.
Tak czy inaczej temat raczej do zamknięcia.