System > Instalacja

Żadna dystrybucja nie uruchamia się po instalacji.

(1/3) > >>

diegoxol:
Witam, nie umiem poradzić sobie z problemem. Próbowałem zainstalować z pendrive minta, opensuse i ubuntu. Za każdym razem po instalacji kiedy trzeba zrestartować komputer, po ponownym uruchomieniu już bez pendrive uruchamia się bios i nie widzi w nim dysku z linuxem. W laptopie jest jeden dysk i tylko z linuxem. Dysk jest sprawny.
Proszę o pomoc!
Pozdrawiam!

kuchtarczyk:
Przydałoby się napisać jaki laptop, jaki dysk itp.
Instalacja zrobionana w trybie UEFI z partycjami GPT czy LEGACY/MBR??
No i przydałoby się opisać też co widać na ekranie gdy już restart się zrobi...

diegoxol:
laptop ASUS R556LN dysk ssd ADATA,
szczerze mówiąc nie wiem w jaki sposób dlatego opisze jak to robiłem.
Mint odpala się z pendrive i z pulpitu włączyłem instalator. podczas instalacji kliknąłem wyczyść dysk i zainstaluj i przy inne próbie sam stworzyłem partycje /, /home i swap.
nie wiem jak odpowiedzieć na to pytanie.
Gdy restart się zrobi to od razu włącza się BIOS i koniec, a w biosie nie widać dysku.

PS. dysk jak podpinałem do stacjonarki i formatowałem to wszystko z nim dobrze. w biosie też był widoczny wtedy. zniknął po instalacji minta.

1709:
Skoro Tobie w Bios / UEFI widzi dysk to znaczy że dysk jest sprawny.
Jeśli Bios / UEFI nie potrafi znaleźć systemu / partycji rozruchowej, to znaczy że źle zainstalowałeś system.
Polecam obejrzeć poradniki na YouTube.


W przypadku dysku sformatowanego na GPT,
na dysku musi się znajdować partycja EFI z flagą boot
Czy jest wymagane w Biosie ustawione "secure boot = enabled" ?
  Nie wiem, raczej nie powinno nic się psuć, ale może to zależy od płyty głównej.
Zerknij, jest tam
- partycja fat32    /boot/efi     z flagą boot



W przypadku dysku sformatowanego na stary format msdos ( pokazane na obrazku niżej )
Musisz powyłączać nowe technologie w Biosie / UEFI które mogą przeszkadzać ( secure boot , UEFI , lub coś tam jeszcze )
 Legacy BIOS = enabled
( jak znajdę  w internecie to tu dodam, bo pewnie jeszcze coś było )
Na tym dysku nie musisz już tworzyć osobnych partycji.
Na partycji na której będzie system ustawiasz flagę boot
Żeby Bios / UEFI wiedziało gdzie jest system na dysku i żeby mogło go uruchomić przy starcie komputera.



Jeszcze ważna rzecz.
Zmiany w Bios / UEFI dokonujesz w pierwszej kolejności a potem instalujesz system.
W przeciwnym wypadku system może się czasami nie uruchomić.

Jeśli instalator systemu Linux nie pozwala ustawić flagi boot,
 to może jest tam narzędzie GParted z którego się da.

Mam nadzieję że niczego nie pomyliłem.

Inne problemy
- Może problem jeśli to SSD ?
https://forums.linuxmint.com/viewtopic.php?f=50&t=354267&p=2048111&hilit=secure+boot#p2048111

robson75:
Jeżeli Twój komp ma UEFI, to do /boot trzeba dodać flagę esp.

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

Idź do wersji pełnej