Nowe posty

Autor Wątek: Problem z bootowaniem systemu  (Przeczytany 438 razy)

Offline Tadeusz

  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
Problem z bootowaniem systemu
« dnia: 2021-04-21, 16:50:21 »
Dzień dobry,

Mam problem z bootowaniem sytemu. Dosłownie co drugie uruchomienie system nie ładuje się i dostaję komunikat, którego treść załączam w pliku jpg.
Problem rozwiązuję resetując komputer z guzika i wtedy system się ładuje poprawnie.
Na komputerze jest zainstalowany tylko Debian.
Szczegóły systemu:

PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian

Będę wdzięczny za pomoc.

Dziękuję!

Offline kszyhu

  • Nowy na forum
  • *
  • Wiadomości: 15
    • Zobacz profil
Odp: Problem z bootowaniem systemu
« Odpowiedź #1 dnia: 2021-04-21, 18:29:58 »
System nie może odczytać dysku o nr UUID=e5d0fc........
Jeżeli jest to jedyny dysk to on a jeżeli masz więcej dysków, to może być inny.
Jeżeli uda Ci się uruchomić komputer sprawdź programem Dyski, który to dysk.
Przyczyną może być złe podłączenie dysku lub uszkodzony kabel SATA lub zasilający.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2720
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: Problem z bootowaniem systemu
« Odpowiedź #2 dnia: 2021-04-22, 07:38:46 »
1. Seria błędów MCE (machine check exception) nie wygląda dobrze. Może być sugestią sypiącego się sprzętu albo czegoś z przedpotopowym/pisanym przez słabo opłacane pawiany BIOSem. Poprosimy o więcej informacji o komputerze.

2. Są odnośniki do hibernacji. Opisane problemy są przy normalnym wyłączaniu, czy przy użyciu hibernacji? Pod Linuksem hibernacja działa poprawnie tylko jeżeli projektant BIOSa nie dał du*y. Czyli rzadko. Jeżeli hibernacja nie jest używana, można ją całkiem wyłączyć.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Tadeusz

  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
Odp: Problem z bootowaniem systemu
« Odpowiedź #3 dnia: 2021-04-22, 09:50:34 »
Dziękuję Wam za szybką reakcję :)

Jestem tu nowy i linuksa używam dopiero od kilku dni, więc z góry przepraszam za głupie pytania.

Czy komenda sudo lshw w terminalu ujawni informacje, które będą pomocne w diagnozie problemu?
Mógłbym je skopiować i umieścić w poście.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2720
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: Problem z bootowaniem systemu
« Odpowiedź #4 dnia: 2021-04-22, 18:23:40 »
Żeby nie "rozdmuchiwać" posta, wydaj następujące polecenia (jak zapyta się o hasło, podaj swoje własne):

sudo lshw | gzip > ~/lshw.gz
sudo blkid | gzip > ~/blkid.gz
sudo cat /etc/fstab | gzip > ~/fstab.gz
sudo dmesg | gzip > ~/dmesg.gz

W Twoim katalogu domowym powinny pojawić się cztery pliki o nazwach, jak po "falkach" - załącz je do odpowiedzi (plusik pod postem, "Załączniki i opcje dodatkowe").

I zanim ktoś powie, żeby nie męczyć kotów - wiem, chciałem zachować podobną składnię linijek, żeby nie mieszać naszemu gościowi.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Tadeusz

  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
Odp: Problem z bootowaniem systemu
« Odpowiedź #5 dnia: 2021-04-23, 09:54:09 »
Wykonałem wszystko według poleceń.
Załączam pliki.
Dzisiaj było jeszcze gorzej, bo normalnie reset zawsze pomagał, a teraz resetowałem komputer kilka razy i nic. W końcu wyłączyłem przytrzymując przycisk zasilania na nieco dłużej i dopiero za którymś razem system zaskoczył.
Komputer jest nowy.
Mam informację od firmy, która dostarczyła mi komputer, że problem może wynikać z tego, że, cytuję:
"Trzeba pozamieniać literki na napędach."
W komputerze są dwa dyski twarde, jeden SSD - na którym jest system a drugi HDD.
Może komputer próbuje bootować się ze złego dysku twardego?
Ten drugi dysk twardy - HDD - na którym zamierzam trzymać dane - nie mogę się w ogóle do niego dostać, system go widzi jako urządzenie, może nie jest dobrze zamontowany?
« Ostatnia zmiana: 2021-04-23, 10:29:41 wysłana przez Tadeusz »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2720
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: Problem z bootowaniem systemu
« Odpowiedź #6 dnia: 2021-04-23, 14:17:05 »
Jest coś nie tak, bo są 4 puste pliki.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline kszyhu

  • Nowy na forum
  • *
  • Wiadomości: 15
    • Zobacz profil
Odp: Problem z bootowaniem systemu
« Odpowiedź #7 dnia: 2021-04-23, 14:45:29 »
Archiwa, które zamieściłeś są puste. Druga sprawa, pisałem o sprawdzeniu zasilania dysków i kabelków SATA.

Offline Tadeusz

  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
Odp: Problem z bootowaniem systemu
« Odpowiedź #8 dnia: 2021-04-26, 09:03:33 »
Sprawdziłem podłączenie kabelków. Wygląda na to, że wszystko jest ok.

Załączam ponownie pliki.
Tym razem poprawne :)

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2720
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: Problem z bootowaniem systemu
« Odpowiedź #9 dnia: 2021-04-26, 10:32:39 »
Teraz widać trochę więcej.

Wygląda to tak: W logach nie ma błędów MCE, które są na screenie z nieudanego boota. Wygląda na to, że raz na jakiś czas coś sypie się podczas inicjalizacji plyty na niskim poziomie. Moja rada na dziś:
* Wejść w BIOS
* Znaleźć opcje typu "fast/quick boot" i je wyłączyć.
* Znaleźć opcje typu "hardware/peripherals initialization" i ustawić wszystkie na "full" czy "all"

Generalnie chodzi o takie ustawienie, w którym BIOS nie zostawia żadnych urządzeń nieskonfigurowanych. Miałem w swoim PCie problem z NVMe, że przy "zimnym" starcie NVMe nie zgłaszało się w systemie. Po jakimkolwiek resecie było już OK. Pomogło właśnie przełączenie opcji jak wyżej.

Poza tym kernel 4.19 jest zdecydowanie za stary na Core 9 generacji - to może mieć wpływ na nieumiejętność zaincjalizowania niektórych urządzeń. Dokumentacja na tej stronie pokazuje, jak włączyć oficjalne nowsze kernele w 10-ce.

W skrócie:
# Dodanie repo backports
echo "deb http://deb.debian.org/debian buster-backports main" | sudo tee -a /etc/apt/sources.list

# Aktualizacja list pakietów
sudo apt-get update

# Aktualizacja kernela
sudo apt -t buster-backports upgrade

Po resecie powinien być kernel serii co najmniej 5.9 i mniej kłopotów.

Dodatkowo warto odblokować gałąź non-free we wszystkich repozytoriach i doinstalować pakiet firmware-linux-nonfree, m.in. z aktualizacją firmware'a procesora.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Tadeusz

  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
Odp: Problem z bootowaniem systemu
« Odpowiedź #10 dnia: 2021-04-26, 15:35:35 »
Dziękuję Wam bardzo, Panowie :)
Aktualizacja kernela pomogła.
Nawet nie musiałem zmieniać ustawień w BIOSIE.
Przy ładowaniu systemu wyświetla mi się jeden błąd:
[FAILED] Failed to start Raise Network Interferences

Ale system ładuje się dalej normalnie i mogę korzystać z komputera.

Mam jeszcze jedno pytanie - dla mnie kluczowy problem - nie mogę dostać się do mojego dysku HDD - wiedzę go w systemie jako urządzenie, ale nie mogę nic na nim zapisać, system plików we właściwościach ma wolne 430 gb - czyli wnioskuję, że jest to mój dysk sdd, na którym jest zapisany system.