Nowe posty

xx Jak poprawić polecenie wyszukujące największe pliki? (2)
Dzisiaj o 01:48:08
xx CUPS - Wyłączenie hostname w nazwie udostępnionej drukarki (6)
Wczoraj o 02:45:06
xx Tłumaczenie prostych programów napisanych w csh na sh (0)
2021-06-11, 16:07:52
xx Do regulaminu (0)
2021-06-07, 02:16:34
xx kompletny restore systemu (5)
2021-06-03, 11:47:08
xx Połączenie wifi, nie skanuje w poszukiwaniu sieci. (1)
2021-06-02, 22:04:54
xx problemy z instalacją (1)
2021-06-02, 14:23:26
xx Pomoc w napisaniu skryptu (11)
2021-05-31, 13:34:19
xx Instalacja php5.4 na Debian10 (2)
2021-05-31, 09:13:54
xx Wielkie firmy wymuszają dane (7)
2021-05-30, 20:25:21

Autor Wątek: Blokada dostępu do możliwości zmiany czasu w UEFI/BIOS  (Przeczytany 352 razy)

pikaczu

  • Gość
Zastanawiam się czy istnieje jakaś łatwa opcja na stałą blokadę dostępu (np. odbiór uprawnień) na to, aby jakakolwiek dystrybucja Linux nie grzebała w UEFI/BIOS w celu zmiany ustawień zegara. Fajna sprawa gdy ma się jeden Linux i np. obok Windows, ogarnąć temat np. w Arch czy Manjaro spoko ale gdy systemów jest więcej nie jest to już takie przyjazne.
Zegar po prostu wariuje.
Uruchamiam Windows, jest godzina 10:00AM (podebrana z BIOSU). Jest to realna i rzeczywista godzina w mojej strefie.
Restrtuję kompa, uruchamiam Manjaro i godzina jest już 12:00AM
Ustawiam zatem poprawną strefę, zapodaję bajery w terminalu ... i od tej pory godzina zarówno w Windows jak i Manjaro jest 10:00AM.
Niby wszystko ok ale restartuję kompa, uruchamiam Linuxa Mint i ... zabawa zaczyna się od początku.
Zegar przestawia się automatycznie tyle że (pomimo poprawnej strefy) cofa się np. o 2 godziny w tył i jest już 8:00AM!
Restartuję kompa, wchodzę do BIOSu i widzę że zamiast pierwotnie ustawionej godziny 10:00AM jest już wartość ustawiona przez Linxa Mint. Przestawiam to kuśśśfa zatem nazad na 10:00AM i po restarcie uruchamiam Windows.
Jest godzina 10:00AM!
Restartuję sprzęt, uruchamiam Linuxa Q4OS (Debian) i ... dostaję oczopląsu, jest godz. 9:00AM.

W czym rzecz?
Ino w tym iż w każdym Linusie ustawiona jest ta sama strefa i czas.
Już mnie to tak wqku...

Pytanie zatem:
W którym miejscu dystrybucji takich jak: Arch, Debian, Mint ... jest plik w którym mogę zakazać jakiejkolwiek ingerencji w ustawienia w UEFI?
Jak zakazać linuxom dostępu do UEFI i zmiany tam czasu??


Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2464
  • 1709
    • Zobacz profil
Odp: Blokada dostępu do możliwości zmiany czasu w UEFI/BIOS
« Odpowiedź #1 dnia: 2021-05-02, 10:47:20 »
Wręcz przeciwnie, producenci ułatwiają grzebanie w UEFI / w Biosie poprzez możliwość instalacji oprogramowania prosto z systemu.
Jedynym ograniczeniem to chyba podpis cyfrowy / klucze producenta i mikrosoftu.

A co to czasu to chyba nie masz ustawionego czasu lokalnego w każdym systemie.
To się ustawia przy instalacji systemu, tylko trzeba zwracać uwagę.
I niestety to jest zmora chyba większości początkujących użytkowników którzy mają więcej niż 1 system.

Niestety dawno nie ustawiałem, może to coś nakieruje
https://dug.net.pl/tekst/198/ustawienie_czasu_(daty_godziny)_w_debianie/

Lub ktoś inne coś podeśle.
Jak nie znajdziesz to napisz na jakie systemy operacyjne potrzebujesz poradniki zmiany czasu UTC na czas lokalny

Edit
Ten poradnik też ciekawy, może będzie pasował do Linux Mint
https://www.digitalocean.com/community/tutorials/how-to-set-up-time-synchronization-on-ubuntu-18-04

Ja mam tak
$ date
nie, 2 maj 2021, 11:14:54 CEST

$ timedatectl
               Local time: nie 2021-05-02 11:17:00 CEST
           Universal time: nie 2021-05-02 09:17:00 UTC
                 RTC time: nie 2021-05-02 09:17:00     
                Time zone: Europe/Warsaw (CEST, +0200)
System clock synchronized: yes                         
              NTP service: active                     
          RTC in local TZ: no   
« Ostatnia zmiana: 2021-05-02, 11:17:37 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline robson75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 225
    • Zobacz profil
Odp: Blokada dostępu do możliwości zmiany czasu w UEFI/BIOS
« Odpowiedź #2 dnia: 2021-05-02, 15:10:33 »
Pytanie zatem:
W którym miejscu dystrybucji takich jak: Arch, Debian, Mint ... jest plik w którym mogę zakazać jakiejkolwiek ingerencji w ustawienia w UEFI?
Jak zakazać linuxom dostępu do UEFI i zmiany tam czasu??
To nie ma nic wspólnego z UEFI, po prostu masz źle skonfigurowaną strefę czasową, proponuje użyć systemd, wklepując tą komendę
systemctl enable systemd-timesyncd.service
Reboot systemu.
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Online Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2717
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: Blokada dostępu do możliwości zmiany czasu w UEFI/BIOS
« Odpowiedź #3 dnia: 2021-05-02, 21:13:06 »
Zacznijmy od początku: wszystkie normalne systemy (BSD, Linux, Unix, MacOS i wiele innych) domyślnie trzymają na płycie głównej czas w UTC bez rozróżnienia letni/zimowy. Jeden jedyny Windows z nudów trzyma na płycie głównej czas lokalny.

Zamiast wkurwiać się na Linuksy (które działają prawidłowo z punktu widzenia technologii) napraw Windows.
W załączniku masz dwa pliki REG przestawiające Windows na pracę z płytą w UTC. Oba ustawiają ten sam klucz w rejestrze, tylko na dwa sposoby - różne Windowsy akceptują różne formy. W mojej 10-ce działa clock2.reg.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

pikaczu

  • Gość
Odp: Blokada dostępu do możliwości zmiany czasu w UEFI/BIOS
« Odpowiedź #4 dnia: 2021-05-04, 10:52:27 »
Paweł, pozwolę sobie po Twojemu czyli bez ceregieli i ... "kurwa, przepraszam". Naprawdę nie wiedziałem że winna jest znowu ta "szmata" zatem prośba o wyrozumiałość, albowiem na forach o "szmacie" wmawiali mi że to Linux jest winny a "szmata" święta dlatgo w końcu dotarłem z zapytaniem i tu. No zrobiłem co napisaliście i w końcu nastał ład i skład.
I tak naprawdę na Linuxa się nie wku...m, wszak gdyby nie było linuxów to najprawdopodobniej wy..bał bym komputer za okno.

No i u mnie jest teraz tak:

$ date
wto, 4 maj 2021, 10:55:05 CEST
$ timedatectl
               Local time: wto 2021-05-04 10:55:16 CEST
           Universal time: wto 2021-05-04 08:55:16 UTC
                 RTC time: wto 2021-05-04 08:55:16     
                Time zone: Europe/Warsaw (CEST, +0200)
System clock synchronized: no                         
              NTP service: inactive                   
          RTC in local TZ: no
« Ostatnia zmiana: 2021-05-04, 10:56:19 wysłana przez pikaczu »

Offline robson75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 225
    • Zobacz profil
Odp: Blokada dostępu do możliwości zmiany czasu w UEFI/BIOS
« Odpowiedź #5 dnia: 2021-05-04, 18:19:14 »
No zrobiłem co napisaliście i w końcu nastał ład i skład
$ timedatectl
System clock synchronized: no                         
              NTP service: inactive                   
Gdybyś uruchomił usługę systemd-timesyncd, to byś miał tak.
timedatectl
               Local time: wto 2021-05-04 18:13:29 CEST
           Universal time: wto 2021-05-04 16:13:29 UTC
                 RTC time: wto 2021-05-04 16:13:29
                Time zone: Europe/Warsaw (CEST, +0200)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller