Nowe posty

Autor Wątek: APT nie aktualizuje do najnowszych security updates.  (Przeczytany 316 razy)

Offline Sandrzey

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Witam,

Mam problem na maszynie VM z zainstalowanym Ubuntu Server 18.04 LTS.

Aktualnie są na nim zainstalowane patche w wersji 4.15.0-118. Najnowsze to 0-140.
Wykonałem dist-upgrade i zresetowałem urzadzenie aby uruchomić system z najnowszym image.
Okazało sie że uaktualnił się release do 18.04.5 ale security packages pozostały nietkniete i system uruchamia sie z obrazu dla 0-118 a nie jek oczekiwano 0-140.

Robię więc uparcie w terminalu 'apt update' i widzę jak ściągają się informacje z repo. Następnie 'apt upgrade' a tu nic.
Wszystkie pakiety są zainstalowane w najnowszych wersjach (???). Do uaktualnienia 0.

Kiedy robie to na innej maszynie to Kernel uaktualnia sie o najnowsze security updates 0-140.

Nie rozumiem, a chciałbym zrozumieć co może być i gdzie przestawione.
Żadne pakiety nie są wycofane lub wstrzymane przed aktualizacją.
Odpowiednie repos są dostępne.

Gdzie jeszcze mogę szukać źródła takiego zachowania?

pozdrawiam i dzieki za podpowiedzi.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2709
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: APT nie aktualizuje do najnowszych security updates.
« Odpowiedź #1 dnia: 2021-04-13, 07:22:38 »
Pokaż wynik
> apt-cache policy linux-generic # Czy jakiego pakietu używasz jako kotwicy dla kernela

> aptitude why-not linux-image-4.15.0-140-generic
# albo
> aptitude why-not linux-image-unsigned-4.15.0-140-generic

Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Sandrzey

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: APT nie aktualizuje do najnowszych security updates.
« Odpowiedź #2 dnia: 2021-04-13, 10:03:20 »
Dzięki Paweł za wskazówkę.

Wczoraj nie wytrzymałem i ściągnąłem pliki recznie po czym zainstalowałem przez 'dpkg -i *.deb'

sudo wget http://archive.ubuntu.com/ubuntu/pool/main/l/linux-signed/linux-image-4.15.0-140-generic_4.15.0-140.144_amd64.deb
sudo wget http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-modules-4.15.0-140-generic_4.15.0-140.144_amd64.deb
sudo wget http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-modules-extra-4.15.0-140-generic_4.15.0-140.144_amd64.deb
sudo wget http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-headers-4.15.0-140-generic_4.15.0-140.144_amd64.deb
sudo wget http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-headers-4.15.0-140_4.15.0-140.144_all.deb

Grub loader się nieuaktualnił choć wybrałem odpowiednią (tak mi się wydaje) opcje w trakcie instalacji.
Podwiązałem więc ręcznie aby ładował z obrazu dla 0-140 a nie 0-118 jak do tej pory.
Po restarcie już nie wstał. Sprawdzałem tą metodę wcześniej i działała. Tym razem coś poszlo nie tak.
Czekam teraz na kolegę aby udostępnił VMware.


Jak tylko uda mi się odzyskać dostęp do tej która leży to się odezwę.
(Poniżej wrzucam wynik z bliźniaczej maszyny na której się udało)

Czy jest coś na co powinienem zwrócić uwagę?


pozdrawiam i dzieki za pomoc.
« Ostatnia zmiana: 2021-04-13, 11:03:26 wysłana przez Sandrzey »

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 322
    • Zobacz profil
Odp: APT nie aktualizuje do najnowszych security updates.
« Odpowiedź #3 dnia: 2021-04-13, 19:40:09 »
> Grub loader się nieuaktualnił choć wybrałem odpowiednią (tak mi się wydaje) opcje w trakcie instalacji.

Trzeba by przejrzeć plik /etc/default/grub.

Pokaż wynik:
apt-cache policy