Nowe posty

Autor Wątek: Emergency mode po dołożeniu dysku twardego  (Przeczytany 4343 razy)

Offline Ramo

  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Emergency mode po dołożeniu dysku twardego
« dnia: 2021-03-31, 13:06:09 »
Cześć! ;) Mam starszy komputer a w nim Debian Jessie i 3 dyski twarde. Chciałem dołożyć jeszcze jeden. Podłączyłem jeden - komputer uruchamia się w trybie "emergency mode", reboot default nie przechodzi gdyż pojawia się informacja, że sdc1 (czyli dysk, który sobie od lat działa i jest prawidłowo zamontowany) nie jest w systemie plików ext4. Po odłączeniu tego dodatkowego też jest ten tryb, ale udaje się uruchomić ponownie normalnie i wszystko działa.

Czemu więc tak się dzieje i jak to rozgryźć (jestem dość podstawowym użytkownikiem)? Co ma świeży dysk do obecnego, że pokazuje błąd? Gdyby prawidłowo się uruchomił to zamontowałbym i sformatował odpowiednio ten dodatkowy dysk, a tak - nic nie mogę..
Bios widzi prawidłowo ten dodatkowy dysk (jak i wszystkie).

Offline Arkadiusz Bednarczyk

  • Linux.pl
  • Administrator
  • Guru
  • *****
  • Wiadomości: 643
    • Zobacz profil
    • Linux.pl
Odp: Emergency mode po dołożeniu dysku twardego
« Odpowiedź #1 dnia: 2021-03-31, 21:31:20 »
Może dołożenie kolejnego dysku przemapowało je i teraz sdc1 dotyczy innego dysku? Dlatego w nowszych dystrybucjach dyski są mapowane przez uuid, a nie bezpośrednie nazwy urządzeń w /dev

Sprawdziłbym w biosie czy nie zmieniła się kolejność dysków, a dodatkowo można odpalić system z jakiegoś livecd i sprawdzić.
--
pozdrawiam
Arkadiusz Bednarczyk
email/jabber: arek@linux.pl

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2709
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Odp: Emergency mode po dołożeniu dysku twardego
« Odpowiedź #2 dnia: 2021-04-01, 07:44:45 »
Rozwijając wypowiedź Arka:

1. Wydaj polecenie
cat /etc/fstab

a) Jeżeli wpisy zaczynają się od UUID= to nie wiem, co jest przyczyną problemu
b) Jeżeli wpisy zaczynają się od /dev/sd... to to może być przyczyna problemu, idź dalej

2. Wydaj polecenie
lsblk -o PATH,UUID -l | grep /dev/sd

w odpowiedzi dostaniesz tabelę zawierającą w pierwszej kolumnie nazwę urządzenia z partycją, w drugiej UUID tej partycji (z czego partycje Windowsowe mają krótkie UUID a btrfs dłuższe od zwykłego i z innym zestawem znaków)

Wynik może wyglądać tak:
/dev/sda1 fe5df58a-1cf3-43e9-ab6b-b7ba8af5ec90
/dev/sda2 87496c16-d0dc-4378-8227-dd20c99d5391

3. Wydaj polecenie
cp /etc/fstab /etc/fstab.bak

4. Wyedytuj plik /etc/fstab zamieniając każde wystąpienie /dev/sd... odpowiadającym wpisem UUID=1111-... na podstawie wyniku punktu 2

Było (na przykład):
/dev/sda1 /    ext4  defaults 0 0
/dev/sda2 none swap  sw       0 0

Po edycji (dla danych z p. 2)
UUID=fe5df58a-1cf3-43e9-ab6b-b7ba8af5ec90 /     ext4 defaults 0 0
UUID=87496c16-d0dc-4378-8227-dd20c99d5391 none  swap sw       0 0

5. Wydaj polecenia

update-initramfs -u
update-grub

6. Zrestuj maszynę
7. Powinna uruchomić się bez problemu.
8. Dodaj nowy dysk. Teraz system powinien wstać bez problemu.


Antyczny skrypt z Ubuntu może wykonać punkty 2..4 automatycznie. Zostaje do zrobienia 5..8.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Ramo

  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Odp: Emergency mode po dołożeniu dysku twardego
« Odpowiedź #3 dnia: 2021-04-03, 14:23:45 »
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=28d2ad14-aa28-485f-ab6f-f1a26d0f0084 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=84406850-2338-4288-90fb-d1ff7d425d71 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

/dev/sdb1       sciezka_zamontowania ext4    rw,users,auto   0       1

/dev/sdc1       sciezka_zamontowania ext4    rw,users,auto   0       1

Wychodzi na to, że systemowy jest pod UUID a pozostałe 2 (cd-romu nie posiadam), które sam dokładałem są w postawi właśnie /dev/

Będę zatem próbował tego sposobu powyżej i dam znać, dzięki za pomoc ;)