Nowe posty

Autor Wątek: Problem z usunięciem katalogu  (Przeczytany 4440 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 170
    • Zobacz profil
Problem z usunięciem katalogu
« dnia: 2021-03-14, 08:23:50 »
Witam. Problem dotyczy dystrybucji OpenATV 6.5 - stosowanej do sterowania tunerami satelitarnymi. W tej dystrybucji, próbuję usunąć katalog który miał być używany do montowania zasobu sieciowego i nie mogę tego zrobić
Połączyłem się przez telnet  laptopem do tunera satelitarnego i próbuję usunąć katalog /media/autofs/Multimedia i nic mi nie wychodzi. Nie mogę też wejść do tego katalogu

Welcome to openATV for vusolo4k
openatv 6.5 vusolo4k

vusolo4k login: root
Password:
Last login: Sun Mar 14 08:11:14 CET 2021 on pts/0
root@vusolo4k:~# cd /
root@vusolo4k:/# cd /media/autofs
root@vusolo4k:/media/autofs# ls
Multimedia
root@vusolo4k:/media/autofs# rmdir Multimedia
rmdir: 'Multimedia': Permission denied
root@vusolo4k:/media/autofs# cd /media/autofs/Multimedia
-bash: cd: /media/autofs/Multimedia: No such file or directory
root@vusolo4k:/media/autofs#

Jak mogę sprawdzić co blokuje usunięcie tego katalogu i co blokuje wejście do tego katalogu?

Offline robson75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 218
    • Zobacz profil
Odp: Problem z usunięciem katalogu
« Odpowiedź #1 dnia: 2021-03-14, 13:53:42 »
A czy próbowałeś usunąć ten katalog przy pomocy tego polecenia?
# rm -rf /ścieżka/do/katalogu
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 170
    • Zobacz profil
Odp: Problem z usunięciem katalogu
« Odpowiedź #2 dnia: 2021-03-14, 17:42:19 »
A czy próbowałeś usunąć ten katalog przy pomocy tego polecenia?
# rm -rf /ścieżka/do/katalogu

Nie wiem co to za draństwo wymyślili w openatv ale ten katalog jest jakiś nie do usunięcia

vusolo4k login: root
Password:
Last login: Sun Mar 14 08:13:10 CET 2021 on pts/0
root@vusolo4k:~# rm -rf /media/autofs/Multimedia
root@vusolo4k:~# cd /media/autofs/
root@vusolo4k:/media/autofs# ls
Multimedia
root@vusolo4k:/media/autofs# rm -rf /media/autofs/Multimedia
root@vusolo4k:/media/autofs# ls
Multimedia
root@vusolo4k:/media/autofs#

Offline robson75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 218
    • Zobacz profil
Arch Linux Xfce+compiz - 64Bit Linux User #621110
anarchyinstaller

Offline pavbaranov

  • Users
  • Guru
  • *****
  • Wiadomości: 745
    • Zobacz profil
Odp: Problem z usunięciem katalogu
« Odpowiedź #4 dnia: 2021-03-15, 12:20:20 »

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 170
    • Zobacz profil
Odp: Problem z usunięciem katalogu
« Odpowiedź #5 dnia: 2021-03-18, 20:46:43 »
To przez przypadek nie jest - jakby ścieżka sugerowała - autofs? Zob.: http://miro.borodziuk.eu/index.php/2017/04/19/autofs/ lub https://www.kernel.org/doc/html/latest/filesystems/autofs.html lub https://wiki.archlinux.org/index.php/Autofs

Znalazłem wis w pliku /etc/auto.network pomimo iż punkt montowania wywaliłem w graficznym konfiguratorze

Multimedia -fstype=cifs,user=admin,pass=********,rw,iocharset=utf8,vers=2.0 ://10.0.0.4/Multhimedia

Czy mam ten wpis wykasować?

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 170
    • Zobacz profil
Odp: Problem z usunięciem katalogu
« Odpowiedź #6 dnia: 2021-03-19, 19:22:04 »
Wywaliłem wpis
Multimedia -fstype=cifs,user=admin,pass=********,rw,iocharset=utf8,vers=2.0 ://10.0.0.4/Multhimedia

i okazało się, że po reboocie katalog Multimedia sam zniknął. Dziękuję wszystkim za pomoc i wskazanie rozwiązania