Nowe posty

xx Jak poprawić polecenie wyszukujące największe pliki? (3)
2021-06-13, 20:00:52
xx CUPS - Wyłączenie hostname w nazwie udostępnionej drukarki (6)
2021-06-12, 02:45:06
xx Tłumaczenie prostych programów napisanych w csh na sh (0)
2021-06-11, 16:07:52
xx Do regulaminu (0)
2021-06-07, 02:16:34
xx kompletny restore systemu (5)
2021-06-03, 11:47:08
xx Połączenie wifi, nie skanuje w poszukiwaniu sieci. (1)
2021-06-02, 22:04:54
xx problemy z instalacją (1)
2021-06-02, 14:23:26
xx Pomoc w napisaniu skryptu (11)
2021-05-31, 13:34:19
xx Instalacja php5.4 na Debian10 (2)
2021-05-31, 09:13:54
xx Wielkie firmy wymuszają dane (7)
2021-05-30, 20:25:21

Autor Wątek: [ROZWIĄZANY] dźwięk się nagrywa w Audacity ale nie słychać w słuchawkach  (Przeczytany 341 razy)

Offline kenpo

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 209
    • Zobacz profil
Wgrałem na Androida aplikację mikrofon i przesyłam dźwięk do PC przez kabel 3,5. I nagrywa się dobrze w Audacity. Mogę to odsłuchać, ale w samych słuchawkach tak jakby "na żywo" go nie słyszę.
Ustawienia:
https://i.imgur.com/Q6GG0Gb.png
https://i.imgur.com/VPzsPAO.png
https://i.imgur.com/HcF79sc.png
Zupełnie się nie znam na Audacity ani na dźwięku w Linuksie. Jak widać w tym pierwszym elemencie Audacity widać Alsa, ale obok musiałem ustawić Pulse żeby coś nagrywał.Czy muszę zainstalować jakiś mixer, equlizer albo coś, żeby to ustawić? Bo w samej Plaźmie nie widzę żadnej opcji.
Używam Manjaro.
Przy okazji czy nie ma dla Linuxa jakiegoś programu, który by "po ludzku" pokazywał zamiast czegoś takiego:
https://i.imgur.com/Va6uWey.png
Coś takiego:
https://www.drivethelife.com/uploadfiles/20171011/realtek-hd-audio-manager-missing-windows-10.jpg

Edycja:Znalazłem takie informacje:https://www.pclinuxos.com/forum/index.php?topic=147977.0
https://thelinuxexperiment.com/pulseaudio-monitoring-your-line-in-interface/
Ale u mnie zastosowanie:
pactl load-module module-loopback
nic nie zmienia.
Edycja 2Jakimś cudem teraz się udało.
« Ostatnia zmiana: 2021-03-08, 19:19:31 wysłana przez kenpo »

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2465
  • 1709
    • Zobacz profil
Generalnie do miksowania  dźwięku to chyba powinniśmy używać QjackCtl
Ale przeciętny użytkownik nie umie z tego korzystać.
Podobno uruchomienie tego jest tak trudne jak wyjście z programu vim
 :D

A tak serio to trochę sprawia problemów.
1. Możliwe że znajdziesz np. taki błąd  https://askubuntu.com/questions/557906/problem-starting-jack-server-jack-server-is-not-running-or-cannot-be-started
Użytkownik niżej pisze że system nie jest odpowiednio skonfigurowany i trzeba sobie skonfigurować samemu.
Cytuj
2) Setup realtime for Jack, ...


2. No trzeba sobie (potem) zmiksować co sobie tam chcesz, klikasz przycisk Connect w QjackCtl
i tam jak masz po lewej i po prawej urządzenia to zaznaczasz je, a potem na dole klikasz Connect
Gotowe.

Przykładowy poradnik z YouTuba https://www.youtube.com/watch?v=txO3J81mfIs

Nagrany dźwięk możesz sobie wyczyścić we wspomnianym Audacity.
Zaznaczając fragment szumu i wybierając odpowiedni filtr.
Filtra aplikacje w trybie rzeczywistym nie widziałem.
Sam tryb rzeczywisty może nie działać idealnie bo np. powinniśmy używać kernela "lowlatency", który domyślnie nie jest zainstalowany.
Ale w sumie można w ustawieniach coś tam zmniejszyć, dzisiaj raczej posiadamy lepszy sprzęt, więc może nie będzie źle.


Edytowane
Jeśli masz Linux Mint 20.1
to w menadżerze pakietów Synaptic możesz wyszukać po nazwie linux-lowlatency
Bedzie tam
Cytuj
linux-lowlatency-hwe-20.04
linux-lowlatency-hwe-20.04-edge
które zainstaluje Tobie kernel 5.8.0-44-lowlatency
Wcześniej zainstalowałem samo "linux-lowlatency" ale ono instaluje starszy kernel 5.4.0.66.69 i coś nie współgra z moją nvidią.

Edytowane
Z kernelami "linux-lowlatency" też jest problem, a właściwie z  dodatkowymi sterownikami nvidia.
Sterownik nvidia na tym kernelu uruchamia się losowo tak jak losowo systemd uruchamia usługi
https://forums.linuxmint.com/viewtopic.php?f=49&t=307168&p=1907600&hilit=lowlatency+kernel+nvidia#p1907600
« Ostatnia zmiana: 2021-03-13, 18:58:40 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.