Nowe posty

xx Gdańsk (2)
Dzisiaj o 12:59:57
xx W Grubie nie pokazuje ubuntu (1)
Dzisiaj o 09:31:29
question Połączenie się z OEL 8 >> MS SQL (0)
2020-09-16, 12:05:25
xx PORADNIK ! [Poszukiwanie bledow] (2)
2020-09-15, 08:24:56
xx Po instalacji minta i tak startuje windows ... (8)
2020-09-13, 00:48:13
xx DHCP i Virtualbox (2)
2020-09-08, 20:56:37
xx Brak macierzy RAID w Ubuntu (3)
2020-09-08, 19:10:24
xx Edycja plików w lokalizacji /sys/class/net/eth0/statistics (1)
2020-09-04, 08:43:34
xx ikona uruchamiająca (chyba) skrypt w ubuntu 16 (4)
2020-09-02, 22:57:36
xx Postfix (2)
2020-09-01, 18:58:16

Autor Wątek: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS  (Przeczytany 8733 razy)

Offline duszeks

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« dnia: 2020-06-20, 00:13:28 »
Witam,

Postadam Xubuntu 18.04 LTS na laptopie Dell Inspiron 5379 zainstalowanego obok Windowsa. Ostatnio system jest nieużywalny, ponieważ nie ma dźwięku.

Próbowałem zmieniać urządzenia w opcjach dźwięku, odpaliłem komendę alsactl restore, w tym odinstalowałem i ponownie zainstalowałem PulseAudio.

Czy ktoś wie, w jaki sposób można naprawić ten problem?

Dźwięk wcześniej działał bez problemów, tylko teraz tak się stało.

Offline robson75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 192
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #1 dnia: 2020-06-20, 12:29:13 »
Uruchom alsamixer w terminalu, i suwakami dostosuj.
Arch Linux Xfce+compiz - 64Bit Linux User #621110https://anarchyinstaller.org/

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2397
  • 1709
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #2 dnia: 2020-06-20, 15:12:57 »
Najczęstsza przyczyną było niestabilne PulseAudio.

1. Tworzysz nowe konto użytkownika i testujesz dźwięk.
Gdy będziesz na nowym koncie, wszystkie pliki powstaną na nowo z domyślnymi ustawieniami.

- Gdy dźwięk działa,
A) przelogowujesz się na stare konto,
B) wyszukujesz pliki

locate pulse

Edytowane
Taka komenda do wyszukiwania chyba bedzie bardziej precyzyjna

locate pulse | grep home | grep config

( Jeśli nie posiadasz komendy locate - prawdopodobnie nie masz zainstalowane mlocate )
( mozesz wyszukac pliki w inny sposob, jesli wiesz jak )

C) usuwasz pliki
~/.config/pulse/ *  i /.config/pulse/cookie ( innych nie )

D) Potem restart systemu lub serwera pulse. Dźwięk powinien działać.
( wszystkie usunięte pliki powinny powstać na nowo z domyślnymi ustawieniami )

- Gdy dźwięk nie działa na nowym koncie,
to problem prawdopodobnie w systemie, a nie w plikach  w katalogu danego użytkownika.
Zobacz https://forum.linux.pl/index.php/topic,25330.msg136060.html#msg136060
« Ostatnia zmiana: 2020-06-20, 15:26:43 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline duszeks

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #3 dnia: 2020-06-21, 23:06:24 »
Uruchom alsamixer w terminalu, i suwakami dostosuj.

Nie działa :'( Próbowałem tego i wciąż jest problem.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 48
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #4 dnia: 2020-06-22, 23:12:42 »
Oprócz suwaków wciśnięcie "m"  wycisza/podgłaśnia.

Offline duszeks

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #5 dnia: 2020-06-27, 11:34:04 »
Cytat:  link=topic=25918.msg139758#msg139758 date=1592860362
Oprócz suwaków wciśnięcie "m"  wycisza/podgłaśnia.

Także próbowałem i nie działa.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2397
  • 1709
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #6 dnia: 2020-07-02, 02:01:25 »
1. Nie wiem czy temat aktualny.
2. Nie wiem czy użytkownik testował na nowym koncie.

Ale jeszcze jedna rada.

Raz na jakiś czas, dżwięk mi się przełącza z "analogowego" na "cyfrowy".
Nie zależnie od dystrybucji.
Akurat teraz tak miałem w Mincie.

Wyjaśnienie:
Używam komputera i w nim karty muzycznej, więc wyjście z karty muzycznej jest analogowe.
Ale system wykrywa mi także HDMI karty graficznej i to jest wyjście cyfrowe.
Jak patrzę w "ustawienia" pavucontrol,
to czasem mi się samo to resetuje i wyjście z karty muzycznej jest wyłączone zamiast włączone i działać, a włączone jest te z karty graficznej.

Nie wspominałem o tym ponieważ każdy sobie mógł zobaczyć i zmienić w ostatniej zakładce pavucontrol ,
 które było instalowane domyślnie na większości dystrybucji linuxa.

No właśnie było. Akurat w Mincie musiałem sobie doinstalować.
Możesz sobie sprawdzić / przetestować.

Przykład pavucontrol z wiki kodi ( odtwarzacza, nie istotne )



Informacja:
 " pavucontrol " to " PulseAudio Volume Control "
« Ostatnia zmiana: 2020-07-02, 02:14:24 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #7 dnia: 2020-07-03, 11:56:45 »
A dźwięku nie ma w głośnikach, w słuchawkach, czy i tu, i tu?

Offline duszeks

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #8 dnia: 2020-07-19, 13:40:24 »
1. Nie wiem czy temat aktualny.
Temat jak najbardziej wciąż jest aktualny.

2. Nie wiem czy użytkownik testował na nowym koncie.
Tak, testowałem to na nowym koncie i dźwięku nie ma.

Ale jeszcze jedna rada.

Raz na jakiś czas, dżwięk mi się przełącza z "analogowego" na "cyfrowy".
Nie zależnie od dystrybucji.
Akurat teraz tak miałem w Mincie.

Wyjaśnienie:
Używam komputera i w nim karty muzycznej, więc wyjście z karty muzycznej jest analogowe.
Ale system wykrywa mi także HDMI karty graficznej i to jest wyjście cyfrowe.
Jak patrzę w "ustawienia" pavucontrol,
to czasem mi się samo to resetuje i wyjście z karty muzycznej jest wyłączone zamiast włączone i działać, a włączone jest te z karty graficznej.

Nie wspominałem o tym ponieważ każdy sobie mógł zobaczyć i zmienić w ostatniej zakładce pavucontrol ,
 które było instalowane domyślnie na większości dystrybucji linuxa.

No właśnie było. Akurat w Mincie musiałem sobie doinstalować.
Możesz sobie sprawdzić / przetestować.

Przykład pavucontrol z wiki kodi ( odtwarzacza, nie istotne )

Mam ten pavucontrol, próbowałem każdego ustawienia, a dźwięku i tak nie ma. No nie żartuj ze mnie Linuksie :P

Informacja:
 " pavucontrol " to " PulseAudio Volume Control "
Dzięki za wyjaśnienie tego skrótu, nie wiedziałem co oznacza ten skrót :)

Offline duszeks

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #9 dnia: 2020-07-19, 13:41:46 »
Cytat:  link=topic=25918.msg139798#msg139798 date=1593770205
A dźwięku nie ma w głośnikach, w słuchawkach, czy i tu, i tu?

Ani tu, ani tu nie ma.

Offline duszeks

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #10 dnia: 2020-07-19, 13:43:18 »
Co dziwne, kiedy uruchomię Live USB, z którego instalowałem ten system, dźwięk działa. Może ktoś wie, jak przywrócić ustawienia z Live USB do instalacji systemu na dysku twardym?

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 342
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #11 dnia: 2020-07-19, 17:59:14 »
a pokaż kolego wynik komendy
aplay -l
i
systemctl --user status pulseaudio

Czy przed zalogowaniem no konto użytkownika też nie ma dźwięku ?
Czy użytkownik na pewno jest właścicielem /home  ?

Offline duszeks

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 7
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #12 dnia: 2020-08-15, 23:44:12 »
a pokaż kolego wynik komendy
aplay -l
i
systemctl --user status pulseaudio

Czy przed zalogowaniem no konto użytkownika też nie ma dźwięku ?
Czy użytkownik na pewno jest właścicielem /home  ?

aplay -l:

**** Lista PLAYBACK urządzeń ****
karta 0: PCH [HDA Intel PCH], urządzenie 0: ALC3253 Analog [ALC3253 Analog]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: PCH [HDA Intel PCH], urządzenie 3: HDMI 0 [HDMI 0]
  Urządzenia podrzędne: 0/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: PCH [HDA Intel PCH], urządzenie 7: HDMI 1 [HDMI 1]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: PCH [HDA Intel PCH], urządzenie 8: HDMI 2 [HDMI 2]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: PCH [HDA Intel PCH], urządzenie 9: HDMI 3 [HDMI 3]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: PCH [HDA Intel PCH], urządzenie 10: HDMI 4 [HDMI 4]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0

systemctl --user status pulseaudio:

● pulseaudio.service - Sound Service
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor pr
   Active: inactive (dead)

Nie mam żadnego dźwięku logowania, tak więc nie mogę sprawdzić tego.

Samo /home należy do roota, ale /home/duszek (czyli ja) należy do mnie:
drwxr-xr-x  4 root   root    4096 sie 15 23:39 .
drwxr-xr-x 24 root   root    4096 sie 15 23:07 ..
drwxr-xr-x 64 duszek duszek  4096 sie 15 23:42 duszek
drwx------  2 root   root   16384 wrz 29  2018 lost+found

Offline robson75

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 192
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #13 dnia: 2020-08-16, 12:39:58 »
To w takim razie uruchom usługę
systemctl --user enable pulseaudio
systemctl --user start pulseaudio
Arch Linux Xfce+compiz - 64Bit Linux User #621110https://anarchyinstaller.org/

Offline kenpo

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 205
    • Zobacz profil
Odp: Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS
« Odpowiedź #14 dnia: 2020-08-29, 10:58:43 »
Nie wiem, czy to ma jakieś znaczenie, ale warto się upewnić, czy użytkownik jest w grupie audio. Ja mam:
id
uid=1000(user_name) gid=1001(user_name) grupy=1001(user_name),90(network),96(scanner),98(power),986(video),988(storage),990(optical),991(lp),994(disk),995(audio),998(wheel),1000(autologin)
Może zacząć od tego, czy karta dźwiękowa jest poprawnie wykryta:

Czy przeglądałeś wyniki google ubuntu+sound, bo jest sporo takich tematów.
link1

link2

« Ostatnia zmiana: 2020-08-29, 11:04:26 wysłana przez kenpo »