Nowe posty

Autor Wątek: Karta Sieciowa , działa ale... - problem :|  (Przeczytany 4040 razy)

  • Gość
Karta Sieciowa , działa ale... - problem :|
« dnia: 2005-12-12, 19:34:21 »
Mam Suse 10 Eval na DVD wczoraj zainstaloawlem i mam kilka problemow a to jeden z nich. Nie dziala net nie wiem jak go skonfigurowac mozliwe ze to nie od tego ale watpie pisze teraz z xp wiec prosze o pomoc. Zadnego problemu nie mialem w Mandrivie 2005 ale zmieniliem bo bardziej podoba mi sie SuSe. PROSZE O POMOC

jk33

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #1 dnia: 2005-12-12, 19:59:10 »
Przy tej ilości podanych przez Ciebie
inforamcji niestety nie jesteśmy Ci w stanie
pomóc.
http://rtfm.killfile.pl
przeczytaj i dopisz potrzebne rzeczy.

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #2 dnia: 2005-12-13, 09:15:35 »
Witam

Mam takie pytanko a jak konfiguracja karty sieciowej ok ?

Nieweim jak to dokladnie wygląda w Suse

Ale polecam zrobienie nastepujących testów jesli wszystko wyjdzie ok to potem coś dalej pomyślimy :

/sbin/ifconfig eth0 (jesli to lan, jesli nie to inny wpis np ppp0, czy coś w tym sensie)

jesli masz urządzenie skonfigurowane ok to powinien ci się wsywietlic opis w tym wypadku karty sieciowej

Nastepnie adres DNS zawarty jest w pliku resolv.conf u mnie w ETC jesli tam go nie masz to:

find -name resolv.conf -print

powineś w nim mieć coś w rodzaju

nameserver 111.111.111.111 - gdzie jedynki to adres ip serwera dns

Potem plik konfiguracji karty sieciowej i tu mam problem bo nieznam suse ale mysle że w /etc/sysconfig będziesz miał plik networking w nnim opis konfiguracji LAN no i w jednym z podfolderów plik konfiguracji sieci o nazwie np. if-eth0 czy coś wtym sensie tam powinneś mieć okreslone adresy ip itd

Jeszcze jedna porada jakbyś mial problem z zdefiniowaniem danych w tym pliku to google -> nazwa pliku ->szukaj :-)

Pozdrawiam

#max

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #3 dnia: 2005-12-12, 18:00:55 »
Witam

Piszę na wstępie, że musiałem zrobić update Hardware Acceleration Layer'a i instalnąć udeva, aby przekompilować pod Gentoo nowe KDE 3.5. Do HAL'a potrzebny był kernel przynajmniej 2.6.13 - postawiłem 2.6.14-r4.

Pierwszy efekt normalny. Gnome nie za dobrze działa bo wymaga przelinkowania na nowsze biblioteki. KDE działa dobrze.

A problem jest z siecią. Dokładnie to karta Realtek na sterowniku 8031too (cy cuś :P) jest wkompilowana w kernel. Mimo to przy starcie systemu nie uruchamia sie sieć. Musze odpalać gnome-network-settings i wciskać "Active". Inaczej nie działa, ani przez ifconfig, ani z KControl. Dodatkowo mnie to dobija, gdyż zanim nie zaktualizuje Gnome, wolałbym nie odpalać jego aplikacji, bo pierwsza odpala gnome-settings-deamon'a, który zakłuca prace HAL'a, co powoduje pooooowooolne odpalanie sie wszystkich możliwich aplikacji. Gorzej niż w XP.

Czy może ktoś mi wyjaśnić jak odpalić karte z konsoli?

jak wspomniałem ifconfig eth0 inet up nie działa.
kcontrol nie aktywuje sieci nie wiedzieć 3mu.
pomysłów już nie mam.

A przyznam, że problemów było więcej z nowym kernel'em, hal'em i udev'em jednocześnie. Została tylko sieć...

Bardzo proszę o pomoc i z góry dziękuję :-)

greg000

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #4 dnia: 2005-12-12, 18:24:11 »
Chyba chodzilo o 8139too :)

Skompiluj sterownik jako modul , dodaj do /etc/modules.autoload.d/kernel-2.6. Pozniej skonfiguruj ip/netmask/broadcast w /etc/conf.d/net i zrob symlinka  /etc/init.d/net.eth0 do /etc/runlevels/default.

Pozdr

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #5 dnia: 2005-12-12, 19:35:43 »
Hmmm, faktycznie nie było net.eth0 to zalinkowałem.

Restartu narazie nie robie bo kompiluje oo 2.0, ale jak zadziała to zamarkuje post na "rozwiązany" lub będę nudzić dalej :D

Dziękuje,
Pozdrawiam :-)

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #6 dnia: 2005-12-12, 23:40:30 »
Szlak mnie trafi zaraz.

Wszystkie sposoby wypróbwałem z forów dyskusyjnych gentoo, ale to za cholere nie chce działać :[

Gnome-network-settings jakoś odpala sieć, tylko fajnie było by wiedzieć jak :[

Zaraz będe płakać :|

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #7 dnia: 2005-12-13, 01:22:13 »
Działa :-)

Nie zaktualizowałem plików konfiguracyjnych :-)

Jakby ktoś miał taki problem to:

PS1: Pamiętaj: to naprawia system tylko wtedy gdy problem pojawił się po aktualizacji narzędzi sieciowych :P

PS2: Objawy: Wywala komunikat "netmount was not started"z długą listą czerwonych linijek, oraz wcześniej error przy odpalaniu net.lo :-)

KATALOG /etc/conf.d/
{
mv net.lo net.lo-copy
# nie ruszac net.eth0 :-)
mv netmount netmount-copy
mv .*net.lo net.lo
mv .*netmount netmount
}

Pozdrawiam

Xax79

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #8 dnia: 2005-12-13, 13:55:50 »
O matko, jak dlugo siedze na gentoo (a siedze juz dosyc dlugo) nie musialem tak cudaczyc, a kerneli i updatow sie przewinelo w tym czasie sporo.

Po tym Twoim magicznym updacie pewnie zmienil sie baselayout, a co za tym idzie wiekszosc plikow konfiguracyjnych, w tym sieciowych. Zatem:

etc-update

To jest jedyne sluszne narzedzie do updatu plikow konfiguracyjnych, reczne latanie wczesniej czy pozniej skonczy sie kleska.
W koncu to jest kurde Gentoo !!

PS Prosze, nie pisz ze nie wiesz jak sie uruchamia w Gentoo uslugi i co to jest etc-update, prosze.

  • Gość
Karta Sieciowa , działa ale... - problem :|
« Odpowiedź #9 dnia: 2005-12-14, 01:03:15 »
Po pierwsze nie wiem kompetnie o co CI chodzi z usługami. Skąt Ci to przyszło?

Po drugie update polegał na zmianie narzędzis sieciowych o "pełną wersję" +1.0.x. I pliki konfiguracyjne nie pasowały.

etc-update nie używam. Robie update tych plików które chce zmienić i mam pewność. Tym bardziej, że aktuaizacje robie masowe i zmiany w plikach (te proponowane ziany) to zwykłe konfigi example. No ale jak chcesz to rób nadal etc-update bez myślenia to wkońcu zastąpi Ci baze userów, index dysków fstab/mtab, konfig gruba i sie pochlastasz :P

Więc proszę, nie sugeruj mi takiej ciemnoty. Chyba, że jesteś hakerem, bo używasz Gentoo :P

Bez urazy, to tylko uwaga.
Na drugi raz zastanów sie jak piszesz. Fakt, nie jestem specem, ale siedze już troche pod Linuxem, pod Gentoo również i czasami zdarzają się problemy tak błache, że byś na to nie wpadł - za to szukał tam gdzie Tobie sie wydaje, że powinna być usterka.

Jeszcze na koniec, naprawdę dobrze Ci radzę, poczytaj o tym "najlepszym" narzędziu etc-update i nigdy nie update'uj strategicznych plików Linuxa za jego pomocą :-)... Wtedy to sobie nachlastasz :D


Pozdrawiam