Nowe posty

Autor Wątek: .htaccess - prośba o pomoc  (Przeczytany 135 razy)

Offline mariuszad

  • Users
  • Użytkownik
  • **
  • Wiadomości: 90
    • Zobacz profil
.htaccess - prośba o pomoc
« dnia: 2019-12-11, 09:19:13 »
Witam

Mam działająca domenę oldpage.tld.pl. Jest ona dostępna pod adresem https://oldpage.tld.pl W folderze /var/www/newpage mam nową wersję strony. Nie chcę jej na razie udostępniać szerszemu gronu do momentu uzupełnienia jej o właściwe treści ale chciałbym aby była dostępna pod adresem https://oldpage.tld.pl/np .
Czy mógłby mi ktoś podpowiedzieć jak powinien wyglądać .htaccess aby stara i nowa strona były widoczne ?

Mój vhost dla oldpage.tld.pl wygląda tak :

<VirtualHost *:80>
    ServerAdmin webmaster@tld.pl
    AddDefaultCharset UTF-8
    DocumentRoot /var/www/oldpage
    ServerName oldpage.tld.pl
    ServerAlias www.oldpage.tld.pl
</VirtualHost>

<VirtualHost *:443>
    AddDefaultCharset UTF-8
    DocumentRoot /var/www/oldpage
    ServerName oldpage.tld.pl
    ServerAlias www.oldpage.tld.pl
 
    SSLEngine on
    SSLCertificateFile    /etc/httpd/ssl/wildcard.tld.pl.crt
    SSLCertificateKeyFile /etc/httpd/ssl/wildcard.tld.pl.key
</VirtualHost>


Obie strony stoją na CMS joomla.

Pozdrawiam
ma

Offline mariuszad

  • Users
  • Użytkownik
  • **
  • Wiadomości: 90
    • Zobacz profil
Odp: .htaccess - prośba o pomoc
« Odpowiedź #1 dnia: 2019-12-11, 09:37:35 »
Ok. Poradziłem sobie

<VirtualHost *:80>
        Alias /np /var/www/newpage
...

<VirtualHost *:443>
        Alias /np /var/www/newpage
...

cat  .htaccess

RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_URI} !^/np/
RewriteRule ^(.*)$ /newpage/$1 [R=302,L]

Offline mariuszad

  • Users
  • Użytkownik
  • **
  • Wiadomości: 90
    • Zobacz profil
Odp: .htaccess - prośba o pomoc
« Odpowiedź #2 dnia: 2019-12-11, 11:25:32 »
Witam

Jednak będę potrzebował pomocy. Po wrzuceniu strony z CMS niby strona się wyświetla ale po kliknięciu w jakikolwiek link odwołujący się do np. artykułu z poziomu menu czy jakiegokolwiek obiektu stworzonego w zapleczu joomla na paski adresu pojawia się:

https://oldpage.tld.pl/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/newpage/var/www/newpage/index.php

Firefox
Wyrzuca taki komunikat:

Pętla przekierowań
Podczas łączenia z serwerem „oldpage.tld.pl” wystąpił błąd.

Pewnie mam skopany .htacess Mółgby ktoś podpowiedzieć jak prawidłowo to ustawić  ?

Pozdrawiam