Nowe posty

xx Nie działa mi Team Speak 3 (13)
2020-10-29, 08:56:37
xx Mint czy Knoppix, który lepszy jako system z USB (1)
2020-10-28, 20:24:25
xx Framebuffer 640x5760 => 2560x1400. "pocięcie" pamięci framebuffer (2)
2020-10-26, 22:06:34
xx kontrola dostępu (1)
2020-10-26, 07:47:58
xx Użytkownicy należący do grupy (1)
2020-10-26, 07:44:46
xx Klawiatura nie działa po włączeniu Ubuntu (3)
2020-10-25, 19:23:34
xx Szkielet z getops (3)
2020-10-25, 15:06:20
xx 2 adresy na jednej sieciówce - brak pingu (1)
2020-10-22, 14:09:22
xx Knoppix z polską klawiaturą. Czy tak się da w ogóle? (5)
2020-10-20, 21:31:47
xx DNF autouzupełnianie (0)
2020-10-20, 18:18:23

Autor Wątek: Mint - czy da się zastąpić oryginalne menedżery Update/Soft na coś z Ubuntu?  (Przeczytany 623 razy)

exTerminator

  • Gość
***** zdaniem forumowiczów i admina = spam *****
« Ostatnia zmiana: 2020-04-06, 16:53:07 wysłana przez exPredator »

Offline mackeire

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 348
    • Zobacz profil
To chyba tak nie działa. Synaptic czy inne 'sklepiki z aplikacjami '  to tylko graficzne nakładki na apt .
 Jak chcesz nowsze czy inne paczki to musisz dodać do systemu  repozytorium z takowymi żeby synaptic miał z czego pobrać :)

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2402
  • 1709
    • Zobacz profil
Ale w przypadku GTK raczej nie da sie tak zrobic.
Nawet jesli daloby sie zainstalowac, to czesc programow (zbudowana z GTK) zeby uzywala nowszego GTK musi byc z nim na nowo przekompilowana.
W przypadku np. srodowiska graficznego to musi byc cale przekompilowane (to moze byc kilka-kilkanascie pakietow)
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2634
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • keybase.io/pkraszewski
Czy jest jakakolwiek możliwość zastąpenia Synaptica oraz menedżera aktualizacji a także Menedżera oprogramowania w mincie 19.2 na coś np. z Ubuntu 19.2??
Chodzi o to że Mint jest przestażały a twórcy distro mają to w d...
Wszystko jest stare, tak jakby nic nie robili. Tłumaczą to stabilnością a tak naprawdę są chyba leniwi.
Przykład GTK+, od xxx czasu działają stabilnie najnowsze GTK w Ubuntu a Mint w najnoszej kompilacji prepchany jest starociami.
Tak. Zainstalować Ubuntu 19.10. W zależności od upodobań, jak ktoś ma alergię na Gnome3: Ubuntu Mate, Ubuntu Budgie, Xubuntu, Kubuntu...
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

exTerminator

  • Gość
***** zdaniem forumowiczów i admina = spam *****
« Ostatnia zmiana: 2020-04-06, 16:53:15 wysłana przez exPredator »

Offline pavbaranov

  • Users
  • Guru
  • *****
  • Wiadomości: 697
    • Zobacz profil
Repozytoria Ubuntu w Mincie są standardowo dodane. Inaczej Mint w ogóle nie działałby :) Wybrałeś Minta 19, który jest oparty o Ubuntu18.04. Innych wersji paczek niż te, które tam są - miał nie będziesz. Paweł, odpowiadając na Twoje potrzeby podpowiedział Ci: zmień system na nowszy, skoro wersje paczek w Mint nie odpowiadają Ci. Innej możliwości nie ma.

exTerminator

  • Gość
***** zdaniem forumowiczów i admina = spam *****
« Ostatnia zmiana: 2020-04-06, 16:53:22 wysłana przez exPredator »

Offline pavbaranov

  • Users
  • Guru
  • *****
  • Wiadomości: 697
    • Zobacz profil
Jakby to powiedzieć: "widziały gały, co brały" :)
W Mint 19.2 jeśli jest Gtk 2 (raczej nie jest to 2.8, ale mniejsza o to), to wersja, którą pobrałeś to Mint XFCE. W Mint 19.2 jest 4.12 wersja tego środowiska, która jest jeszcze oparta o Gtk 2. Gtk 3 - z uwagi na udostępnienie repozytoriów Ubuntu w Mincie również musi być, a jest ona pobierana wyłącznie jeśli instalujesz coś, co jest zależne od tych bibliotek. W Mint 19.3 będzie wersja Xfce 4.14, która w większym stopniu zbudowana jest na Gtk 3, choć w zależnościach ma jeszcze Gtk 2. Takie to jest DE. Jeśli wybrałbyś wersję z Cinnamon, czy z MATE, to - jeśli żadna z aplikacji (np. GIMP) by nie potrzebowała Gtk 2 - nie miałbyś tych bibliotek w systemie. Zatem nie jest to śmiech na sali, ale po prostu konsekwencja używania określonego środowiska graficznego, opartego na tej linii bibliotek. Xfce 4.12, żeby bardzo chcieć, nie da się od Gtk 2 uwolnić, bo takie on ma zależności.
Mint 19 jest zbudowany na Ubuntu 18.04., a nie na Ubuntu "w ogólności" a w 18.04, nawet z repozytoriami updates i backports, Xfce4 występuje również w wersji 4.12.
Od stycznia zatem (wówczas wejdzie 19.3) będziesz miał w Mint nowszą wersję Xfce niż to jest w Ubuntu 18.04.
A na przyszłość nie kombinuj z "ręcznym" wrzucaniem libc6, bowiem jest to jedna z tych bibliotek, od której wersji wymagane jest przebudowanie mnóstwa innych paczek w systemie. Stąd konsekwencją próby wprowadzenia nowszej wersji tej biblioteki jest zgłoszenie Ci przez menedżera paczek, że chce odinstalować wszystko to, co ma zadeklarowaną tę bibliotekę w niższej wersji. A różnych wersji - w normalny sposób - w jednym systemie nie bardzo można mieć.

exTerminator

  • Gość
***** zdaniem forumowiczów i admina = spam *****
« Ostatnia zmiana: 2020-04-06, 16:53:29 wysłana przez exPredator »