Nowe posty

Autor Wątek: BIOS nie widzi dysku z Linuxem  (Przeczytany 165 razy)

Offline Mroovkoyad

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
BIOS nie widzi dysku z Linuxem
« dnia: 2019-09-13, 23:34:20 »
Mam dwa dyski w laptopie. Jeden na Ubuntu 16.04, drugi na Win10. Ostatnio postanowiłem przeinstalować oba systemy.
Przeinstalowałem Win10 (przy okazji formatując dysk z Linuxem). Następnie wyciągnąłem dysk z Win10 i zainstalowałem Ubuntu, po czym znów zamontowałem dysk z Win 10.
Przystąpiłem do ustawiania świeżej instalacji Ubuntu. Wszystko szło dobrze, aż postanowiłem przełączyć sprzęt ze zintegrowanej karty graficznej, na kartę nVidia. W tym miejscu wyskoczyło jakieś okienko ostrzegające o wyłączeniu Secure Boot i proszące o hasło dla tej operacji. Uznałem, że zrobię to później i chciałem wyjść. Ale się nie dało i doszło do zawieszenia systemu. Tu zaczęły się problemy.

W efekcie po kolejnym restarcie BIOS nie widzi dysku z Ubuntu ani żadnego pędraka, a jedynie dysk z Windowsem, po wyciągnięciu którego przy uruchamianiu wyświetla się napis "no bootable device".
Po przełączeniu BIOSa z UEFI na Legacy widzi wszystkie dyski, ale w tym trybie chodzi dziwnie i Ubuntu się odpala, ale zawiesza przy kliknięciu w ustawienia lub próbie zamknięcia/restartu. Wcześniej, na UEFI, pomagało dodanie do gruba "nomodeset" od razu po instalacji. Teraz na Legacy nie pomaga.

Oczywiście próbowałem przywracać domyślne ustawienia BIOSU, a także z poziomu Windowsa zaktualizowałem BIOS, ale nic się nie zmieniło.

Bardzo proszę o pomoc.

Offline pavbaranov

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 353
    • Zobacz profil
Odp: BIOS nie widzi dysku z Linuxem
« Odpowiedź #1 dnia: 2019-09-14, 10:10:16 »
Jeśli w legacy widzi dyski, to:
1. doprowadź dysk z Ubuntu do stanu "oglądalności", czyli... sformatuj jako GPT,
2. przełącz na UEFI,
3. wyłącz w BIOS secure boot,
4. z załączonym dyskiem z Win10, zainstaluj od nowa Ubuntu, dodaj os-probe, zainstaluj program rozruchowy.
Winno działać, oba systemy winne być widoczne w programie rozruchowym. Potem sobie zainstaluj sterowniki jakie (i czy w ogóle) potrzebujesz.

PS: Żadna niedokończona instalacja nie kończy się sukcesem :)

Offline parana

  • Users
  • Użytkownik
  • **
  • Wiadomości: 54
    • Zobacz profil
Odp: BIOS nie widzi dysku z Linuxem
« Odpowiedź #2 dnia: 2019-09-14, 10:41:31 »
Twój problem nie ma nic wspólnego z Linuxem - pomyliłeś fora.
To co piszesz to elementarna wiedza z zakresu serwisowania sprzętu komputerowego!!! i instalacji jakiegokolwiek systemu.
Proszę zgłosić się do najbliższego serwisu lub znajdź osobę kompetentną i po temacie.


Mam dwa dyski w laptopie. Jeden na Ubuntu 16.04, drugi na Win10. Ostatnio postanowiłem przeinstalować oba systemy.
Przeinstalowałem Win10 (przy okazji formatując dysk z Linuxem). Następnie wyciągnąłem dysk z Win10 i zainstalowałem Ubuntu, po czym znów zamontowałem dysk z Win 10.
Przystąpiłem do ustawiania świeżej instalacji Ubuntu. Wszystko szło dobrze, aż postanowiłem przełączyć sprzęt ze zintegrowanej karty graficznej, na kartę nVidia. W tym miejscu wyskoczyło jakieś okienko ostrzegające o wyłączeniu Secure Boot i proszące o hasło dla tej operacji. Uznałem, że zrobię to później i chciałem wyjść. Ale się nie dało i doszło do zawieszenia systemu. Tu zaczęły się problemy.

W efekcie po kolejnym restarcie BIOS nie widzi dysku z Ubuntu ani żadnego pędraka, a jedynie dysk z Windowsem, po wyciągnięciu którego przy uruchamianiu wyświetla się napis "no bootable device".
Po przełączeniu BIOSa z UEFI na Legacy widzi wszystkie dyski, ale w tym trybie chodzi dziwnie i Ubuntu się odpala, ale zawiesza przy kliknięciu w ustawienia lub próbie zamknięcia/restartu. Wcześniej, na UEFI, pomagało dodanie do gruba "nomodeset" od razu po instalacji. Teraz na Legacy nie pomaga.

Oczywiście próbowałem przywracać domyślne ustawienia BIOSU, a także z poziomu Windowsa zaktualizowałem BIOS, ale nic się nie zmieniło.

Bardzo proszę o pomoc.
ASRock A320M-HDV 3.0, ASRock TPM2-S, Athlon 200GE, 2X4GB 2400MHz Ballistix Sport LT, PCIe Gen 3 M2 Silicon 128 GB, 2XSSD Silicon Power A55 256GB, Logic M4, Be quiet! B9 350W, SilentiumPC Zephyr 80mm. GNU/Linux Debian 10

Offline Gimini

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Odp: BIOS nie widzi dysku z Linuxem
« Odpowiedź #3 dnia: 2019-09-18, 22:48:34 »
Witam :-)
Jakiego masz laptopa? Jakiej pojemności są to dyski? Masz możliwość wyłączenia w BIOSie UEFI (może nazywać się CSM)?