Nowe posty

xx Problem z partycjonowaniem dysku z openmediavault (1)
2023-01-25, 20:37:16
xx Zmienne php w virtual host (3)
2023-01-25, 09:21:13
xx Gra ciągle nadpisuje plik konfiguracyjny... (3)
2023-01-24, 12:43:49
xx Jak wejsc w bios ? (1)
2023-01-21, 02:33:58
xx instalacja pycharm comunity -komunikaty (3)
2023-01-18, 06:49:32
xx Problem z brakiem miejsca na partycji systemowej (19)
2023-01-17, 14:07:13
xx Projekt serwera (8)
2023-01-15, 06:02:33
xx Problem z instalacją Minta.. (0)
2023-01-14, 20:38:23
clip problem z vncserver (3)
2023-01-08, 20:22:36
xx Instalacja pakietu preinstal Oracle (4)
2023-01-06, 17:59:46

Autor Wątek: Pblem z montowaniem dysku sieciowego  (Przeczytany 6492 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 170
    • Zobacz profil
Pblem z montowaniem dysku sieciowego
« dnia: 2019-08-09, 21:41:22 »
Mój system operacyjny to:

cat /etc/*-release
NAME="openSUSE Leap"
VERSION="15.1 "
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.1"
PRETTY_NAME="openSUSE Leap 15.1"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.1"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

Po aktualizacji systemu operacyjnego z OpenSuse 42.3 do OpenSuse 15.1, pojawił się problem z montowaniem dysków sieciowych poprzez CIFS.
W pliku /etc/fstab mam następujący wpis do montowania dysku sieciowego

//10.0.0.4/Multimedia /home/gienek/Multimedia cifs username=admin,password=**********,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/archiwum /home/gienek/Archiwum cifs username=admin,password=*****,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/Praca /home/gienek/Praca cifs username=admin,password=*****,user,file_mode=0777,dir_mode=0777 0 0

Zdziwiłem się, gdy kliknąłem w menagerze plików na katalog /home/gienek/Multimedia a tam pusto. Spróbowałem zamontować katalog Multimedia i otrzymałem dziwną odpowiedź

linux-nx5d:~ # mount /home/gienek/Multimedia
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

linux-nx5d:~ # rpm -qa | grep cifs
pcp-pmda-cifs-4.3.1-lp151.1.3.x86_64
cifs-utils-6.8-lp151.3.1.x86_64
cifs-utils-devel-6.8-lp151.3.1.x86_64

linux-nx5d:~ # rpm -qa | grep mount
libmount1-2.33.1-lp151.2.23.x86_64
linux-nx5d:~ #

Nie wiem w czym jest problem. Przed aktualizacją systemu, nie było żadnego problemu, przy takim wpisie w pliku fstab z montowaniem dysków sieciowych. Czy ktoś może mi pomóc w montowaniu dysków sieciowych?


Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2629
  • 1709
    • Zobacz profil
Odp: Pblem z montowaniem dysku sieciowego
« Odpowiedź #1 dnia: 2019-08-09, 23:36:45 »
Nigdy nie używałem Cifs, także jak napisze coś głupiego to przepraszam.
1. Czy patrzyłeś w logi żeby poszukać linii zawierającej "mount" ?
2. Próbowałeś zamiast fstab, zamontować dyski ręcznie czyli "mount -t" costam ...
https://www.cyberciti.biz/faq/linux-mount-cifs-windows-share/
żeby się wyświetlił jakiś komunikat o będzie jeśli nie może go zamontować?
3. Próbowałeś restartować komputer po aktualizacji?
4. Czy przed aktualizacja konfigurowałeś Cifs i czy po aktualizacji nadal jest skonfigurowane i aktywne tak jak trzeba?

Edytowane
5. I sprawdziłeś ustawienia firewalla, czy są takie same jak wcześniej?
« Ostatnia zmiana: 2019-08-10, 00:18:36 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 170
    • Zobacz profil
Odp: Pblem z montowaniem dysku sieciowego
« Odpowiedź #2 dnia: 2019-09-22, 20:26:05 »
Nie wiem co autorzy mieli na myśli i po co wprowadzali te zmiany ale pomogło dopisanie w fstab

Cytuj
//10.0.0.4/Multimedia /home/gienek/Multimedia cifs username=admin,password=*****,vers=1.0,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/archiwum /home/gienek/Archiwum cifs username=admin,password=*****,vers=1.0,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/Praca /home/gienek/Praca cifs username=admin,password=*****,user,vers=1.0,file_mode=0777,dir_mode=0777 0 0

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2629
  • 1709
    • Zobacz profil
Odp: Pblem z montowaniem dysku sieciowego
« Odpowiedź #3 dnia: 2019-09-22, 22:05:08 »
Może coś jest za stare.
Cytuj
SMB3 is the now the default dialect (SMB3.1.1/SMB3.02/SMB3/SMB2.1 dialects are requested by default)
CIFS protocol (and other old dialects) can be selected (by specifying "vers=1.0" or "vers=2.02" in the mount options for example).
https://wiki.samba.org/index.php/LinuxCIFSKernel
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.