Nowe posty

xx Kompilacja jądra z biblioteką statyczną. (0)
Wczoraj o 11:53:01
exclamation postfix - rekonfiguracja (0)
2019-10-22, 16:01:27
xx Telecommunications Equipment Installers and Repairers (0)
2019-10-22, 12:43:24
xx Sprzet z Linuxem (2)
2019-10-22, 11:36:50
xx Debian 9 Stretch, linuxcnc i restart przy uruchamianiu (2)
2019-10-19, 21:54:36
xx Zakup sprzętu bez preinstalowanego windowsa (8)
2019-10-17, 16:50:51
xx Problem z pocztą Dovecot+Postfix+MySQL (3)
2019-10-16, 14:43:41
xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
2019-10-15, 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36

Autor Wątek: Pblem z montowaniem dysku sieciowego  (Przeczytany 3910 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 165
    • Zobacz profil
Pblem z montowaniem dysku sieciowego
« dnia: 2019-08-09, 21:41:22 »
Mój system operacyjny to:

cat /etc/*-release
NAME="openSUSE Leap"
VERSION="15.1 "
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.1"
PRETTY_NAME="openSUSE Leap 15.1"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.1"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

Po aktualizacji systemu operacyjnego z OpenSuse 42.3 do OpenSuse 15.1, pojawił się problem z montowaniem dysków sieciowych poprzez CIFS.
W pliku /etc/fstab mam następujący wpis do montowania dysku sieciowego

//10.0.0.4/Multimedia /home/gienek/Multimedia cifs username=admin,password=**********,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/archiwum /home/gienek/Archiwum cifs username=admin,password=*****,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/Praca /home/gienek/Praca cifs username=admin,password=*****,user,file_mode=0777,dir_mode=0777 0 0

Zdziwiłem się, gdy kliknąłem w menagerze plików na katalog /home/gienek/Multimedia a tam pusto. Spróbowałem zamontować katalog Multimedia i otrzymałem dziwną odpowiedź

linux-nx5d:~ # mount /home/gienek/Multimedia
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

linux-nx5d:~ # rpm -qa | grep cifs
pcp-pmda-cifs-4.3.1-lp151.1.3.x86_64
cifs-utils-6.8-lp151.3.1.x86_64
cifs-utils-devel-6.8-lp151.3.1.x86_64

linux-nx5d:~ # rpm -qa | grep mount
libmount1-2.33.1-lp151.2.23.x86_64
linux-nx5d:~ #

Nie wiem w czym jest problem. Przed aktualizacją systemu, nie było żadnego problemu, przy takim wpisie w pliku fstab z montowaniem dysków sieciowych. Czy ktoś może mi pomóc w montowaniu dysków sieciowych?


Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2212
  • 1709
    • Zobacz profil
Odp: Pblem z montowaniem dysku sieciowego
« Odpowiedź #1 dnia: 2019-08-09, 23:36:45 »
Nigdy nie używałem Cifs, także jak napisze coś głupiego to przepraszam.
1. Czy patrzyłeś w logi żeby poszukać linii zawierającej "mount" ?
2. Próbowałeś zamiast fstab, zamontować dyski ręcznie czyli "mount -t" costam ...
https://www.cyberciti.biz/faq/linux-mount-cifs-windows-share/
żeby się wyświetlił jakiś komunikat o będzie jeśli nie może go zamontować?
3. Próbowałeś restartować komputer po aktualizacji?
4. Czy przed aktualizacja konfigurowałeś Cifs i czy po aktualizacji nadal jest skonfigurowane i aktywne tak jak trzeba?

Edytowane
5. I sprawdziłeś ustawienia firewalla, czy są takie same jak wcześniej?
« Ostatnia zmiana: 2019-08-10, 00:18:36 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 165
    • Zobacz profil
Odp: Pblem z montowaniem dysku sieciowego
« Odpowiedź #2 dnia: 2019-09-22, 20:26:05 »
Nie wiem co autorzy mieli na myśli i po co wprowadzali te zmiany ale pomogło dopisanie w fstab

Cytuj
//10.0.0.4/Multimedia /home/gienek/Multimedia cifs username=admin,password=*****,vers=1.0,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/archiwum /home/gienek/Archiwum cifs username=admin,password=*****,vers=1.0,user,file_mode=0777,dir_mode=0777 0 0
//10.0.0.4/Praca /home/gienek/Praca cifs username=admin,password=*****,user,vers=1.0,file_mode=0777,dir_mode=0777 0 0

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2212
  • 1709
    • Zobacz profil
Odp: Pblem z montowaniem dysku sieciowego
« Odpowiedź #3 dnia: 2019-09-22, 22:05:08 »
Może coś jest za stare.
Cytuj
SMB3 is the now the default dialect (SMB3.1.1/SMB3.02/SMB3/SMB2.1 dialects are requested by default)
CIFS protocol (and other old dialects) can be selected (by specifying "vers=1.0" or "vers=2.02" in the mount options for example).
https://wiki.samba.org/index.php/LinuxCIFSKernel
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122