Nowe posty

xx Kompilacja jądra z biblioteką statyczną. (0)
Wczoraj o 11:53:01
exclamation postfix - rekonfiguracja (0)
2019-10-22, 16:01:27
xx Telecommunications Equipment Installers and Repairers (0)
2019-10-22, 12:43:24
xx Sprzet z Linuxem (2)
2019-10-22, 11:36:50
xx Debian 9 Stretch, linuxcnc i restart przy uruchamianiu (2)
2019-10-19, 21:54:36
xx Zakup sprzętu bez preinstalowanego windowsa (8)
2019-10-17, 16:50:51
xx Problem z pocztą Dovecot+Postfix+MySQL (3)
2019-10-16, 14:43:41
xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
2019-10-15, 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36

Autor Wątek: [solved] Problematyczna aktualizacja firefox'a na opensuse tumbleweed  (Przeczytany 116 razy)

Offline Robert

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2498
    • Zobacz profil
Problem polega na tym, ze instalator kopiuje na dysk błedny/uszkodzony plik libxul.so do katalogu
/usr/lib/firefox/

Wskutek tego firefox sie nie uruchamia, a próba odpalenia w konsoli wypluwa taki komunikat:

Cytuj
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
/usr/lib/firefox/libxul.so: undefined symbol: FT_Palette_Select
Couldn't load XPCOM.

najprostsze rozwiązanie tego problemu, to pobranie najnowszego firefoksa od producenta, i nadpisanie błednego pliku przez ten z paczki.

Można to zrobić np tak:
su
rm /usr/lib/firefox/libxul.so
cp /ścieżkadokataloguzropakowanymfirefoxem/libxul.so /usr/lib/firefox/



Zanim popełnisz grafomaństwo: 1 | 2 | 3
Baza RPM Jak szukać informacji