Nowe posty

xx Migracja GRUB2 (0)
Wczoraj o 12:30:46
xx Przydatne Linki (4)
2019-08-23, 14:13:00
xx Awstat (0)
2019-08-22, 14:55:15
xx SMB - Access denied z Windows (9)
2019-08-19, 11:27:24
xx Kali Linux - książka. (0)
2019-08-19, 00:20:25
xx Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera (6)
2019-08-18, 14:37:04
xx Nie moge urchmomic laptopa - grub rescue. (1)
2019-08-17, 18:24:00
xx Po aktualizacji zniknęły niektóre funkcje (45)
2019-08-14, 06:39:01
xx Operacje na bitach. (4)
2019-08-10, 21:44:36
xx Pblem z montowaniem dysku sieciowego (1)
2019-08-09, 23:36:45

Autor Wątek: Flatpak / Flathub powrót do poprzedniej wersji aplikacji  (Przeczytany 624 razy)

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Nawigacja Pure Maps https://flathub.org/apps/details/io.github.rinigus.PureMaps  zainstalowana przez Flathub po aktualizacji przestała działać, cierpliwie czekałem na następną ale nie przyniosła poprawy.
 Czy jest możliwość powrotu do wersji 1.17.0  a jeżeli tak to jak to zrobić ?
 

Offline pavbaranov

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 344
    • Zobacz profil
Odp: Flatpak / Flathub powrót do poprzedniej wersji aplikacji
« Odpowiedź #1 dnia: 2019-03-31, 14:32:15 »
Prędzej bym próbował dociec dlaczego "przestała działać", bo nie powinna. Jeśli uruchamiasz z konsoli to cokolwiek wypisuje? Ewentualne usunięcie cache aplikacji - coś zmienia?
Niestety nie odpowiem Ci czy flatpak ma swój cache (pewnie tak), bo najprościej byłoby Ci zainstalować stamtąd.
Jeśli nie - wersja 1.17: https://github.com/flathub/io.github.rinigus.PureMaps/tree/1.17
Możesz też spróbować zbudować ze źródeł.
Jak nic się nie uda, to są alternatywne programy (np. Marble, które w większości dystrybucji, Google Earth - jest możliwość zbudowania również AppImage), a tymczasem po prostu zgłosić błąd, ale "nie działa" będzie zbyt mało :)

Offline mackeire

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 189
    • Zobacz profil
Odp: Flatpak / Flathub powrót do poprzedniej wersji aplikacji
« Odpowiedź #2 dnia: 2019-03-31, 14:58:09 »
[/code]
Prędzej bym próbował dociec dlaczego "przestała działać", bo nie powinna. Jeśli uruchamiasz z konsoli to cokolwiek wypisuje?

Fedora :
[dell@dell-venue ~]$ flatpak run io.github.rinigus.PureMaps
Gtk-Message: 14:48:24.214: Failed to load module "pk-gtk-module"
Gtk-Message: 14:48:24.215: Failed to load module "canberra-gtk-module"
Gtk-Message: 14:48:24.215: Failed to load module "pk-gtk-module"
Gtk-Message: 14:48:24.216: Failed to load module "canberra-gtk-module"
Qt: Session management error: None of the authentication protocols specified are supported
Current locale: pl_PL
Loaded translation
Got library name:  "/app/usr/lib/qml/io/thp/pyotherside/libpyothersideplugin.so"
qt.positioning.geoclue2: Already running
qt.positioning.geoclue2: Already running
<Unknown File>:7: TypeError: Cannot read property 'contentX' of null
[ INFO ]  "{QSGRenderThread}[General]: GPU Identifier: Mesa DRI Intel(R) Bay Trail "
[dell@dell-venue ~]$

Neon :
dell@dell-E6430:~$ flatpak run io.github.rinigus.PureMaps
Current locale: pl_PL
Loaded translation
Got library name:  "/app/usr/lib/qml/io/thp/pyotherside/libpyothersideplugin.so"
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
qt.positioning.geoclue2: Already running
qt.positioning.geoclue2: Already running
<Unknown File>:7: TypeError: Cannot read property 'contentX' of null
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
[ INFO ]  "{QSGRenderThread}[General]: GPU Identifier: Mesa DRI Intel(R) Ivybridge Mobile "
Quitting
Calling http.pool.terminate
Calling poor.conf.write
Calling self.history.write
Calling self.narrative.quit
All quit methods called
dell@dell-E6430:~$

Na Neonie hula jak trzeba , natomiast na Fedorze uruchamia się ale jak się naciśnie jakąkolwiek ikonę to aplikacja się wyłącza.

Dociekałem przyczyn ale po siódmej stronie googlowania stwierdziłem że łatwiej będzie wrócić do działającej wersji i zablokować aktualizacje. Jestem użytkownikiem komputera a nie  programistą.


Usunięcie cache nie pomaga, zbudować ze źródeł nie potrafię.
« Ostatnia zmiana: 2019-03-31, 15:08:51 wysłana przez mackeire »

Offline pavbaranov

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 344
    • Zobacz profil
Odp: Flatpak / Flathub powrót do poprzedniej wersji aplikacji
« Odpowiedź #3 dnia: 2019-03-31, 15:17:12 »
To jest ten sam, czy dwa różne komputery?

W przypadku Fedory - być może cokolwiek pomoże analogiczne rozwiązanie jak: https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/solutions/rd10042012_508.html
Też nie jestem programistą, stąd też pisałem - błąd - to zgłaszać tam, gdzie tego miejsce. Niemniej jednak problem wydaje się być związany z GPU Intela.