Nowe posty

Autor Wątek: pgadmin4 ubuntu 18.04  (Przeczytany 1149 razy)

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
pgadmin4 ubuntu 18.04
« dnia: 2019-01-27, 20:14:13 »
Przy porządkach wywaliłem pgadmin4 i teraz nie mogę go zainstalować
Lecę jak panowie przykazali przez ppa https://wiki.postgresql.org/wiki/Apt

sudo apt-get install postgresql-11 pgadmin4
[sudo] hasło użytkownika panas:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
postgresql-11 is already the newest version (11.1-1.pgdg18.04+1).
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 pgadmin4 : Wymaga: pgadmin4-common (= 4.1-1.pgdg18.04+1) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2277
  • 1709
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #1 dnia: 2019-01-27, 22:25:33 »
Moze symulacja instalacji brakujacej zaleznosci cos powie wiecej ?
sudo apt-get install -s pgadmin4-common

Edytowane
Albo inaczej, moze najpierw sprawdz jakie sa dostepne pakiety.
postgresql-11 juz miales zainstalowane.
Ale pgadmin4 moze nie jest juz w tej wersji dostepne ?
( " apt-cache search  pgadmin " ? )

Edytowane
Albo nie uzyles "apt-get update" zeby pobralo liste dostepnych pakietow ?
« Ostatnia zmiana: 2019-01-27, 22:31:27 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #2 dnia: 2019-01-28, 18:31:43 »
Pamiętam pisałeś o tym teraz to wiem jak to wygląda jednak mam problem z zależnościami.

sudo apt-get install -s pgadmin4-common
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 pgadmin4-common : Wymaga: fonts-roboto-unhinted ale nie da się go zainstalować
                   Wymaga: fonts-open-sans ale nie da się go zainstalować
                   Wymaga: python3-flask ale nie da się go zainstalować
                   Wymaga: python3-flask-babelex ale nie zostanie zainstalowany
                   Wymaga: python3-flask-gravatar ale nie zostanie zainstalowany
                   Wymaga: python3-flask-htmlmin ale nie zostanie zainstalowany
                   Wymaga: python3-flask-login ale nie da się go zainstalować
                   Wymaga: python3-flask-migrate ale nie da się go zainstalować
                   Wymaga: python3-flask-paranoid ale nie zostanie zainstalowany
                   Wymaga: python3-flask-security ale nie zostanie zainstalowany
                   Wymaga: python3-flask-sqlalchemy ale nie da się go zainstalować
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
panas@Panas:~$ sudo apt-get install python3-flask*
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Note, selecting 'python3-flask-migrate' for glob 'python3-flask*'
Note, selecting 'python3-flask-login' for glob 'python3-flask*'
Note, selecting 'python3-flask-sqlalchemy' for glob 'python3-flask*'
Note, selecting 'python3-flask-security' for glob 'python3-flask*'
Note, selecting 'python3-flask-htmlmin' for glob 'python3-flask*'
Note, selecting 'python3-flaskext.wtf' for glob 'python3-flask*'
Note, selecting 'python3-flask-principal' for glob 'python3-flask*'
Note, selecting 'python3-flask-mail' for glob 'python3-flask*'
Note, selecting 'python3-flask-babelex' for glob 'python3-flask*'
Note, selecting 'python3-flask' for glob 'python3-flask*'
Note, selecting 'python3-flask-peewee' for glob 'python3-flask*'
Note, selecting 'python3-flask-gravatar' for glob 'python3-flask*'
Note, selecting 'python3-flask-paranoid' for glob 'python3-flask*'
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 python3-flask-babelex : Wymaga: python3-flask ale nie da się go zainstalować
 python3-flask-gravatar : Wymaga: python3-flask ale nie da się go zainstalować
 python3-flask-htmlmin : Wymaga: python3-flask ale nie da się go zainstalować
 python3-flask-mail : Wymaga: python3-flask ale nie da się go zainstalować
 python3-flask-paranoid : Wymaga: python3-flask (>= 0.10) ale nie da się go zainstalować
 python3-flask-peewee : Wymaga: python3-peewee ale nie da się go zainstalować
                        Wymaga: python3-wtf-peewee ale nie zostanie zainstalowany
                        Wymaga: python3-flask ale nie da się go zainstalować
                        Wymaga: python3-werkzeug ale nie da się go zainstalować
                        Wymaga: python3-wtforms ale nie da się go zainstalować
 python3-flask-security : Wymaga: python3-flask (>= 0.9) ale nie da się go zainstalować
                          Wymaga: python3-flask-login ale nie da się go zainstalować
                          Wymaga: python3-flask-principal ale nie da się go zainstalować
                          Wymaga: python3-passlib ale nie da się go zainstalować
 python3-flaskext.wtf : Wymaga: python3-flask ale nie da się go zainstalować
                        Wymaga: python3-wtforms ale nie da się go zainstalować
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
panas@Panas:~$ sudo apt-get install python3-flask
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet python3-flask nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.

E: Pakiet python3-flask nie ma kandydata do instalacji
panas@Panas:~$

Jeszcze to wrzucę ale nie wiem jak to ugryźć
sudo apt-cache showpkg pgadmin4-common
Package: pgadmin4-common
Versions:
4.1-1.pgdg18.04+1 (/var/lib/apt/lists/apt.postgresql.org_pub_repos_apt_dists_bionic-pgdg_main_binary-amd64_Packages) (/var/lib/apt/lists/apt.postgresql.org_pub_repos_apt_dists_bionic-pgdg_main_binary-i386_Packages)
 Description Language:
                 File: /var/lib/apt/lists/apt.postgresql.org_pub_repos_apt_dists_bionic-pgdg_main_binary-amd64_Packages
                  MD5: 30a9e50c833809a214cbf53c669b5ea7


Reverse Depends:
  pgadmin4,pgadmin4-common 4.1-1.pgdg18.04+1
  pgadmin4-apache2,pgadmin4-common 4.1-1.pgdg18.04+1
Dependencies:
4.1-1.pgdg18.04+1 - fonts-font-awesome (0 (null)) fonts-roboto-unhinted (0 (null)) fonts-open-sans (0 (null)) python3-crypto (0 (null)) python3-dateutil (0 (null)) python3-flask (0 (null)) python3-flask-babelex (0 (null)) python3-flask-gravatar (0 (null)) python3-flask-htmlmin (0 (null)) python3-flask-login (0 (null)) python3-flask-migrate (0 (null)) python3-flask-paranoid (0 (null)) python3-flask-security (0 (null)) python3-flask-sqlalchemy (0 (null)) python3-psutil (0 (null)) python3-psycopg2 (2 2.7.4) python3-simplejson (0 (null)) python3-sqlparse (4 0.2) python3-sshtunnel (0 (null)) python3:any (2 3.3.2-2~) python3-pgadmin4 (0 (null)) pgadmin4-doc (0 (null)) python3-pgadmin4 (0 (null))
Provides:
4.1-1.pgdg18.04+1 -
Reverse Provides:
panas@Panas:~$ sudo apt-cache depends pgadmin4-common
pgadmin4-common
  Wymaga: fonts-font-awesome
  Wymaga: <fonts-roboto-unhinted>
  Wymaga: <fonts-open-sans>
  Wymaga: python3-crypto
  Wymaga: python3-dateutil
  Wymaga: <python3-flask>
  Wymaga: python3-flask-babelex
  Wymaga: python3-flask-gravatar
  Wymaga: python3-flask-htmlmin
  Wymaga: <python3-flask-login>
  Wymaga: <python3-flask-migrate>
  Wymaga: python3-flask-paranoid
  Wymaga: python3-flask-security
  Wymaga: <python3-flask-sqlalchemy>
  Wymaga: python3-psutil
  Wymaga: python3-psycopg2
  Wymaga: python3-simplejson
  Wymaga: python3-sqlparse
  Wymaga: python3-sshtunnel
  Wymaga: <python3:any>
    python3
    python3:i386
  W konflikcie z: <python3-pgadmin4>
  Sugeruje: pgadmin4-doc
  Zastępuje: <python3-pgadmin4>

sudo apt-get build-dep pgadmin4-common 
Czytanie list pakietów... Gotowe
Zmieniono wybrany pakiet źródłowy na "pgadmin4" z "pgadmin4-common"
E: Nie udało się odnaleźć źródła dla pakietu pgadmin4-common
« Ostatnia zmiana: 2019-01-28, 18:46:11 wysłana przez Panas »

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 294
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #3 dnia: 2019-01-28, 18:53:11 »
Czy system jest zaktualizowany?

apt-get update && apt-get dist-upgrade

Masz dużo dodatkowych repozytoriów?
apt-cache policy

marcin82

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #4 dnia: 2019-01-28, 19:48:10 »
Zaktualizowany, aktualizacje staram się robić systematycznie, dist-upgrade wykonuję rzadziej.
Zastanawiam się czy domyślną wersję phytona nie zmienić? Chociaż to by było dziwnę bo nie robiłem tego wcześniej a pgadmin4 działał

apt-cache policy
Plików pakietów:
 100 /var/lib/dpkg/status
     release a=now
 500 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main i386 Packages
     release v=18.04,o=LP-PPA-webupd8team-java,a=bionic,n=bionic,l=Oracle Java (JDK) 8 Installer PPA,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic/main amd64 Packages
     release v=18.04,o=LP-PPA-webupd8team-java,a=bionic,n=bionic,l=Oracle Java (JDK) 8 Installer PPA,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://packages.microsoft.com/repos/vscode stable/main amd64 Packages
     release o=vscode stable,a=stable,n=stable,l=vscode stable,c=main,b=amd64
     origin packages.microsoft.com
 500 http://repo.steampowered.com/steam precise/steam i386 Packages
     release o=Valve Software LLC,n=precise,l=Steam,c=steam,b=i386
     origin repo.steampowered.com
 500 http://repo.steampowered.com/steam precise/steam amd64 Packages
     release o=Valve Software LLC,n=precise,l=Steam,c=steam,b=amd64
     origin repo.steampowered.com
 500 http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic/main amd64 Packages
     release v=18.04,o=LP-PPA-serge-rider-dbeaver-ce,a=bionic,n=bionic,l=DBeaver Community,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/ricotz/docky/ubuntu bionic/main i386 Packages
     release v=18.04,o=LP-PPA-ricotz-docky,a=bionic,n=bionic,l=Docky/Plank Testing PPA,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/ricotz/docky/ubuntu bionic/main amd64 Packages
     release v=18.04,o=LP-PPA-ricotz-docky,a=bionic,n=bionic,l=Docky/Plank Testing PPA,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://apt.postgresql.org/pub/repos/apt bionic-pgdg/main i386 Packages
     release o=apt.postgresql.org,a=bionic-pgdg,n=bionic-pgdg,l=PostgreSQL for Debian/Ubuntu repository,c=main,b=i386
     origin apt.postgresql.org
 500 http://apt.postgresql.org/pub/repos/apt bionic-pgdg/main amd64 Packages
     release o=apt.postgresql.org,a=bionic-pgdg,n=bionic-pgdg,l=PostgreSQL for Debian/Ubuntu repository,c=main,b=amd64
     origin apt.postgresql.org
 500 https://deb.opera.com/opera-stable stable/non-free i386 Packages
     release o=Opera Software AS,a=stable,n=stable,l=The Opera web browser,c=non-free,b=i386
     origin deb.opera.com
 500 https://deb.opera.com/opera-stable stable/non-free amd64 Packages
     release o=Opera Software AS,a=stable,n=stable,l=The Opera web browser,c=non-free,b=amd64
     origin deb.opera.com
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic/main i386 Packages
     release v=18.04,o=LP-PPA-gezakovacs,a=bionic,n=bionic,l=UNetbootin PPA,c=main,b=i386
     origin ppa.launchpad.net
 500 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic/main amd64 Packages
     release v=18.04,o=LP-PPA-gezakovacs,a=bionic,n=bionic,l=UNetbootin PPA,c=main,b=amd64
     origin ppa.launchpad.net
 500 http://archive.ubuntu.com/ubuntu bionic/main i386 Packages
     release v=18.04,o=Ubuntu,a=bionic,n=bionic,l=Ubuntu,c=main,b=i386
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
     release v=18.04,o=Ubuntu,a=bionic,n=bionic,l=Ubuntu,c=main,b=amd64
     origin archive.ubuntu.com
Przypięte pakiety:

apt list --upgradable
Lista... Gotowe

panas@Panas:~$ python --version
Python 2.7.15rc1
panas@Panas:~$ python3 --version
Python 3.6.7
« Ostatnia zmiana: 2019-01-28, 19:54:50 wysłana przez Panas »

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 294
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #5 dnia: 2019-01-28, 20:10:44 »
No i już z tego powodu mogą być problemy, pokaż wynik - jako root:
apt-get update && apt-get -s dist-upgrade

Pokaż listę repozytoriów głównych:
cat /etc/apt/sources.list
marcin82

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #6 dnia: 2019-01-28, 21:21:40 »
Problemy z powodu rzadszych dist-upgrade? Raz na miesiąc czy dwa robię.


Cytuj
panas@Panas:~$ sudo su
[sudo] hasło użytkownika panas:
root@Panas:/home/panas# apt-get update && apt-get -s dist-upgrade
Ign.:1 http://dl.google.com/linux/chrome/deb stable InRelease
Stary:2 http://archive.ubuntu.com/ubuntu bionic InRelease                                                                                           
Stary:3 http://packages.microsoft.com/repos/vscode stable InRelease                                                                                 
Stary:4 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic InRelease                                                                             
Stary:5 http://dl.google.com/linux/chrome/deb stable Release                                                                                         
Stary:6 https://deb.opera.com/opera-stable stable InRelease                                                                                         
Stary:7 http://ppa.launchpad.net/ricotz/docky/ubuntu bionic InRelease                                                                   
Stary:8 http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic InRelease                                                                     
Stary:9 http://repo.steampowered.com/steam precise InRelease                                                                                         
Stary:11 http://apt.postgresql.org/pub/repos/apt bionic-pgdg InRelease                                                             
Stary:12 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease             
Czytanie list pakietów... Gotowe                           
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
root@Panas:/home/panas# cat /etc/ap
apache2/        apg.conf        apm/            apparmor/       apparmor.d/     apport/         appstream.conf  apt/           
root@Panas:/home/panas# cat /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu bionic main



root@Panas:/home/panas#

« Ostatnia zmiana: 2019-01-28, 21:23:28 wysłana przez Panas »

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 294
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #7 dnia: 2019-01-28, 21:34:31 »
No to chłopie - masz niepełne repozytoria w ogóle...

Podmień sources.list na taki:
deb http://pl.archive.ubuntu.com/ubuntu/ bionic main restricted universe multiverse 
deb http://pl.archive.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
deb http://pl.archive.ubuntu.com/ubuntu/ bionic-updates main restricted universe multiverse
deb http://pl.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

Co masz w /etc/apt/sources.list.d?
cat /etc/apt/sources.list.d/*


EDYCJA:
Jak zmienisz sources.list to zaktualizuj system przez pełne dist-upgrade. Potem instaluj pgadmin4.
« Ostatnia zmiana: 2019-01-28, 21:37:51 wysłana przez marcin'82 »
marcin82

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #8 dnia: 2019-01-28, 21:59:44 »
Maina ostatnio przywracałem bo coś siadło i nawet tego nie zauważyłem
https://forum.linux.pl/index.php/topic,25475.msg136869.html?PHPSESSID=jp67ad525falv90avuno576983#msg136869

W sources.list.save też podmieniać?
ps. pgadmin4 działa, dziękuję bardzo za pomoc no i za kolejna porcję wiedzy.

root@Panas:/home/panas# cat /etc/apt/sources.list.d/*
deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
# deb-src http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
# deb-src http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
deb http://apt.postgresql.org/pub/repos/apt/ bionic-pgdg main
deb http://apt.postgresql.org/pub/repos/apt/ bionic-pgdg main
deb http://ppa.launchpad.net/ricotz/docky/ubuntu bionic main
# deb-src http://ppa.launchpad.net/ricotz/docky/ubuntu bionic main
deb http://ppa.launchpad.net/ricotz/docky/ubuntu bionic main
# deb-src http://ppa.launchpad.net/ricotz/docky/ubuntu bionic main
deb http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic main
# deb-src http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic main
# deb-src http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic main
deb http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic main
# deb-src http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic main
# deb-src http://ppa.launchpad.net/serge-rider/dbeaver-ce/ubuntu bionic main
deb [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
deb-src [arch=amd64,i386] http://repo.steampowered.com/steam/ precise steam
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://packages.microsoft.com/repos/vscode stable main
deb http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
deb http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
« Ostatnia zmiana: 2019-01-28, 22:07:08 wysłana przez Panas »

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 294
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #9 dnia: 2019-01-28, 22:04:08 »
W /etc/apt/sources.list.d/jakaś_nazwa masz ZEWNĘTRZNE repozytoria PPA. Jeśli chcesz możesz sprawdzić jakie działy udostępniają. Jeśli dodawałeś je ze strony PPA czy jakiegoś poradnika to na ogół jest poprawne to co jest. Zostaw.

Teraz doprowadź system do porządku, bo z upływem czasu coraz więcej rzeczy będzie brakować, albo będą "w Incoming".
marcin82

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #10 dnia: 2019-01-28, 22:21:03 »
Właśnie będę robić reboot po pobraniu aktualizacji

 sources.list.save zostawić z tym co było czy też tam wstawić to co podałeś?

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 294
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #11 dnia: 2019-01-28, 22:23:21 »
Plik sources.list.save przenieś w bezpieczne miejsce. Niech go tam nie będzie po prostu :D
marcin82

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #12 dnia: 2019-01-28, 22:29:01 »
Dobra, teraz czuję się jak w przedszkolu a jak nie w przedszkolu to jak na pierwszych lekcjach
Czemu powinienem przenieść o z domyślnej lokalizacji.
Myślałem że to buckup czy też to co ma sie wykonywać domyślnie w momencie gdy source.list zawiedzie
(No i tutaj logika podpowiada że repo w środku też powinienem podmienić)

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 294
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #13 dnia: 2019-01-28, 22:30:56 »
Utworzy się nowy - sam automatycznie. Jak chcesz to zostaw.
marcin82

Offline Panas

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 132
    • Zobacz profil
Odp: pgadmin4 ubuntu 18.04
« Odpowiedź #14 dnia: 2019-01-29, 13:16:26 »
Teraz  to nawet i mssql zaskoczył więc jestem szczęśliwy