Nowe posty

xx KDE Wallet (5)
Dzisiaj o 20:15:28
xx MacOS vs Linux (17)
Wczoraj o 21:20:08
xx [rozwiązane] Jak zainstalować Firefox'a 66 w Mint'cie 19.1? (15)
Wczoraj o 19:24:47
xx Dziwne zachowanie Firefoxa 65.0.1 (8)
Wczoraj o 11:49:13
xx Gdzie jest link do MOJE POSTY? (2)
Wczoraj o 07:34:45
xx HUMBLE BOOK BUNDLE: LINUX BY WILEY (0)
Wczoraj o 07:24:44
xx [ Gra Za Darmo on-line ] Albion Online (1)
Wczoraj o 07:21:33
xx Mint 19.1 - jest na wpół po polsku i angielsku, no szlag... (5)
2019-03-20, 10:49:16
xx brak uprawnień przy pobieraniu (3)
2019-03-20, 02:57:12
xx Reklamy (2)
2019-03-19, 14:58:34

Autor Wątek: apt-get  (Przeczytany 477 razy)

Offline ciepi

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
apt-get
« dnia: 2019-01-06, 00:38:27 »
witam mam linuxa ubuntu (serwerowy) a problemem jest nie mogę nic pobierać  błąd brzmi np"E:Nie udało się odnaleźć pakietu java"

Offline arecki

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 38
    • Zobacz profil
Odp: apt-get
« Odpowiedź #1 dnia: 2019-01-06, 07:46:33 »
Widać nie ma go w repozytoriach.
Najlepiej jak je pokażesz i opiszesz co takiego chcesz zrobić lub do czego Ci potrzebna Java.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2480
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: apt-get
« Odpowiedź #2 dnia: 2019-01-06, 10:43:41 »
Bo java nie nazywa się java (zbyt szerokie znaczenie).

Jak chcesz tylko JRE (czyli chcesz uruchamiać aplikacje w Javie, ale nie je pisać), to pakiet nazywa się default-jre.
Jak chcesz pełne JDK (czyli chcesz też kompilować aplikacje w Javie), to pakiet nazywa się default-jdk.

Jeżeli nie pasuje ci open-JDK bazujący na wersji IBM-a i koniecznie chcesz Javę od Oracle'a, to zainstaluj PPS LinuxUprising

sudo add-apt-repository ppa:linuxuprising/java
sudo apt update
sudo apt install oracle-java11-set-default

Jeżeli chcesz Javę 8 (bo najnowsze javy są tak zajebiście przenośne, że starsze aplikację często źle działają na nowym JDK):
sudo add-apt-repository ppa:webupd8team/java
sudo apt update
sudo apt install oracle-java8-set-default

Możesz mieć zainstalowane obie wersje pakietami oracle-java8-installer i oracle-java11-installer, ale tylko jedna może być domyślna pakietem *-set-default.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline ciepi

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Odp: apt-get
« Odpowiedź #3 dnia: 2019-01-06, 14:40:27 »
Dziękuje działa jeszcze mam jeden problem a teraz ze sterownikami karty wifi i nie wiem jak pobrac model to: Atheros AR5007EG

Offline arecki

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 38
    • Zobacz profil
Odp: apt-get
« Odpowiedź #4 dnia: 2019-01-06, 18:19:33 »
lspci -k

Offline parana

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 29
    • Zobacz profil
Odp: apt-get
« Odpowiedź #5 dnia: 2019-01-06, 18:44:24 »
Dziękuje działa jeszcze mam jeden problem a teraz ze sterownikami karty wifi i nie wiem jak pobrac model to: Atheros AR5007EG

wpisz:
sudo apt-cache search atheros

i dowiesz się czy jest pakiet fireware-atheros

pisałem już o tym na tym forum: https://forum.linux.pl/index.php/topic,25419.msg136589.html#msg136589
ASRock A320M-HDV 3.0, ASRock TPM2-S, Athlon 200GE, 2X4GB 2400MHz Ballistix Sport LT, SSD Silicon Power A55 256GB, Be quiet! B9 350W.

Offline ciepi

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Odp: apt-get
« Odpowiedź #6 dnia: 2019-01-06, 19:51:30 »
pisze "Sorry try again." musi byc internet?
« Ostatnia zmiana: 2019-01-06, 19:56:35 wysłana przez ciepi »

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 283
    • Zobacz profil
Odp: apt-get
« Odpowiedź #7 dnia: 2019-01-09, 19:41:57 »
Musi być internet do odświeżenia indeksów repozytoriów przez program apt. Możesz podłączyć się do routera za pomocą kabla? I dopiero sprawdzaj te komendy co podał parana.

dpkg -l | grep atheros
marcin82