Oprogramowanie > Programy graficzne

Jak zainstalować GIMPa?

<< < (2/4) > >>

pavbaranov:

--- Cytat: Zdzisław Knop w 2018-09-03, 22:39:46 ---Co robie źle?

--- Koniec cytatu ---
Wszystko i to od samego początku, włącznie nawet z precyzją pisania tytułów wątków, które zakładasz.
W tym przypadku:
- z innych wątków wynika, że wybrałeś sobie Debiana Stable, czyli obecnie 9; to taka dystrybucja, która co do zasady nie oferuje w ogóle nowszych wersji oprogramowania w stosunku do tych, z którymi się ukazała; jeśli nie ma dla niego wersji w repozytorium backports, to poprostu takiej nie ma,
- w przypadku GIMPa 2.10 i Debiana 9 to... instalacja wersji np. z Ubuntu 18.04 z PPA (dla Ubuntu!) zwykle kończyła się destabilizacją systemu (jeśli została wymuszona), albo po prostu nie udało jej się przeprowadzić - wystarczy zadać pytanie w wyszukiwarce.
Ergo - jeśli musisz mieć GIMPa 2.10 w Debian 9, to masz do wyboru:
- flatpak,
- snap,
- appimage.
Wszystkie w podanym wyżej przez @Paweł Kraszewski linku.
Nie wiem, skąd Ci przyszło w ogóle do głowy dodawanie do Debiana repozytorium dla Ubuntu w dodatku dla wersji zbudowanych na nowszych paczkach niż te,  które są w Debian 9. Wystarczy kliknąć w link do PPA by się o tym przekonać.

Co do reszty całej. Chyba najwyższy czas zacząć czytać albo wiki swej dystrybucji, albo kupić książkę o podstawach używania Debiana.

prezes.cc:
Wszystko to nawyki z Windowsa i Linuksa Mint. Tak zrobie - kupie porządną książke, skoro wszystko robie źle. I tak sukces, że siedze na Debianie pół dnia a nie na Windowsie. Rezygnuje z GIMPa 2.10, pozostaje przy domyślnym 2.8. Temat do zamknięcia.

pavbaranov:
Nie musisz rezygnować wcale. Ba, możesz je mieć oba nawet i nie będą ze sobą kolidować. Ściągnij appimage ze strony podanej przez Pawła do dowolnego katalogu (ja mam dodatkowy katalog w ~/, który jest w PATH i tam trzymam binarki, które lokalnie chcę używać), nadaj plikowi uprawnienia do wykonywania (jeśli nie wiesz jak, to w konsoli polecenie chmod +x nazwa_paczki_appimage) i pierwszy raz musisz go uruchomić z konsoli. Paczka AppImage, jeśli została zrobiona prawidłowo, winna być kompatybilna z każdym linuksem co najmniej mającym oprogramowanie w wersji takiej jak w Ubuntu 14.04. Z informacji z innych stron wynika, że ten appimage GIMPa działał na Mint 17 (a zatem na Ubuntu 16.04) - stąd można liczyć, że na Debianie 9 również będzie. Jeśli nie - po prostu skasujesz plik.

PS: Nawet nie musisz kupować książki - jest wszak oficjalny podręcznik Debiana.

prezes.cc:
Za długo walczyłem z instalacją, że jestem zmęczony swoją nieporadnością. Jutro na świeżo to przeczytam. Znalazłem Podręcznik Administratora Debiana 8 - troche cegła ale myśle, że dam rade.

//Edit
Ide na Windowsa troche pograć - musze się odstresować

prezes.cc:
Coraz bardziej zastanawiam się nad powrotem na Minta. Prosty system, wszystko pod ręką, a ja spróbowałem Debiana i mi nie spasował. Posiedze jeszcze na Debianie i zobacze co z tego wyjdzie. Odnośnie Linuksa to jestem n00bem i to wychodzi na każdym kroku.

Nawigacja

[0] Indeks wiadomości

[#] Następna strona

[*] Poprzednia strona

Idź do wersji pełnej