Nowe posty

Autor Wątek: Problem z instalacją nvidia 396.54  (Przeczytany 858 razy)

Offline Panas

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
Problem z instalacją nvidia 396.54
« dnia: 2018-08-22, 03:45:28 »
Mam problem z instalacją sterwników do kary  gefore 740m, karta jest dalej wpierana.
instalacja przez ppa czy z pliku kończy się failem niestety i nie wiem jak  zainstalować najnowsze sterowniki.

https://www.nvidia.com/Download/driverResults.aspx/137211/en-us

sudo apt install nvidia-driver-396
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 nvidia-driver-396 : Wymaga: libnvidia-gl-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: nvidia-dkms-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-compute-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: nvidia-compute-utils-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-decode-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-encode-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: nvidia-utils-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Wymaga: libnvidia-ifr1-396 (= 396.51-0ubuntu0~gpu18.04.1) ale nie zostanie zainstalowany
                     Poleca: libnvidia-compute-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-decode-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-encode-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-ifr1-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
                     Poleca: libnvidia-gl-396:i386 (= 396.51-0ubuntu0~gpu18.04.1)
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2025
  • 1709
    • Zobacz profil
Odp: Problem z instalacją nvidia 396.54
« Odpowiedź #1 dnia: 2018-08-22, 13:17:40 »
Moze jest nowsza wersja, sprawdz najpierw jakie sa dostepne wersje
apt-cache search nvidia-driver
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Panas

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
Odp: Problem z instalacją nvidia 396.54
« Odpowiedź #2 dnia: 2018-08-22, 14:54:44 »
Mam taki dysonans ponieważ tutaj mam zalecaną instalację 396.54
https://github.com/ValveSoftware/Proton/blob/proton_3.7/PREREQS.md
Na stronie znalazłem stery 396.54
https://www.nvidia.com/Download/driverResults.aspx/137211/en-us
ale w tej rubryce najnowsze to 396.18 (beta)
https://www.geforce.com/drivers

Palić się z tym nie pali aby aktualizację zrobić ale ciekawość  mnie zżera jak jasna ...



nvidia-340 - NVIDIA binary driver - version 340.106
nvidia-384 - Transitional package for nvidia-driver-390
nvidia-384-dev - Transitional package for nvidia-driver-390
nvidia-driver-390 - NVIDIA driver metapackage
nvidia-headless-390 - NVIDIA headless metapackage
nvidia-headless-no-dkms-390 - NVIDIA headless metapackage - no DKMS
xserver-xorg-video-nvidia-390 - NVIDIA binary Xorg driver

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2025
  • 1709
    • Zobacz profil
Odp: Problem z instalacją nvidia 396.54
« Odpowiedź #3 dnia: 2018-08-22, 16:03:42 »
1. Zobacz najpierw ( bo nie wiem jakiej dystrybucji uzywasz )
czy masz u siebie w menu lub ustawieniach taki lub inny menadzer do sterowników ?
https://www.youtube.com/watch?v=xOB5g9R_mi8

On automatycznie wykryje jaki sterownik możesz zainstalować
i bedziesz mógł z niego zainstalować może tylko 2 kliknięciami.

2. Nie instaluj sterowników ze strony Nvidia jeśli nie musisz.
To może zrobić bałagan w systemie,
( mam na mysli że menadzer pakietów tego nie wykryje bo instalowane z .run, mam namysli nie kompatybilnosc z dkms )
  lepszą alternatywą jest z menadzera pakietów.
Tylko że używając menadzera pakietów trzeba ręcznie wybrać wersje sterownika do karty graficznej,
 jeśli wersja nie będzie kompatybilna, to po restarcie system nie wstanie ( bedzie czarny ekran ).
Dlatego poradzilem ten menadzer w pierwszym punkcie.


Edytowane:
Tylko Ciekawostka:
W Steam  --> Ustawienia --> Konto i jak wybierzesz opcje "Udział w testach Beta "
to zaktualizuje się Steam i w Ustawieniach pojawi się nowa opcja "Steam Play"
i tam mozesz zaznaczyć używanie "Proton"

EDYTOWANE
Link do Steam o Protonie.
https://steamcommunity.com/games/221410/announcements/detail/1696055855739350561
« Ostatnia zmiana: 2018-08-23, 01:05:27 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline pavbaranov

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 214
    • Zobacz profil
Odp: Problem z instalacją nvidia 396.54
« Odpowiedź #4 dnia: 2018-08-22, 18:01:38 »
@1709 - System @Panas to Ubuntu 18.04

@Panas - Ciekawostka przyrodnicza. W Archu, gdzie stosunkowo szybko trafiają nowe wersje programów, czy sterowników, nvidia 396 występuje w wersji 396.51, jest oflagowana i jak na razie nie trafia nowsza wersja nawet do repozytorium testowego. W przypadku Ubuntu instalacja sterowników bezpośrednio z binarki NVidii może (choć nie musi) wysypać cały system (np. czarny ekran, brak możliwości uruchomienia sesji graficznej itp. itd.). Jak nie wiesz jak sobie z taką, możliwą sytuacją poradzić, to... zostaw.
Dużo bezpieczniejsze bywa instalowanie z jakiegoś PPA, do którego ma się zaufanie. Z podanego przez Ciebie wyniku próby aktualizacji wynika, że instalację wstrzymują inne biblioteki, które są w zbyt "starych" wersjach, jak na potrzeby co  sterownika. Jeśli nie znajdziesz jakiegoś PPA, które oferuje kompleksowo wszystkie niezbędne paczki, o którym ktoś twierdzi, że to przetestował (a nie tylko zbudował), to pozostaw jak jest. Masz przynajmniej działający system.

Offline Panas

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
Odp: Problem z instalacją nvidia 396.54
« Odpowiedź #5 dnia: 2018-08-23, 08:45:43 »
Nie wiedziałem o tym, w przyszłości będę takie próby robił na innym systemie.