Nowe posty

Autor Wątek: Problem z dźwiękiem  (Przeczytany 649 razy)

Offline Zdzisław Knop

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 375
    • Zobacz profil
Problem z dźwiękiem
« dnia: 2018-07-10, 14:38:38 »
Dźwięk muszę regulować potencjometrem w głośniku, bo raz jest bardzo cicho, drugi raz jest głośniej. Dźwięk systemowy mam ustawiony na maksymalny. Jeśli chodzi o Debiana to jestem początkujący, po przesiadce z Minta.

//Edit
Zapomniałem dodać, że Debian 9 postawiony jest na wirtualnej maszynie
« Ostatnia zmiana: 2018-07-10, 14:52:18 wysłana przez Zdzisław Knop »
Windows for playing - Linux for programming - Hobby: Haiku OS

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2153
  • 1709
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #1 dnia: 2018-07-10, 15:09:59 »
1. Dźwięk systemowy w jakim srodowisku graficznym ?
Bo nie wiem o jaka nazwę aplikacji sie rozchodzi.

2. " raz jest bardzo cicho, drugi raz jest głośniej "
W jakich odstępach czasu ?
Przy uruchomieniu systemu głośność jest inna ?
Czy w czasie używania systemu ?

3. Debugowanie problemu.
- Mozesz sprawdzic czy masz aktualny system ?
- Czy robiles juz jakies aktualizacje ? Jesli tak, to mozesz sprawdzic czy problem występuje na nowym koncie użytkownika ?
- Możesz zajzec do logów za błędami ?
- Mozesz stworzyc log pulseaudio ?
Korzystasz z pulse audio ? Nic nie zmieniałeś na Alse ?
Tu masz trochę taki poradnik jak zabić pulse audio i uruchomić
https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Running/
i to mniej więcej pokrywa sie z tym
https://wiki.ubuntu.com/PulseAudio/Log
czyli  dla Ciebie
killall pulseaudio
LANG=C pulseaudio -vvvv --log-time=1 > ~/pulseverbose.log 2>&1
Zabija pulseaudio i tworzy log z tego uruchomienia. Zeby znalesc błędy.
Taki log także w przyszłości mozesz dac developerom aby naprawili sterowniki, jeśli coś by było nie tak.
Po wykonaniu tej komendy, zwlaszcza po zamknieciu terminala moze zniknac dzwiek. On powinien wrocic po zresetowaniu komputera.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Zdzisław Knop

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 375
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #2 dnia: 2018-07-10, 16:05:27 »
Cytuj
1. Dźwięk systemowy w jakim srodowisku graficznym ?
Bo nie wiem o jaka nazwę aplikacji sie rozchodzi.

Środowisko graficzne to MATE
Chodzi o YouTuba

Cytuj
2. " raz jest bardzo cicho, drugi raz jest głośniej "
W jakich odstępach czasu ?
Przy uruchomieniu systemu głośność jest inna ?
Czy w czasie używania systemu ?

W różnych odstępach.
Przy uruchomieniu systemu głośności nie ma.
W czasie używania systemu też nie ma.

Cytuj
Mozesz sprawdzic czy masz aktualny system ?
- Czy robiles juz jakies aktualizacje ? Jesli tak, to mozesz sprawdzic czy problem występuje na nowym koncie użytkownika ?

System aktualny, nie robiłem żadnych aktualizacji. Na nowym użytkowniku sprawdze

Cytuj
Możesz zajzec do logów za błędami ?
- Mozesz stworzyc log pulseaudio ?

Tego nie potrafie zrobić

Cytuj
Korzystasz z pulse audio ? Nic nie zmieniałeś na Alse ?
Nie wiem. Wczoraj pobrałem system i dopiero go sprawdzam

Cytuj
Tu masz trochę taki poradnik jak zabić pulse audio i uruchomić

Przejrze je

Cytuj
killall pulseaudio
LANG=C pulseaudio -vvvv --log-time=1 > ~/pulseverbose.log 2>&1

Gdzie zapisuje się log - w katalogu domowym?
Windows for playing - Linux for programming - Hobby: Haiku OS

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2153
  • 1709
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #3 dnia: 2018-07-10, 16:33:12 »
Gdzie zapisuje się log - w katalogu domowym?
"~/ " to jest skrucona sciezka do katalogu domowego (uzytkownika),
czyli plik pulseverbose.log bedzie np.
 /home/twoja_nazwa_uzytkownika/pulseverbose.log
« Ostatnia zmiana: 2018-07-10, 16:36:19 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Zdzisław Knop

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 375
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #4 dnia: 2018-07-10, 19:53:25 »
Pojawia mi się coś takiego

Cytuj
piotr@prezes:/root$ killall pulseaudio
pulseaudio: nie znaleziono żadnego procesu
Windows for playing - Linux for programming - Hobby: Haiku OS

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2153
  • 1709
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #5 dnia: 2018-07-10, 20:31:40 »
No to nie zabijesz procesu, bo pulseaudio nie dziala.
A co z następną komenda ? Jest log ?
« Ostatnia zmiana: 2018-07-10, 20:40:09 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Zdzisław Knop

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 375
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #6 dnia: 2018-07-10, 22:00:53 »
Jest log

Cytuj
(   0.000|   0.000) I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
(   0.000|   0.000) I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
(   0.000|   0.000) D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
(   0.079|   0.079) D: [pulseaudio] core-util.c: RealtimeKit worked.
(   0.079|   0.000) I: [pulseaudio] core-util.c: Successfully gained nice level -11.
(   0.079|   0.000) I: [pulseaudio] main.c: This is PulseAudio 10.0
(   0.079|   0.000) D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
(   0.079|   0.000) D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fdebug-prefix-map=/build/pulseaudio-ZMrhzG/pulseaudio-10.0=. -fstack-protector-strong -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
(   0.079|   0.000) D: [pulseaudio] main.c: Running on host: Linux x86_64 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07)
(   0.079|   0.000) D: [pulseaudio] main.c: Found 1 CPUs.
(   0.079|   0.000) I: [pulseaudio] main.c: Page size is 4096 bytes
(   0.079|   0.000) D: [pulseaudio] main.c: Compiled with Valgrind support: no
(   0.079|   0.000) D: [pulseaudio] main.c: Running in valgrind mode: no
(   0.079|   0.000) D: [pulseaudio] main.c: Running in VM: yes
(   0.079|   0.000) D: [pulseaudio] main.c: Optimized build: yes
(   0.079|   0.000) D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
(   0.079|   0.000) I: [pulseaudio] main.c: Machine ID is bda0d7c3c0a5475681d38426b73b904b.
(   0.079|   0.000) I: [pulseaudio] main.c: Session ID is 2.
(   0.079|   0.000) E: [pulseaudio] core-util.c: XDG_RUNTIME_DIR (/run/user/0) is not owned by us (uid 1000), but by uid 0! (This could e g happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
Windows for playing - Linux for programming - Hobby: Haiku OS

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2153
  • 1709
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #7 dnia: 2018-07-10, 22:48:34 »
Cytuj
//Edit
Zapomniałem dodać, że Debian 9 postawiony jest na wirtualnej maszynie
A na systemie na ktorym jest ta maszyna wirtualna problemow z dzwiekiem nie ma ?

Podczas tworzenia logu napewno robiles to z konta zwyklego uzytkownika ?
Poniewaz na koncu wyskoczyl blad odnosnie root.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Zdzisław Knop

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 375
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #8 dnia: 2018-07-11, 08:25:34 »
Cytuj
A na systemie na ktorym jest ta maszyna wirtualna problemow z dzwiekiem nie ma ?

Dźwięk  jest normalnie. Maszyna stoi na Windows 10

Jak robie z konta zwykłego użytkownika to wyskakuje błąd:

Cytuj
piotr@prezes:~$ gedit pulseverbose.log
No protocol specified
Unable to init server: Nie można połączyć: Połączenie odrzucone

(gedit:3806): Gtk-WARNING **: cannot open display: :0
Windows for playing - Linux for programming - Hobby: Haiku OS

Offline pavbaranov

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 317
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #9 dnia: 2018-07-11, 10:52:49 »
Chodzi o YouTuba
Na tym samym materiale, czy na różnych? Pochodzą z tego samego, czy z różnych źródeł? Problem występuje również w innych przypadkach? Problem pojawia się w ramach tego samego materiału? Dwa razy odtwarzany ten sam materiał ma ten sam, czy różny poziom dźwięku przy tych samych ustawieniach potencjometrów?
Poziom dźwięku w filmikach (także w materiale wyłącznie audio) na YT bywa bardzo różny, zatem jeśli niczego nam więcej nie opowiesz, nie podasz przykładów, abyśmy mogli sprawdzić na innych systemach, to należałoby ogólnie stwierdzić: "ten system tak ma" ;), czyli zjawisko jak najbardziej normalne.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2153
  • 1709
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #10 dnia: 2018-07-11, 11:42:52 »
Do otwarcia z pliku skorzystaj z cat
https://www.youtube.com/watch?v=sHiK8ZPXs1A
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Zdzisław Knop

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 375
    • Zobacz profil
Odp: Problem z dźwiękiem
« Odpowiedź #11 dnia: 2018-07-11, 15:25:17 »
Dzięki za Wasze zaangażowanie, ale problem się rozwiązał. Po prostu suwak głośnika systemowego był na samym dole, ale ja wcześniej sprawdzałem ten głośnik i nie działało. Nie wiem dlaczego. Puszczałem jedną piosenke i było bardzo cicho, natomiast na innej był dźwięk ale głośniejszy. Bywało tak, że na jednej piosence dźwięk był raz głosniejszy raz cichszy. Teraz wszystko jest w porządku, dla pewności posprawdzałem kilka razy. Troche nierozumie takiego rozwiązania, ale ważne że działa.
Windows for playing - Linux for programming - Hobby: Haiku OS